Bug 220739 - pbmtog3 seg faults
pbmtog3 seg faults
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-25 04:54 EST by Steve Underwood
Modified: 2013-07-02 19:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: 10.35.32-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 10:05:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A sample PBM file (501.20 KB, image/x-portable-bitmap)
2006-12-25 05:34 EST, Steve Underwood
no flags Details

  None (edit)
Description Steve Underwood 2006-12-25 04:54:16 EST
Description of problem:

The pbmtog3 program in RPM netpbm-progs-10.35-6.fc6 for x86_64 seg faults with
almost any PBM image file I try. The version from the RPM for FC4 x86_64 works
OK. The one in netpbm-progs-10.35-6.fc6 for i386 works OK. It seems to be a 64
bit specific fault introduced in recent versions.
Comment 1 Jindrich Novy 2006-12-25 05:00:24 EST
Could you please attach a testing pbm image here?
Comment 2 Steve Underwood 2006-12-25 05:34:48 EST
Created attachment 144350 [details]
A sample PBM file

Any old PBM FAX will cause the problem, which is why I didn't attach a test
case. Still, here is an arbitrary PBM FAX file, and like every other PBM FAX
file, it causes FC6's pbmtog3 for x86_64 to segfault.
Comment 3 Jindrich Novy 2006-12-28 06:00:46 EST
The algorithm used in the pbmtog3 is broken and needs to be fixed upstream. It
works just fine in case that the sizeof(wordint) == 4, but fails on any 64bit
platform because sizeof(wordint) == 8. The segfault is caused by index
underflow, where pbmtog3 tries to index milepost[n-1] even though n is zero...
This needs to be fixed upstream as well.

I added a fix for segfault for now, another fix will be needed to make pbmtog3
actually work on 64bit arches to produce sane output...
Comment 4 Jindrich Novy 2007-10-18 10:08:39 EDT
It's fixed in 10.35.32. Update is comming soon.
Comment 5 Fedora Update System 2007-10-24 03:15:48 EDT
netpbm-10.35.32-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netpbm'
Comment 6 Fedora Update System 2007-11-05 10:05:13 EST
netpbm-10.35.32-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Ron Askew 2007-11-06 20:29:38 EST
A new bug has been introduced by this change.

          ID  FEDORA-2007-731
        Type  bugfix
      Status  final
      Issued  2007-11-05 09:29:24.63
     Updated  2007-11-05 09:29:24.63
        Bugs  220739  337181 

There is a new conflict with the man pages.
When installing via rmp, the following error message is seen:

[('file /usr/share/man/man1/index.1.gz from install of
netpbm-progs-10.35.32-1.fc6 conflicts with file from package
html-xml-utils-3.7-4.fc6', (7, '/usr/share/man/man1/index.1.gz', 0L))]
Comment 8 Jindrich Novy 2007-11-07 02:50:11 EST
It seems there are more conflicts caused by html-xml-utils:

# yum install html-xml-utils

...

Transaction Check Error:
  file /usr/bin/extract from install of html-xml-utils-3.7-4.fc6 conflicts with
file from package csound-5.03.0-13.fc7
  file /usr/share/man/man1/index.1.gz from install of html-xml-utils-3.7-4.fc6
conflicts with file from package netpbm-progs-10.35.32-1.fc7


I presume the .fc6 prefix reveals that the html-xml-utils was not build for a
long time. We should make the conflicts clear with the html-xml-utils maintainer
first. Not sure it's actually a fault of netpbm.
Comment 9 Ron Askew 2007-11-07 03:14:31 EST
csound has issues with some other packages too.  The csound maintainers have 
work to do.

But the conflict with index is with netpbm because netpbm doesn't have an index 
executable or man page. html-xml-utils owns the index command.
Comment 10 Jindrich Novy 2007-11-07 04:21:00 EST
Ok, I removed man pages from the latest netpbm-progs that lacks the
corresponding binaries in rawhide.
Comment 11 Michael Schwendt 2007-11-07 06:55:51 EST
html-xml-utils conflicts are known for a long time: bug 208781
Comment 12 Fedora Update System 2007-11-17 00:35:50 EST
netpbm-10.35.32-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Ron Askew 2007-11-17 06:36:08 EST
Can the fix be published to the f6 trees as well?
Comment 14 Jindrich Novy 2007-11-17 09:33:15 EST
Ron, the update to netpbm-10.35.32-1.fc6 submitted on 2007-10-18 is in the
queue. I'm not of the exact time when it will be pushed.
Comment 15 Steve Underwood 2007-12-17 06:06:39 EST
I now have x86_64 FC8 installed, with netpbm-10.35.32-2  The update to that
revision, by yum, was odd, as it left the previous netpbm-10.35-17 RPMs on my
machine. I've removed those, and cleaned up, and I'm sure I am now using
netpbm-10.35.32-2.

When I try the original test, pbmtog3 no longer seg faults. It seems to get
stuck in an endless loop, producing output forever. The test file I originally
posted displays this problem. x86_64 still looks pretty broken.

Note You need to log in before you can comment on or make changes to this bug.