Bug 208781 - html-xml-utils conflicts with five other packages
html-xml-utils conflicts with five other packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: html-xml-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
: Reopened
: 248685 (view as bug list)
Depends On:
Blocks: 208780 210215 FE7Target 222047
  Show dependency treegraph
 
Reported: 2006-10-01 19:19 EDT by Michael Schwendt
Modified: 2008-11-21 14:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 14:19:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2006-10-01 19:19:24 EDT
The packages conflict with other packages in either Extras or Core. Details following in next comment.
Comment 1 Michael Schwendt 2006-10-01 19:30:13 EDT
html-xml-utils-3.7-3.fc5.i386.rpm
  File conflict with: /usr/bin/count
  File conflict with: /usr/share/man/man1/count.1.gz
  => Package conflicts with: fish - 1.21.12-0.fc5.i386

Comment 2 Michael Schwendt 2006-10-10 16:05:43 EDT
devel:

html-xml-utils - 3.7-4.fc6.i386
  File conflict with: /usr/share/man/man1/count.1.gz
  File conflict with: /usr/bin/count
  File conflict with: /usr/bin/extract
  => Package conflicts with: fish - 1.21.12-1.fc6.i386
  => Package conflicts with: csound - 5.03.0-3.fc6.i386
Comment 3 Michael Schwendt 2006-10-12 04:11:07 EDT
normalize - 0.7.7-2.lvn6.i386
  File conflict with: /usr/share/man/man1/normalize.1.gz
  File conflict with: /usr/bin/normalize
  => Package conflicts with: html-xml-utils - 3.7-4.fc6.i386
Comment 4 John Guthrie 2006-11-07 09:20:53 EST
This same error is still occuring in fc6:

Transaction Check Error:   file /usr/bin/count conflicts between attempted
installs of html-xml-utils-3.7-4.fc6 and fish-1.21.12-1.fc6
  file /usr/share/man/man1/count.1.gz conflicts between attempted installs of
html-xml-utils-3.7-4.fc6 and fish-1.21.12-1.fc6
Comment 5 Gavin Henry 2006-11-07 09:53:34 EST
Just trying to find time to sort it.

Gavin.
Comment 6 Gavin Henry 2006-12-05 04:33:35 EST
How do I resolve this again? 
Comment 7 Michael Schwendt 2006-12-05 06:01:27 EST
Well, FESCO needs to tell whether explict RPM "Conflicts: ..." are
permitted in Fedora Extras.

Generally, file names like "count" and "extract" are much too generic
for the /usr/bin namespace. It would be wise if developers used some sort
of prefix to avoid (or reduce the risk of) clashes.
Comment 8 Thorsten Leemhuis 2006-12-05 06:14:23 EST
(In reply to comment #7)
> Well, FESCO needs to tell whether explict RPM "Conflicts: ..." are
> permitted in Fedora Extras.

Well, yes, FESCo or the PC should sort this out. Anyway:

> Generally, file names like "count" and "extract" are much too generic
> for the /usr/bin namespace. It would be wise if developers used some sort
> of prefix to avoid (or reduce the risk of) clashes.

Much agreed. This is an area where Fedora IMHO should not allow Conflicts
(explicit or implicit) (*). This sepcific problem should be fixed in a different
way.

(*) An explicit conflicts for example might be acceptable to prevent that both
postfix and sendmail get installed at the same time (not the best exmple as it
might be possible these days, but it should show what I mean)

Comment 9 Thorsten Leemhuis 2006-12-05 12:29:41 EST
I poked the Packaging Commitee. Draft:
http://fedoraproject.org/wiki/PackagingDrafts/Conflicts
Comment 10 Michael Schwendt 2007-02-03 18:12:31 EST
html-xml-utils - 3.7-4.fc6.i386
  Conflicts: 13
  File conflict in:
     /usr/bin/count
     /usr/bin/extract
     /usr/share/man/man1/count.1.gz
  Packages with the same files:
     fish - 1.21.12-1.fc6.i386
     libextractor - 0.5.17a-1.fc7.i386
     csound - 5.03.0-9.fc7.i386
Comment 11 Thorsten Leemhuis 2007-02-09 13:48:49 EST
We really need to find a solution for the conflicts thing. We still after months
have no ratified rules from the Packaging Committee how to handle conflicts
(latest proposal is at 
http://fedoraproject.org/wiki/PackagingDrafts/Conflicts -- seems there were
enough votes on the mailinglist, but its still in the Drafts section).

And after having those rules and cleaning up the repo we IMHO need a script
running periodically somewhere that checks for implicit and explicit conflicts.

Anyway, I'm not in FESCo anymore and I have enough on my plate already, so I'll
leave that to somebody else.
Comment 12 Michael Schwendt 2007-06-11 11:24:57 EDT
html-xml-utils - 3.7-4.fc6.i386
  File conflict with: csound - 5.03.0-13.fc7.i386
     /usr/bin/extract
  File conflict with: fish - 1.21.12-1.fc6.i386
     /usr/bin/count
     /usr/share/man/man1/count.1.gz
  File conflict with: libextractor - 0.5.17a-1.fc7.i386
     /usr/bin/extract
  File conflict with: surfraw - 1.0.7-3.fc8.noarch
     /usr/bin/cite
Comment 13 Michael Schwendt 2007-07-18 07:01:01 EDT
*** Bug 248685 has been marked as a duplicate of this bug. ***
Comment 14 Michael Schwendt 2007-07-18 07:02:38 EDT
  file /usr/bin/normalize from install of html-xml-utils-3.7-4.fc6 conflicts 
with file from package normalize-0.7.7-2.lvn6
(bug 248685)
Comment 15 Michael Schwendt 2007-07-18 07:04:51 EDT
The conflict with "normalize" has been covered before in comment 3.
Comment 16 John Guthrie 2007-08-19 11:57:31 EDT
(In reply to comment #11)
> We really need to find a solution for the conflicts thing. We still after months
> have no ratified rules from the Packaging Committee how to handle conflicts
> (latest proposal is at 
> http://fedoraproject.org/wiki/PackagingDrafts/Conflicts -- seems there were
> enough votes on the mailinglist, but its still in the Drafts section).

It seems that page has now moved out of the Drafts section:

http://fedoraproject.org/wiki/Packaging/Conflicts

However, the only suggestion that page has for this situation is to convince
upstream to rename their binaries.  Are there any plans or drafts to cover the
case where upstream doesn't rename the binaries?
> 
> And after having those rules and cleaning up the repo we IMHO need a script
> running periodically somewhere that checks for implicit and explicit conflicts.
> 
> Anyway, I'm not in FESCo anymore and I have enough on my plate already, so I'll
> leave that to somebody else.

Comment 17 Tom "spot" Callaway 2007-08-19 16:25:54 EDT
Alternatives?

Prefix the binaries with a "hxu-"?

Suffix the binaries with "-hxu" ?
Comment 18 Doncho N. Gunchev 2007-08-21 21:10:34 EDT
(In reply to comment #17)
> Alternatives?

Alternatives is for alternative packages/binaries. Take a look at 
the "normalize" case - one works with sound and the other with XML - nothing 
in common, right ;-)
Comment 19 John Guthrie 2007-08-23 11:09:28 EDT
(In reply to comment #17)
> Alternatives?
> 
> Prefix the binaries with a "hxu-"?
> 
> Suffix the binaries with "-hxu" ?

Personally, I like the prefix idea the best.  If we want to be *really* pedantic
about it, we would worry about the possibility that someone would contribute a
package named "hxu".  (There do seem to be a fair number of packages whose names
seem to be a random string of three letters. ;-)  I think that the probability
that someone would name a package "hxu" that would also contain a binary named
"normalize" to be extremely low.  If we don't care about this, (or are willing
to deal with it when the situation arises) then I think that prefixing the
binaries with "hxu-" would be a great way to go.

If we do care about this situation, then the obvious solution would be to prefix
the binaries with "html-xml-utils-".  But that's actually kind of cumbersome. 
In that case, might I propose a conflicts-alternatives in reply to comment #18?
 (I know it wouldn't pretty, but I'm not certain what we can do that would be.)
Comment 20 John Guthrie 2007-11-07 14:11:53 EST
For anyone whose still keeping score at this point, I just received the
following error message from yum update:

file /usr/share/man/man1/index.1.gz conflicts between attempted installs of
netpbm-progs-10.35.32-1.fc7 and html-xml-utils-3.7-4.fc6
Comment 21 Jindrich Novy 2008-01-14 05:02:51 EST
I see no more conflicts with html-xml-utils and latest netpbm updates to FC7, F8
as well as in rawhide. Should we close this?
Comment 22 Michael Schwendt 2008-04-03 16:20:13 EDT
> Should we close this?

No, this ticket is not specific to netpbm.
Comment 23 Bug Zapper 2008-05-13 22:23:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 24 John Guthrie 2008-08-29 00:41:25 EDT
FYI, I was just able to update both fish and html-xml-utils to the latest in f9.  So no more conflicts between those two.  I don't have access to an f8 machine, so I can't check that.
Comment 25 petrosyan 2008-10-15 18:06:53 EDT
This bug has been fixed in Fedora 9.
Comment 26 Michael Schwendt 2008-10-15 18:37:56 EDT
Not true. Easy to verify (comment 12) even without special tools:

Transaction Check Error:
  file /usr/bin/cite conflicts between attempted installs of surfraw-1.0.7-3.fc8.noarch and html-xml-utils-3.7-5.fc9.i386

[...]

Also, please fill in your real name in bugzilla.
Comment 27 Michael Schwendt 2008-11-21 14:19:09 EST
Notes for Gavin:

* Upstream has renamed the programs in html-xml-utils >= 5.0
(released in November) to resolve the conflicts.

* There are several releases you've missed: 3.8 to 5.1

* Careful! There's a _licence change_ from GPL to something else.

Note You need to log in before you can comment on or make changes to this bug.