This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 220747 - ICE building mjpegtools
ICE building mjpegtools
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 220978 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-25 13:29 EST by sean
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.1-49
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 08:18:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Preprocessed source stored into /tmp/ccFtgcNI.out (998.04 KB, application/octet-stream)
2006-12-25 13:29 EST, sean
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 29535 None None None Never

  None (edit)
Description sean 2006-12-25 13:29:22 EST
Description of problem:
g++ -DHAVE_CONFIG_H -I. -I.. -I.. -I/usr/include -I../utils   -DNDEBUG
-finline-functions -fno-PIC -march=k8 -O2 -fPIC -funswitch-loops
-ftree-vectorize -fvisibility-inlines-hidden -march=k8 -pipe -mfpmath=sse
-frename-registers -pthread  -MT newdenoise.o -MD -MP -MF .deps/newdenoise.Tpo
-c -o newdenoise.o newdenoise.cc
MotionSearcher.hh: In instantiation of 'MotionSearcher<unsigned char, 1, int,
short int, int, 4, 2, short unsigned int, Pixel<unsigned char, 1, int>,
ReferencePixel<short unsigned int, unsigned char, 1, Pixel<unsigned char, 1,
int> >, ReferenceFrame<ReferencePixel<short unsigned int, unsigned char, 1,
Pixel<unsigned char, 1, int> >, short int, int> >::MatchThrottleFloodFillControl':
MotionSearcher.hh:507:   instantiated from 'MotionSearcher<unsigned char, 1,
int, short int, int, 4, 2, short unsigned int, Pixel<unsigned char, 1, int>,
ReferencePixel<short unsigned int, unsigned char, 1, Pixel<unsigned char, 1,
int> >, ReferenceFrame<ReferencePixel<short unsigned int, unsigned char, 1,
Pixel<unsigned char, 1, int> >, short int, int> >'
newdenoise.cc:33:   instantiated from here
MotionSearcher.hh:2444: internal compiler error: in tsubst, at cp/pt.c:7281

Version-Release number of selected component (if applicable):

gcc-4.1.1-48.x86_64
gcc-c++-4.1.1-48.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sean 2006-12-25 13:29:23 EST
Created attachment 144353 [details]
Preprocessed source stored into /tmp/ccFtgcNI.out
Comment 2 Axel Thimm 2006-12-29 16:22:24 EST
*** Bug 220978 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Jelinek 2007-01-03 08:18:02 EST
Should be fixed in gcc-4.1.1-49 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.