Bug 220978 - ICE: in tsubst, at cp/pt.c:7281
ICE: in tsubst, at cp/pt.c:7281
Status: CLOSED DUPLICATE of bug 220747
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-29 16:14 EST by Axel Thimm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-29 16:22:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compressed preprocessed source to trigger ICE (109.29 KB, application/x-bzip2)
2006-12-29 16:14 EST, Axel Thimm
no flags Details

  None (edit)
Description Axel Thimm 2006-12-29 16:14:24 EST
Description of problem:
$ g++ -c -o newdenoise.o newdenoise-E.cc
MotionSearcher.hh: In instantiation of 'MotionSearcher<unsigned char, 1, int,
short int, int, 4, 2, short unsigned int, Pixel<unsigned char, 1, int>,
ReferencePixel<short unsigned int, unsigned char, 1, Pixel<unsigned char, 1,
int> >, ReferenceFrame<ReferencePixel<short unsigned int, unsigned char, 1,
Pixel<unsigned char, 1, int> >, short int, int> >::MatchThrottleFloodFillControl':
MotionSearcher.hh:507:   instantiated from 'MotionSearcher<unsigned char, 1,
int, short int, int, 4, 2, short unsigned int, Pixel<unsigned char, 1, int>,
ReferencePixel<short unsigned int, unsigned char, 1, Pixel<unsigned char, 1,
int> >, ReferenceFrame<ReferencePixel<short unsigned int, unsigned char, 1,
Pixel<unsigned char, 1, int> >, short int, int> >'
newdenoise.cc:33:   instantiated from here
MotionSearcher.hh:2444: internal compiler error: in tsubst, at cp/pt.c:7281
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccNDAuTh.out file, please attach this to
your bugreport.


Version-Release number of selected component (if applicable):
gcc-4.1.1-48

How reproducible:
always on i386 and x86_64

Steps to Reproduce:
1.g++ -c -o newdenoise.o newdenoise-E.cc
2.
3.
  
Actual results:
See aboce (ICE)

Expected results:
successful compilation

Additional info:
Source builds otherwise on FC6 (4.1.1-30) and before.
Comment 1 Axel Thimm 2006-12-29 16:14:25 EST
Created attachment 144563 [details]
compressed preprocessed source to trigger ICE
Comment 2 Axel Thimm 2006-12-29 16:22:20 EST
Sorry, I missed bug #220747 before :/

*** This bug has been marked as a duplicate of 220747 ***

Note You need to log in before you can comment on or make changes to this bug.