Bug 220778 - sdpd does not come back up after resume from hibernate
sdpd does not come back up after resume from hibernate
Status: CLOSED DUPLICATE of bug 213387
Product: Fedora
Classification: Fedora
Component: bluez-sdp (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Depends On:
  Show dependency treegraph
Reported: 2006-12-26 12:54 EST by Muyi Taiwo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-12 03:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
pop-up error message displayed on resume from hibernate (19.80 KB, image/jpeg)
2006-12-26 12:54 EST, Muyi Taiwo
no flags Details

  None (edit)
Description Muyi Taiwo 2006-12-26 12:54:55 EST
On resuming from hibernate, KbluetoothD (KDE Bluetooth Framework) pops up a
message box with the error "Failed to connect to the SDP server.  Please make
sure that sdpd is running; without it, other devices will not be able to find
out which services your computer offers"

I'm using:

HP Pavillion dv4000 with built-in Bluetooth
kernel 2.6.18-1.2868
bluez-utils 3.7-1
bluez-libs 3.7-1

I also have:
bluez-gnome 0.6-1

Having bluez-gnome is the only way I could get my laptop and phone to pair, by
using bluetooth-applet.  kdebluetooth doesn't seem to have any way for pairing

It's also probably worth mentioning that bluetooth-applet seems to ignore my
settings in /etc/bluetooth/hcid.conf for the computer's name and PIN.  Does
anybody know where it keeps this information?

How reproducible:

Happens every time the computer resumes from hibernate (suspend to disk)

Steps to Reproduce:
1. From normal KDE desktop, close lid.  Laptop goes into hibernate mode
2. Open laptop lid, push power switch to bring laptop into resume mode
3. Laptop resumes, but messagebox with the error pops up
Actual results:

See above.  Also, KDE Bluetooth icon in notification area is unusable.  However,
manually starting sdpd at command line restores normal behaviour

Expected results:

I expect Bluetooth to resume working as it was before going into hibernate.

Additional info:
Comment 1 Muyi Taiwo 2006-12-26 12:54:55 EST
Created attachment 144376 [details]
pop-up error message displayed on resume from hibernate
Comment 2 Muyi Taiwo 2007-01-03 14:19:29 EST
I removed the bluetooth unloading and reloading stuff in
/etc/pm/hooks/49bluetooth as suggested in bug 213387, and this fixed the problem.  

The real bug is probably 213387,and this should be fixed.
Comment 3 Nigel Cunningham 2007-06-12 03:12:05 EDT
Marking as a duplicate of 213387, as per previous comment.

*** This bug has been marked as a duplicate of 213387 ***

Note You need to log in before you can comment on or make changes to this bug.