Bug 220806 - Kernels after 2.6.17-1.2187_FC5 crashes
Kernels after 2.6.17-1.2187_FC5 crashes
Status: CLOSED DUPLICATE of bug 224359
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
:
: 220811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-27 05:45 EST by Lars Bjorndal
Modified: 2014-06-18 03:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 07:15:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Bjorndal 2006-12-27 05:45:09 EST
Description of problem: All kernels after version 2.6.17-1.2187_FC5 get my computer crashing
sooner or later, after reboot with a later kernel version. With
2.6.17-1.2187_FC5, all works fine. The kernels I've tried after this one, is: kernel-2.6.18-1.2239.fc5, kernel-2.6.18-1.2200.fc5 and
kernel-2.6.18-1.2257.fc5, and all of them crashes after some minutes
or hours or after a few days, at least. What I've noticed, is that it may have something to do with the
network. I've three network cards on the system, and I think the
crash problem can has to do with eth2. There are two modules related
to the network cards that are loaded, e100 and 3c59x. I'm not 100%
sure which of them are serving two cards, but I think it is the last
one, 3c59x.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes, the bug occures if I do a 'mount -t cifs //<local-ip>/dir /mnt', to access a Windows share. This IP is on eth2. Sometimes I can do the mount operation without problems

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The computer crashes sooner or later on. I need to cold reboot.

Expected results:


Additional info:
Comment 1 Lars Bjorndal 2006-12-27 06:54:44 EST
What I've noticed, is that it may have something to do with the
network. I've three network cards on the system, and I think the
crash problem can has to do with eth2. There are two modules related
to the network cards that are loaded, e100 and 3c59x. I'm not 100%
sure which of them are serving two cards, but I think it is the last
one, 3c59x.
The crash problem behaves as follows, I'm blind, so I cannot see what's
comming on the screen. I'm only using the text console (no GUI):

- The braille display stop responding (I'm using the screen reader 'BRLTTY'.)
- I hear several beeps with about 1 sec. pause between, which I suppose
  comes from the 10 'screen' sessions in the current console.
- Sometimes I'm able to press Ctrl-Alt-Del to reboot, and after
  that, all hangs. Sometimes I'm not able to do so.
- I allways need to do a hard reboot.

Some background info:
Output from lspci is:

00:00.0 Host bridge: Intel Corporation 915G/P/GV/GL/PL/910GL Processor to I/O
Controller
00:01.0 PCI bridge: Intel Corporation 915G/P/GV/GL/PL/910GL PCI Express Root
Port
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface
Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA
Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 6200
TurboCache(TM) (rev a1)
06:02.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev
64)
06:03.0 Ethernet controller: 3Com Corporation 3c900B-Combo Etherlink XL
[Cyclone] (rev 04)
06:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE
(LOM) Ethernet Controller (rev 01)

Output from lsmod is:
Module                  Size  Used by
cls_u32                12613  1 
sch_tbf                11073  2 
sch_cbq                21825  1 
ipt_LOG                10689  1 
xt_mac                  6209  16 
xt_limit                6977  4 
ip_nat_irc              6849  0 
ip_nat_ftp              7745  0 
ip_conntrack_irc       11057  1 ip_nat_irc
ip_conntrack_ftp       12081  1 ip_nat_ftp
iptable_nat            11845  1 
ip_nat                 22509  3 ip_nat_irc,ip_nat_ftp,iptable_nat
autofs4                25925  1 
hidp                   25025  2 
l2cap                  31937  5 hidp
bluetooth              56869  2 hidp,l2cap
tun                    15681  1 
ipv6                  265057  30 
ip_conntrack_netbios_ns     7233  0 
ipt_REJECT              9665  0 
xt_state                6465  9 
ip_conntrack           57633  8
ip_nat_irc,ip_nat_ftp,ip_conntrack_irc,ip_conntrack_ftp,iptable_nat,ip_nat,ip_conntrack_netbios_ns,xt_state
nfnetlink              11225  2 ip_nat,ip_conntrack
xt_tcpudp               7361  49 
iptable_filter          7233  1 
ip_tables              17669  2 iptable_nat,iptable_filter
x_tables               19269  8
ipt_LOG,xt_mac,xt_limit,iptable_nat,ipt_REJECT,xt_state,xt_tcpudp,ip_tables
acpi_cpufreq           11717  1 
io_edgeport            92361  0 
usbserial              36649  1 io_edgeport
loop                   20297  0 
usblp                  18497  0 
usb_storage            73377  0 
video                  20677  0 
button                 10961  0 
battery                14021  0 
ac                      9157  0 
lp                     17033  0 
parport_pc             31205  1 
parport                41225  2 lp,parport_pc
ehci_hcd               36941  0 
uhci_hcd               28109  0 
floppy                 62789  0 
sg                     38493  0 
snd_hda_intel          22613  0 
snd_hda_codec         141761  1 snd_hda_intel
snd_seq_dummy           8133  0 
snd_seq_oss            37185  0 
serio_raw              11589  0 
snd_seq_midi_event     11841  1 snd_seq_oss
3c59x                  47593  0 
snd_seq                59441  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
e100                   40133  0 
snd_seq_device         13005  3 snd_seq_dummy,snd_seq_oss,snd_seq
mii                     9665  2 3c59x,e100
snd_pcm_oss            43985  0 
snd_mixer_oss          21825  1 snd_pcm_oss
snd_pcm                88005  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
i2c_i801               12749  0 
i2c_core               26305  1 i2c_i801
snd_timer              28613  2 snd_seq,snd_pcm
snd                    59973  9
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              14113  1 snd
snd_page_alloc         14665  2 snd_hda_intel,snd_pcm
pcspkr                  7361  0 
dm_snapshot            22765  0 
dm_zero                 6209  0 
dm_mirror              27025  0 
dm_mod                 64345  23 dm_snapshot,dm_zero,dm_mirror
ata_piix               15941  2 
libata                 72145  1 ata_piix
sd_mod                 24385  3 
scsi_mod              140009  4 usb_storage,sg,libata,sd_mod
ext3                  135369  9 
jbd                    62549  1 ext3

And finally the log related to the bug. In this case, I used the
2.6.18-1.2257.fc5 kernel (ignore the first line):
Dec 22 14:18:01 fox clamd[2824]: SelfCheck: Database status OK. 
Dec 22 14:48:06 fox kernel: list_del corruption. next->prev should be ed9e88a0,
but was 008094e4
Dec 22 14:48:06 fox kernel: ------------[ cut here ]------------
Dec 22 14:48:06 fox kernel: kernel BUG at lib/list_debug.c:70!
Dec 22 14:48:06 fox kernel: invalid opcode: 0000 [#1]
Dec 22 14:48:06 fox kernel: last sysfs file:
/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
Dec 22 14:48:06 fox kernel: Modules linked in: vfat fat nls_utf8 cifs cls_u32
sch_tbf sch_cbq ipt_LOG xt_mac xt_limit ip_nat_irc ip_nat_ftp ip_conntrack_irc
ip_conntrack_ftp iptable_nat ip_nat autofs4 hidp l2cap bluetooth tun ipv6
ip_conntrack_netbios_ns ipt_REJECT xt_state ip_conntrack nfnetlink xt_tcpudp
iptable_filter ip_tables x_tables acpi_cpufreq io_edgeport usbserial loop usblp
video usb_storage sbs i2c_ec container button battery asus_acpi ac lp
parport_pc parport ehci_hcd uhci_hcd floppy sg snd_hda_intel snd_hda_codec
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq e100 3c59x snd_seq_device
snd_pcm_oss mii serio_raw snd_mixer_oss snd_pcm i2c_i801 i2c_core snd_timer snd
soundcore snd_page_alloc ide_cd cdrom pcspkr dm_snapshot dm_zero dm_mirror
dm_mod ata_piix libata sd_mod scsi_mod ext3 jbd
Dec 22 14:48:06 fox kernel: CPU:    0
Dec 22 14:48:06 fox kernel: EIP:    0060:[<c04d559c>]    Not tainted VLI
Dec 22 14:48:06 fox kernel: EFLAGS: 00010096   (2.6.18-1.2257.fc5 #1) 
Dec 22 14:48:06 fox kernel: EIP is at list_del+0x48/0x6c
Dec 22 14:48:06 fox kernel: eax: 00000048   ebx: ed9e88a0   ecx: c0661470  
edx: f7fef000
Dec 22 14:48:06 fox kernel: esi: f7ffb7c0   edi: d288a000   ebp: f7fffec0  
esp: f7fefef8
Dec 22 14:48:06 fox kernel: ds: 007b   es: 007b   ss: 0068
Dec 22 14:48:06 fox kernel: Process events/0 (pid: 4, ti=f7fef000 task=c18e05a0
task.ti=f7fef000)
Dec 22 14:48:06 fox kernel: Stack: c062409e ed9e88a0 008094e4 ed9e88a0 c045a0be
c079d754 00000002 f7ffb860 
Dec 22 14:48:06 fox kernel:        00000000 f7ffb860 00000002 f7ffb840 00000000
c045a1b6 00000000 00000000 
Dec 22 14:48:06 fox kernel:        f7fffec0 f7ffb7e4 f7ffb7c0 f7fffec0 f7e24440
00000282 c045b15e 00000000 
Dec 22 14:48:06 fox kernel: Call Trace:
Dec 22 14:48:06 fox kernel:  [<c045a0be>] free_block+0x65/0xd3
Dec 22 14:48:06 fox kernel:  [<c045a1b6>] drain_array+0x8a/0xb5
Dec 22 14:48:06 fox kernel:  [<c045b15e>] cache_reap+0x3f/0xd6
Dec 22 14:48:06 fox kernel:  [<c0428a48>] run_workqueue+0x85/0xc5
Dec 22 14:48:06 fox kernel:  [<c0428f46>] worker_thread+0xe8/0x11a
Dec 22 14:48:06 fox kernel:  [<c042b1a5>] kthread+0xad/0xd8
Dec 22 14:48:06 fox kernel:  [<c0403adf>] kernel_thread_helper+0x7/0x10
Dec 22 14:48:06 fox kernel: DWARF2 unwinder stuck at
kernel_thread_helper+0x7/0x10
Dec 22 14:48:06 fox kernel: Leftover inexact backtrace:
Dec 22 14:48:06 fox kernel:  =======================
Dec 22 14:48:06 fox kernel: Code: c0 e8 4e 63 f4 ff 0f 0b 41 00 8d 40 62 c0 8b
03 8b 40 04 39 d8 74 1c 89 5c 24 04 89 44 24 08 c7 04 24 9e 40 62 c0 e8 29 63
f4 ff <0f> 0b 46 00 8d 40 62 c0 8b 13 8b 43 04 89 42 04 89 10 c7 43 04 
Dec 22 14:48:06 fox kernel: EIP: [<c04d559c>] list_del+0x48/0x6c SS:ESP
0068:f7fefef8
Dec 22 14:48:06 fox kernel:  <3>BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Dec 22 14:48:06 fox kernel: in_atomic():0, irqs_disabled():1
Dec 22 14:48:06 fox kernel:  [<c0403f28>] dump_trace+0x69/0x1af
Dec 22 14:48:06 fox kernel:  [<c0404086>] show_trace_log_lvl+0x18/0x2c
Dec 22 14:48:06 fox kernel:  [<c0404601>] show_trace+0xf/0x11
Dec 22 14:48:06 fox kernel:  [<c040468b>] dump_stack+0x15/0x17
Dec 22 14:48:06 fox kernel:  [<c042da0c>] down_read+0x12/0x1f
Dec 22 14:48:06 fox kernel:  [<c042635f>] blocking_notifier_call_chain+0xe/0x29
Dec 22 14:48:06 fox kernel:  [<c041d522>] do_exit+0x1b/0x795
Dec 22 14:48:06 fox kernel:  [<c04045a2>] die+0x26b/0x290
Dec 22 14:48:06 fox kernel:  [<c0404c42>] do_invalid_op+0xa2/0xab
Dec 22 14:48:06 fox kernel:  [<c04038b9>] error_code+0x39/0x40
Dec 22 14:48:06 fox kernel: DWARF2 unwinder stuck at error_code+0x39/0x40
Dec 22 14:48:06 fox kernel: Leftover inexact backtrace:
Dec 22 14:48:06 fox kernel:  [<c04d559c>] list_del+0x48/0x6c
Dec 22 14:48:06 fox kernel:  [<c045a0be>] free_block+0x65/0xd3
Dec 22 14:48:06 fox kernel:  [<c045a1b6>] drain_array+0x8a/0xb5
Dec 22 14:48:06 fox kernel:  [<c045b15e>] cache_reap+0x3f/0xd6
Dec 22 14:48:06 fox kernel:  [<c0428a48>] run_workqueue+0x85/0xc5
Dec 22 14:48:06 fox kernel:  [<c045b11f>] cache_reap+0x0/0xd6
Dec 22 14:48:06 fox kernel:  [<c0428f46>] worker_thread+0xe8/0x11a
Dec 22 14:48:06 fox kernel:  [<c0417a48>] default_wake_function+0x0/0xc
Dec 22 14:48:06 fox kernel:  [<c0428e5e>] worker_thread+0x0/0x11a
Dec 22 14:48:06 fox kernel:  [<c042b1a5>] kthread+0xad/0xd8
Dec 22 14:48:06 fox kernel:  [<c042b0f8>] kthread+0x0/0xd8
Dec 22 14:48:06 fox kernel:  [<c0403adf>] kernel_thread_helper+0x7/0x10
Dec 22 14:48:06 fox kernel:  =======================
Dec 22 14:48:37 fox shutdown[14892]: shutting down for system reboot

Hope this information can help the developers to solve the problem.
Please tell me if I can contribute something else.
Comment 2 Jeff Layton 2007-12-29 07:00:54 EST
*** Bug 220811 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Layton 2007-12-29 07:15:16 EST
This appears to be a dupe of bug 224359, please reopen if this is still
occurring in recent kernels.

*** This bug has been marked as a duplicate of 224359 ***

Note You need to log in before you can comment on or make changes to this bug.