Bug 220850 - 3ware 9650SE not recognized by updated 3w-9xxx module
3ware 9650SE not recognized by updated 3w-9xxx module
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Brian Brock
:
Depends On:
Blocks: 223465
  Show dependency treegraph
 
Reported: 2006-12-27 18:04 EST by Scott Becker
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 00:34:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to support the 3ware 9650SE SATA-RAID controller (15.42 KB, patch)
2007-01-19 10:41 EST, Chip Coldwell
no flags Details | Diff
touch up of the preceeding patch (16.57 KB, patch)
2007-01-19 10:55 EST, Chip Coldwell
no flags Details | Diff

  None (edit)
Description Scott Becker 2006-12-27 18:04:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

Description of problem:
The latest version of 3w-9xxx.c, from manufacturer 2.26.06.001, is supposed to support the 9650SE card. It is designed for newer than 2.6.9 kernels and will not compile on RHEL 4. I need to deploy a production server and don't want to buy an older controller as a work around.

Version-Release number of selected component (if applicable):
2.26.04.010

How reproducible:
Always


Steps to Reproduce:
1. Installer won't recognize drives.

Actual Results:


Expected Results:


Additional info:
Upstream maintainer: Tom Couch <linuxraid@amcc.com>
Comment 1 Scott Becker 2007-01-02 14:32:57 EST
I got the install accomplished using version 2.26.05.006 of the 3w-9xxx kernel
module I found on www.3ware.com. It looks like they have tested it with WS. I
used it successfully with ES.

It appears that the 2.26.05 series of 3w-9xxx is dedicated to kernel 2.6.9.

3ware's site also contains a 2.26.06 series which is supposed to work with newer
kernels in fedora but I couldn't get them to work.

The current update version of the kernel for RHEL4 contains version 2.26.04.010
of the module. If the next kernel update included 2.26.05.006 or a later version
of the 2.26.05 series, then as far as I know, this bug would be closed.
Comment 2 Scott Becker 2007-01-04 12:22:15 EST
Background that I've learned so far about this 3ware card:

This new model (Installation Guide dated Oct 06) is not an incremental updated
version, it's a version for pci-express where the next older model is for pci-x.
I assume that this explains why the older driver isn't compatible; the
connection bus is different.

3ware claims that their cards provide the highest capacity and performance, and
best raid 6 performance. They might be accurate, I checked adaptec to see if
they had a product I could purchase to work around the lack of driver problem
and the biggest card they had was 8 ports with discrete cables (my server has 16
bays) wheras the 3ware product has 16 ports with 4 quad cables (their invention
they say). They claim the write performance hit from raid 6 over raid 5 is only
15% with their cards (as opposed to 60% with others). 

The only problem I have with their product (since I got the driver to work) is
that the management tool is not open source, boo. ( It works good though. )
Comment 5 Chip Coldwell 2007-01-19 10:41:46 EST
Created attachment 145988 [details]
patch to support the 3ware 9650SE SATA-RAID controller

From Michael Benz and Patrick Pejack at AMCC.
Comment 6 Chip Coldwell 2007-01-19 10:55:12 EST
Created attachment 145992 [details]
touch up of the preceeding patch
Comment 8 RHEL Product and Program Management 2007-01-19 11:26:47 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Jay Turner 2007-01-19 12:36:23 EST
QE ack for RHEL4.5.
Comment 10 Jason Baron 2007-01-23 11:45:31 EST
committed in stream U5 build 44. A test kernel with this patch is available from
http://people.redhat.com/~jbaron/rhel4/
Comment 13 Red Hat Bugzilla 2007-05-08 00:34:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.