Bug 223465 - 3ware 9650SE not recognized by updated 3w-9xxx module
3ware 9650SE not recognized by updated 3w-9xxx module
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Brian Brock
:
: 248580 (view as bug list)
Depends On: 220850
Blocks: 222082
  Show dependency treegraph
 
Reported: 2007-01-19 11:07 EST by Chip Coldwell
Modified: 2010-10-22 04:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:21:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chip Coldwell 2007-01-19 11:07:42 EST
+++ This bug was initially created as a clone of Bug #220850 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8)
Gecko/20061025 Firefox/1.5.0.8

Description of problem:
The latest version of 3w-9xxx.c, from manufacturer 2.26.06.001, is supposed to
support the 9650SE card. It is designed for newer than 2.6.9 kernels and will
not compile on RHEL 4. I need to deploy a production server and don't want to
buy an older controller as a work around.

Version-Release number of selected component (if applicable):
2.26.04.010

How reproducible:
Always


Steps to Reproduce:
1. Installer won't recognize drives.

Actual Results:


Expected Results:


Additional info:
Upstream maintainer: Tom Couch <linuxraid@amcc.com>

-- Additional comment from scottb@bxwa.com on 2007-01-02 14:32 EST --
I got the install accomplished using version 2.26.05.006 of the 3w-9xxx kernel
module I found on www.3ware.com. It looks like they have tested it with WS. I
used it successfully with ES.

It appears that the 2.26.05 series of 3w-9xxx is dedicated to kernel 2.6.9.

3ware's site also contains a 2.26.06 series which is supposed to work with newer
kernels in fedora but I couldn't get them to work.

The current update version of the kernel for RHEL4 contains version 2.26.04.010
of the module. If the next kernel update included 2.26.05.006 or a later version
of the 2.26.05 series, then as far as I know, this bug would be closed.

-- Additional comment from scottb@bxwa.com on 2007-01-04 12:22 EST --
Background that I've learned so far about this 3ware card:

This new model (Installation Guide dated Oct 06) is not an incremental updated
version, it's a version for pci-express where the next older model is for pci-x.
I assume that this explains why the older driver isn't compatible; the
connection bus is different.

3ware claims that their cards provide the highest capacity and performance, and
best raid 6 performance. They might be accurate, I checked adaptec to see if
they had a product I could purchase to work around the lack of driver problem
and the biggest card they had was 8 ports with discrete cables (my server has 16
bays) wheras the 3ware product has 16 ports with 4 quad cables (their invention
they say). They claim the write performance hit from raid 6 over raid 5 is only
15% with their cards (as opposed to 60% with others). 

The only problem I have with their product (since I got the driver to work) is
that the management tool is not open source, boo. ( It works good though. )

-- Additional comment from jwilson@redhat.com on 2007-01-05 12:36 EST --
Based on an up-to-date-as-of-this-writing RHEL4 kernel cvs tree's
linux-2.6.9-scsi-3ware-update.patch, we're still at 2.26.04.010 for RHEL4 U5.

-- Additional comment from coughlan@redhat.com on 2007-01-16 10:53 EST --
Chip,

Please check with 3ware to see if there is a low-risk update for this driver
that may be feasible for 4.5.

Tom

-- Additional comment from coldwell@redhat.com on 2007-01-19 10:41 EST --
Created an attachment (id=145988)
patch to support the 3ware 9650SE SATA-RAID controller

From Michael Benz and Patrick Pejack at AMCC.

-- Additional comment from coldwell@redhat.com on 2007-01-19 10:55 EST --
Created an attachment (id=145992)
touch up of the preceeding patch
Comment 1 RHEL Product and Program Management 2007-01-19 11:47:46 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Chip Coldwell 2007-05-31 15:41:15 EDT
POSTed 31-MAY-2007
Comment 4 Don Zickus 2007-06-12 15:01:48 EDT
in 2.6.18-24.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 7 Tomas Henzl 2007-10-02 08:08:26 EDT
*** Bug 248580 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2007-11-07 14:21:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.