Bug 221380 - wrong permissions on cjkv directory
wrong permissions on cjkv directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 222375 (view as bug list)
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2007-01-04 04:02 EST by Penelope Fudd
Modified: 2014-01-21 17:56 EST (History)
2 users (show)

See Also:
Fixed In Version: 8.15.3-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 13:18:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/rpmpkgs, the list of installed packages as of last night. (41.03 KB, text/plain)
2007-01-06 18:30 EST, Penelope Fudd
no flags Details
/var/log/yum.log, from the 'dawn of time' until now. (24.50 KB, text/plain)
2007-01-06 18:34 EST, Penelope Fudd
no flags Details

  None (edit)
Description Penelope Fudd 2007-01-04 04:02:28 EST
Description of problem:
Printing stopped working for everything except 'gimp'.

Version-Release number of selected component (if applicable):
ghostscript-8.15.3-1.fc6.i386.rpm

How reproducible:
Every time

Steps to Reproduce:
1. lpr tiger.eps
2.
3.
  
Actual results:
Printer doesn't print

Expected results:
Printer does print

Additional info:
The problem is caused because the directory /usr/share/ghostscript/8.15/lib/cjkv
has the wrong permissions (700 instead of 755).  chmod fixed the problem.

Also, I seem to have two rpms for ghostscript:
ghostscript-8.15.2-8.1.i386.rpm
ghostscript-8.15.3-1.fc6.i386.rpm

No idea why.  I'm using the yum auto-updating daemon.
Comment 1 Tim Waugh 2007-01-05 09:58:58 EST
I expect the conflicting RPM packages is the reason, but why they would be like
that I don't know.
Comment 2 Jeremy Katz 2007-01-05 12:02:34 EST
Did you have a yum update fail at some point?
Comment 3 Penelope Fudd 2007-01-06 18:28:18 EST
The yum log doesn't have a record of any failure, and it does have a record of
ghostscript being updated on Dec 20th at 3:25am.  This system was a fresh
install of FC6 on Dec 19, 2006.

The only thing I can think of is that I set the umask for root to be 77 on all
of my systems, and the update at 3:25am was part of the system-wide initial
update, not an automatic yum update, so the umask would have been in effect. 
This would have created the directory with the faulty permissions.  It doesn't
explain the duplicates.

I'm looking at the rpm package list, and I'm seeing a lot of duplicates.  I'm
attaching it and the yum log file. 
Comment 4 Penelope Fudd 2007-01-06 18:30:35 EST
Created attachment 144987 [details]
/var/log/rpmpkgs, the list of installed packages as of last night.

This contains duplicates; see GConf2, Gconf2-devel, ImageMagick, ORBit2, etc,
etc.  Ghostscript was the one that inspired this search.
Comment 5 Penelope Fudd 2007-01-06 18:34:33 EST
Created attachment 144988 [details]
/var/log/yum.log, from the 'dawn of time' until now.

The system was installed Dec 19th, if the date of /dev/modprobe.conf is to be
believed.
Comment 6 Penelope Fudd 2007-01-06 18:36:51 EST
Er, dev -> etc.
Comment 7 Tim Waugh 2007-01-12 09:51:42 EST
Ah, I think I might have found it: the ghostscript package doesn't own that cjkv
directory.
Comment 8 Tim Waugh 2007-01-12 09:52:52 EST
*** Bug 222375 has been marked as a duplicate of this bug. ***
Comment 9 Kevin R. Page 2007-01-13 13:33:29 EST
I've experienced this problem with a LaserJet 5L on an FC6; rectifying the
permissions allows me to print again.

Just to note, in case it's relevant, that I don't have any conflicting
ghostscript packages - only ghostscript-8.15.3-1.fc6.

"file /usr/share/ghostscript/8.15/lib/cjkv is not owned by any package"

It's on a system that's been upgraded many times (RHL through FC, if I recall
correctly).
Comment 10 Penelope Fudd 2007-01-13 16:23:41 EST
As an aside, I fixed the duplicate packages (all 50+ of them) with the Smart
program, a free replacement for yum.  Just typed 'smart check' to see the
duplicates, and 'smart fix' to fix them.  (See http://labix.org/smart)
Comment 11 Fedora Update System 2007-01-18 12:20:45 EST
Fixed in update: ghostscript-8.15.3-3.fc6

Note You need to log in before you can comment on or make changes to this bug.