Bug 221492 - Rhythmbox stops playback and starts a new song when searching
Rhythmbox stops playback and starts a new song when searching
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
: Reopened
: 206908 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 15:16 EST by Stewart Adam
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-30 11:17:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2007-01-04 15:16:18 EST
Description of problem:
As one types text into the search bar in Rhythmbox, sometimes it will stop the
current playback and play a song from the results.

Version-Release number of selected component (if applicable):
rhythmbox-0.9.5-8.fc6

How reproducible:
Sometimes

Steps to Reproduce:
1. Open Rhythmbox
2. Load a few songs if the library's empty
3. Search
  
Actual results:
On some searches (I've found it's more common when one types slowly) it will
stop playback and play a song from the results

Expected results:
Searching doesn't affect playback

Additional info:
Should have been reported at Gnome's bugzilla?
Comment 1 Bastien Nocera 2007-01-30 10:36:10 EST
Could you please check whether the same thing occurs with Rhythmbox 0.9.6 that
was uploaded to the FC6 updates recently?

If so, could you check whether the song you're currently playing finishes when
that happens? If so, then it's a bug by design, which should probably be taken
up upstream.
Comment 2 Bastien Nocera 2007-01-30 10:50:28 EST
*** Bug 206908 has been marked as a duplicate of this bug. ***
Comment 3 Stewart Adam 2007-02-13 19:56:03 EST
I've updated to F7T1, and that rhythmbox no longer has this problem.
Comment 4 Stewart Adam 2007-05-02 17:42:20 EDT
I'm not sure why, but this has started occurring again with
rhythmbox-0.10.0-6.fc7 - Does it have to do with the update to 0.10?
Comment 5 Bastien Nocera 2007-06-12 05:49:59 EDT
Could you check whether the song you're currently playing finishes when
that happens? If so, then it's a bug by design, which should probably be taken
up upstream.
Comment 6 Stewart Adam 2007-06-12 16:38:25 EDT
Yup, that's it - I'll wait 'till Rhythmbox 0.11 (I tried from rawhide but it
didn't work so I'll give it another week or two) and then submit a bug to the
Gnome bugzilla.
Comment 7 Stewart Adam 2008-01-07 12:30:58 EST
Initial issue is present again with rhythmbox-0.11.4-1.fc9 (playback stops
mid-track and starts from search results)
Comment 8 Bastien Nocera 2008-01-07 12:43:24 EST
Could you check whether the track plays until the end when not entering any
searches? It might be that the progress bar isn't accurate and the song is
actually truncated. That's the only way I can see this problem happening.
Comment 9 Stewart Adam 2008-01-07 13:37:04 EST
Nope, this is a full track (it plays properly the whole way through) and I can
search at any time, typing slowly like with the older versions and playback
stops or changes depending on if I have any search results.
Comment 10 Bastien Nocera 2008-03-28 11:04:26 EDT
I can't reproduce it... Could you post the output of "rhythmbox -d" when
reproducing the problem (possibly from f9)?
Comment 11 Stewart Adam 2008-03-30 11:17:53 EDT
I remember it occurred when I typed the beginning of a specific string, but I
forgot what that string was... In any case it seems to be working again now.

Note You need to log in before you can comment on or make changes to this bug.