Bug 221503 - Crash at exit in SavageGEReset
Crash at exit in SavageGEReset
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
http://www.asus.com/search.aspx?searc...
: Reopened
: 244103 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 15:46 EST by Răzvan Sandu
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 13:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (61.27 KB, text/plain)
2007-01-08 06:21 EST, Răzvan Sandu
no flags Details
Xorg.0.log.old (62.09 KB, application/octet-stream)
2007-01-08 06:22 EST, Răzvan Sandu
no flags Details
Xorg.setup.log (2.00 KB, text/plain)
2007-01-08 06:23 EST, Răzvan Sandu
no flags Details
xorg.conf (1.02 KB, application/octet-stream)
2007-01-08 06:26 EST, Răzvan Sandu
no flags Details
The required log file. (60.89 KB, text/plain)
2007-06-14 14:05 EDT, Răzvan Sandu
no flags Details

  None (edit)
Description Răzvan Sandu 2007-01-04 15:46:16 EST
Description of problem:

Hello,

I have a stock Fedora Core 6 + latest updates (as of January 4, 2007).

Video board is integrated on mainboard: seems to be a S3 ProSavage8 integrated
on an Asus P4VP-MX motherboard
(http://www.asus.com/search.aspx?searchitem=1&searchkey=P4VP-MX).

Monitor is LCD: a NEC AccuSync 72VM
(http://www.nec-mitsubishi.com/coremedia/generator/index,realm=Products__Details__Specification,spec=x__uk__en,docId=87036,type=LCD)
In Windows, it works at 1280x1024, million colors with no problem (according to
OSD, this is the optimal resolution).

Fedora 6 installs on this system, in X mode, with no problems. After reboot,
loading starts normally, then screen becomes and remains black instead of
displaying X login.

Booting Fedora in level 3 works OK.

Doing a "system-config-display --reconfig" from text mode shows a 800x600 screen
and works OK. Video board is detetected and uses S3 ProSavage driver, monitor is
detected as generic LCD.

Starting X works OK - by manually setting monitor as "Generic LCD 1280x1024",
you can get 1280x1024 at 32 bits depth, good quality.

However, after shutting down X to get back in command line, the screen remains
black and OSD displays "No video signal" for some time, the the power LED turns
orange (standby). One can exit this state only by rebooting system (CTRL-ALT-DEL
works), to re-enter in text mode. 

In the above state, some of the keyboard functions seems to be disabled (one
cannot press NumLock to switch the NumLock LED on).


Version-Release number of selected component (if applicable):


How reproducible:
Always, in the hardware configuration described above. 


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Screen remains black after exiting from X; you must reboot.

Expected results:
The system should return to text-mode.

Additional info:
I experienced this on other Asus mainboards too: for example the P4P800-VM.


Regards,
Razvan
Comment 1 Matěj Cepl 2007-01-05 10:20:26 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Răzvan Sandu 2007-01-08 06:21:25 EST
Created attachment 145045 [details]
Xorg.0.log
Comment 3 Răzvan Sandu 2007-01-08 06:22:35 EST
Created attachment 145046 [details]
Xorg.0.log.old
Comment 4 Răzvan Sandu 2007-01-08 06:23:39 EST
Created attachment 145047 [details]
Xorg.setup.log
Comment 5 Răzvan Sandu 2007-01-08 06:26:25 EST
Created attachment 145048 [details]
xorg.conf
Comment 6 Răzvan Sandu 2007-01-08 06:27:35 EST
Hello,

I am pleased to provide the requested files (please see above).

Regards,
Razvan
Comment 7 Răzvan Sandu 2007-01-10 10:55:05 EST
Hello,

It seems this was "magically" solved after recent updates (last days).

Works OK now, without any intervention from my part.

Regards,
Razvan
Comment 8 Adam Jackson 2007-01-24 15:00:52 EST
Marking WFM as per comment #7.  Please reopen if this issue reappears.

Thanks for the report!
Comment 9 Răzvan Sandu 2007-05-14 12:50:46 EDT
Hello,

I have downloaded Fedora 6.93 and this issue reappeared (it was OK in FC6, as
reported above).

I have done all the online updates as of May 14, 2007, but this remains the same.


Regards,
Răzvan
Comment 10 Răzvan Sandu 2007-05-14 12:53:59 EDT
Additional comment:

The screen remains black after exiting X and monitor's LED turn from green to
yello, suggesting it entered in an unsupported mode.


Răzvan
Comment 11 Răzvan Sandu 2007-06-10 04:37:42 EDT
Hello,

This bug is still present in Fedora 7 (after final release) and *very* annoying,
because it's impossible to exit normally from X and return to text mode (in
runlevel 3) - I must reboot the workstation ... :-(


Could you check, please ?


Thanks a lot,
Răzvan
Comment 12 Alex Villacís Lasso 2007-06-13 16:02:20 EDT
The following bug report:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=244103

might be a duplicate of this bug. However, bug 244103 has a Xorg.0.log file with
a crash backtrace. Could anybody who follows and can reproduce this bug do the
following:

1) Make the X server enter the black-screen state.
2) Reboot
3) On GRUB, modify required parameters to enter into runlevel 3 without
graphical boot (for me, its remove "rhgb", then add "3" to kernel parameters).
4) Log in as root and save /var/log/Xorg.0.log, then post it here for examination.
Comment 13 Răzvan Sandu 2007-06-14 12:57:45 EDT
Here is smolt output from machine exhibiting crash:

http://smolt.fedoraproject.org/show?UUID=96d4d333-663e-47b4-8c14-28f809e08889


Regards,
Răzvan
Comment 14 Răzvan Sandu 2007-06-14 14:05:55 EDT
Created attachment 157026 [details]
The required log file.

Hello,

As required in comment #12, here is my bet ;-)	- please see attached log

Many thanks,
Răzvan
Comment 15 Alex Villacís Lasso 2007-06-14 14:18:03 EDT
*** Bug 244103 has been marked as a duplicate of this bug. ***
Comment 16 Alex Villacís Lasso 2007-06-14 14:19:36 EDT
As I suspected, bug 244103 is a duplicate this bug (bug 221503). There is a
crash, and the crash occurs at the exact same place. So I marked my bug as a
duplicate of this one.
Comment 17 Matěj Cepl 2007-07-10 05:57:24 EDT
Thanks, Alex!
Comment 18 Alex Villacís Lasso 2007-08-06 20:12:01 EDT
This bug might be related to the following bug reports in bugs.freedesktop.org:

http://bugs.freedesktop.org/show_bug.cgi?id=11354
http://bugs.freedesktop.org/show_bug.cgi?id=11237
Comment 19 Alex Villacís Lasso 2007-08-16 11:50:56 EDT
Current git for savage driver from freedesktop.org fixes this crash on exit for
me. I just replaced savage_drv.so with the one resulting from compiling the
current git.

I recommend updating the savage package to current git. 
Comment 20 Răzvan Sandu 2007-08-17 02:24:33 EDT
*Please* include this, as a n updatedc RPM, into official Fedora repository.
This bug is *extremely* annoying...

Regards,
Răzvan
Comment 21 Răzvan Sandu 2007-09-04 11:34:49 EDT
Any news on this, please ? The fix is still not present in Fedora repositories
for F7 ?
Comment 22 Steve Schaeffer 2007-10-06 08:24:39 EDT
I've been experiencing the same thing. None of the suggested remedies work for
me either. I never had this problem with FC6 and have never NOT had it with F7
and I keep up with released packages. My solution? Run FC6. Here is the tail of
Xorg.0.log.old:

(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded
AUDIT: Mon Oct  1 21:57:34 2007: 2702 X: client 11 rejected from local host (uid 99)
(II) SAVAGE(0): [drm] removed 1 reserved context for kernel
(II) SAVAGE(0): [drm] unmapping 8192 bytes of SAREA 0xeec5f000 at 0xafda0000

Backtrace:
0: X(xf86SigHandler+0x81) [0x80c2d21]
1: [0x110420]
2: /usr/lib/xorg/modules/drivers//savage_drv.so [0x230e1f]
3: /usr/lib/xorg/modules/drivers//savage_drv.so(SavageGEReset+0x35d) [0x236c9d]
4: /usr/lib/xorg/modules/drivers//savage_drv.so [0x237b20]
5: /usr/lib/xorg/modules/drivers//savage_drv.so [0x237eca]
6: X [0x80c9dd1]
7: /usr/lib/xorg/modules/extensions//libextmod.so [0x18b853]
8: X [0x8168fc7]
9: X [0x80e479c]
10: X [0x80c1e79]
11: X [0x8142748]
12: X [0x81668c5]
13: X [0x8105475]
14: X(main+0x50c) [0x80717ac]
15: /lib/libc.so.6(__libc_start_main+0xe0) [0x28af70]
16: X(FontFileCompleteXLFD+0x1e9) [0x8070a21]

Fatal server error:
Caught signal 11.  Server aborting

Comment 23 Răzvan Sandu 2007-10-07 04:31:08 EDT
Since we are very close to Fedora 8, continuing using FC6 is at least
counterproductive... :-(

However, I'll need very much a solution for this...

Thanks,
Răzvan
Comment 24 Răzvan Sandu 2007-10-11 07:13:28 EDT
I now run fedora 8 test 3 + updates as of October 11, 2007.
At least for me, this seems to be solved.

Thanks A LOT,
Răzvan

Note You need to log in before you can comment on or make changes to this bug.