Bug 244103 - savage_drv with ProSavage8 - X server crashes on exit and leaves blank screen
savage_drv with ProSavage8 - X server crashes on exit and leaves blank screen
Status: CLOSED DUPLICATE of bug 221503
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 15:57 EDT by Alex Villacís Lasso
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 14:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log with backtrace (59.91 KB, text/plain)
2007-06-13 15:57 EDT, Alex Villacís Lasso
no flags Details
Configuration file on machine exhibiting crash (2.07 KB, text/plain)
2007-06-13 16:06 EDT, Alex Villacís Lasso
no flags Details
Output of lspci -v on machine exhibiting crash (4.25 KB, text/plain)
2007-06-13 16:10 EDT, Alex Villacís Lasso
no flags Details
smolt output for machine exhibiting crash (7.67 KB, text/plain)
2007-06-13 16:10 EDT, Alex Villacís Lasso
no flags Details

  None (edit)
Description Alex Villacís Lasso 2007-06-13 15:57:37 EDT
Description of problem:
On default installation of Fedora Core 7 (from LiveCD) in a computer with
ProSavage chipset, the X server always crashes on exit and leaves the monitor
unusable, with no text or anything, and LEDs blinking. I know it is a crash
because if I reboot the computer and carefully configure it to remove rhgb and
select text-mode boot (3) (both as kernel parameters), I can recover the X log
before being overwritten by graphical login.

If I manually switch the X server to a text console with Ctrl-Alt-F[1-6] and
then killall Xorg, the crash does not occur.

Computer itself is not hung, because Ctrl-Alt-Delete is handled normally and
allows to reboot cleanly, even after the crash. Also, in GNOME, the menu option
to shut down the computer also runs normally (even with the screen blank).

Version-Release number of selected component (if applicable):


How reproducible: Always

Steps to Reproduce:
1. On hardware config. with ProSavage4 videocard/chipset, start X server
2. Attempt to shut down X session from within X itself.
  
Actual results:
X server crashes, backtrace reported in Xorg.0.log, monitor left in undefined
state with no output at all (black screen).

Expected results:
X server cleans up correctly and returns to normal text mode.

Additional info:

The bug report at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221503
seems very similar to my case. However, there is no mention of a crash, only of
the blank screen. Maybe this is a duplicate and the other bug reveals a crash in
the X log if examined properly.
Comment 1 Alex Villacís Lasso 2007-06-13 15:57:37 EDT
Created attachment 156912 [details]
Xorg log with backtrace
Comment 2 Alex Villacís Lasso 2007-06-13 16:06:29 EDT
Created attachment 156914 [details]
Configuration file on machine exhibiting crash
Comment 3 Alex Villacís Lasso 2007-06-13 16:10:10 EDT
Created attachment 156915 [details]
Output of lspci -v on machine exhibiting crash
Comment 4 Alex Villacís Lasso 2007-06-13 16:10:52 EDT
Created attachment 156916 [details]
smolt output for machine exhibiting crash
Comment 5 Alex Villacís Lasso 2007-06-14 14:18:01 EDT

*** This bug has been marked as a duplicate of 221503 ***

Note You need to log in before you can comment on or make changes to this bug.