Bug 221612 - ia64: show_mem() for sparsemem NUMA
Summary: ia64: show_mem() for sparsemem NUMA
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: George Beshers
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 276281 (view as bug list)
Depends On:
Blocks: 253733 276281 425461
TreeView+ depends on / blocked
 
Reported: 2007-01-05 17:04 UTC by George Beshers
Modified: 2008-05-21 14:40 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-05-21 14:40:35 UTC


Attachments (Terms of Use)
patch accepted by Tony Luck and Andrew Morton. (3.36 KB, patch)
2007-01-05 17:04 UTC, George Beshers
no flags Details | Diff
Leader to patch series (234 bytes, application/octet-stream)
2007-10-04 20:28 UTC, George Beshers
no flags Details
backport (4.03 KB, patch)
2007-10-04 20:28 UTC, George Beshers
no flags Details | Diff
backport (1.76 KB, patch)
2007-10-04 20:29 UTC, George Beshers
no flags Details | Diff
backport (3.74 KB, patch)
2007-10-04 20:29 UTC, George Beshers
no flags Details | Diff
backport (2.01 KB, patch)
2007-10-04 20:30 UTC, George Beshers
no flags Details | Diff
Old sysrq-m on altix6 (6.23 KB, text/plain)
2007-10-11 18:24 UTC, George Beshers
no flags Details
new sysrq-m on altix6 (6.16 KB, text/plain)
2007-10-11 18:24 UTC, George Beshers
no flags Details
combined patch against 2.6.18-52 (5.91 KB, patch)
2007-10-11 18:25 UTC, George Beshers
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description George Beshers 2007-01-05 17:04:24 UTC
Description of problem:
  The change from discontig to sparsemem undercut Jes's
  upstream patch to show_mem().  A new patch is now in the
  -mm tree awaiting a move to Linus' tree.

  The importance of this patch is that it provides more information
  about NUMA memory in a form that is more compact than the original
  discontig.c:show_mem().  It should be noted that this is one of
  the few ways of getting at this information when an error occurs
  in the field.


Version-Release number of selected component (if applicable):


How reproducible:
Always.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Will post to rhkernel-list when it goes into Linus' tree.

Comment 1 George Beshers 2007-01-05 17:04:24 UTC
Created attachment 144914 [details]
patch accepted by Tony Luck and Andrew Morton.

Comment 2 RHEL Product and Program Management 2007-04-25 22:27:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Peter Martuccelli 2007-05-02 13:47:50 UTC
Conditional devel ACK, post when accepted into mainline.

Comment 5 Marizol Martinez 2007-06-06 21:28:35 UTC
Red Hat Product Management and Engineering have evaluated this request and
currently plan to include it in the next Red Hat Enterprise Linux minor release.
Please note that its inclusion depends upon the successful completion of code
integration and testing.

Comment 6 Don Zickus 2007-07-19 19:50:15 UTC
rejected on rhkl, moving back to assign

Comment 7 Luming Yu 2007-08-27 13:25:43 UTC
The patch at comment#1 has been in upstream
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=f1c0afa2e8802c01cf82c915e2bb3cb2a81570d4

Is it reasonable to post the back port again?

Comment 8 Luming Yu 2007-08-28 08:19:30 UTC
Do you agree to re-post?

Comment 9 George Beshers 2007-08-28 14:46:42 UTC
Yes, I will re-post; 5.1 testing is winding down.


Comment 10 George Beshers 2007-10-04 20:28:05 UTC
Created attachment 216391 [details]
Leader to patch series

Comment 11 George Beshers 2007-10-04 20:28:42 UTC
Created attachment 216401 [details]
backport

Comment 12 George Beshers 2007-10-04 20:29:09 UTC
Created attachment 216411 [details]
backport

Comment 13 George Beshers 2007-10-04 20:29:48 UTC
Created attachment 216421 [details]
backport

Comment 14 George Beshers 2007-10-04 20:30:32 UTC
Created attachment 216431 [details]
backport

Comment 15 George Beshers 2007-10-11 18:24:15 UTC
Created attachment 224591 [details]
Old sysrq-m on altix6

Comment 16 George Beshers 2007-10-11 18:24:52 UTC
Created attachment 224601 [details]
new sysrq-m on altix6

Comment 17 George Beshers 2007-10-11 18:25:28 UTC
Created attachment 224611 [details]
combined patch against 2.6.18-52

Comment 18 George Beshers 2007-10-25 14:11:04 UTC
*** Bug 276281 has been marked as a duplicate of this bug. ***

Comment 19 Don Zickus 2007-12-14 18:34:03 UTC
in 2.6.18-60.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 22 errata-xmlrpc 2008-05-21 14:40:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.