Bug 221699 - SQLite objects created in a thread can only be used in that same thread
SQLite objects created in a thread can only be used in that same thread
Status: CLOSED DUPLICATE of bug 220750
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-06 06:03 EST by Ameya Gore
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-07 06:50:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TBe83547cb sqlitesack.py:446:simplePkgList:ProgrammingError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id -1269429360 and this is thread (1.57 KB, text/plain)
2007-01-06 06:03 EST, Ameya Gore
no flags Details

  None (edit)
Description Ameya Gore 2007-01-06 06:03:47 EST
Description of problem:
TBe83547cb sqlitesack.py:446:simplePkgList:ProgrammingError: SQLite objects
created in a thread can only be used in that same thread.The object was created
in thread id -1269429360 and this is thread id -1208805696

Version-Release number of selected component (if applicable):
yumex 1.2.1

How reproducible:


Steps to Reproduce:
 Initialize yumex

 
Actual results:

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in <module>
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 995, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.5/site-packages/yumex/yumexBase.py", line 445, in
build_package_lists
    self.doUpdateSetup()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 357, in
doUpdateSetup
    self.pkgSack.simplePkgList())
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 303, in
simplePkgList
    return self._computeAggregateListResult("simplePkgList")
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 323, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 446, in
simplePkgList
    cur = cache.cursor()
ProgrammingError: SQLite objects created in a thread can only be used in that
same thread.The object was created in thread id -1269429360 and this is thread
id -1208805696

Expected results:


Additional info:
Comment 1 Ameya Gore 2007-01-06 06:03:47 EST
Created attachment 144964 [details]
TBe83547cb sqlitesack.py:446:simplePkgList:ProgrammingError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id -1269429360 and this is thread
Comment 2 Tim Lauridsen 2007-01-07 06:50:00 EST
Yumex 1.2.1 dont work with python 2.5, check out yumex 1.9.x.

get it here :

http://www.yum-extender.org/dnl/yumex/devel/

it will soon be pushed to fedora Extras Development

*** This bug has been marked as a duplicate of 220750 ***

Note You need to log in before you can comment on or make changes to this bug.