Bug 221765 - cannot default to 32 bit firefox as 64 bit binaries have dependancies
cannot default to 32 bit firefox as 64 bit binaries have dependancies
Status: CLOSED DUPLICATE of bug 425951
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-07 14:05 EST by Benjamin LaHaise
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 09:05:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Benjamin LaHaise 2007-01-07 14:05:00 EST
When trying to use only 32 bit firefox on x86-64 by uninstalling the 64 bit
package, it is impossible to remove the binaries due to several dependancies on
internal firefox libraries.  Manually changing the script that starts firefox
breaks on updates when the changes are overwritten.

[root@tower ipv4]# rpm -e firefox-1.5.0.9-1.fc6.x86_64
error: Failed dependencies:
        libgtkembedmoz.so()(64bit) is needed by (installed)
devhelp-0.12-9.fc6.x86_64
        libgtkembedmoz.so()(64bit) is needed by (installed)
yelp-2.16.0-11.fc6.x86_64
        libxpcom.so()(64bit) is needed by (installed)
libswt3-gtk2-3.2.1-23.fc6.x86_64
        libxpcom.so()(64bit) is needed by (installed) devhelp-0.12-9.fc6.x86_64
        libxpcom.so()(64bit) is needed by (installed) yelp-2.16.0-11.fc6.x86_64
        libxpcom_core.so()(64bit) is needed by (installed) yelp-2.16.0-11.fc6.x86_64
Comment 1 Warren Togami 2007-01-08 15:33:32 EST
Unfortunately, removing firefox.x86_64 will not be long-term solution even if
there were not these dependency problems.

You may want to try "yum install firefox-32" from Extras.  It isn't a supported
solution either, but it at least works.
Comment 2 Benjamin LaHaise 2007-01-08 15:53:12 EST
If firefox were split into a -libs package, this approach would work fine. 
There has to be some way to make a supported technique available, even if it
means adding a /etc/sysconfig/firefox
Comment 3 Warren Togami 2007-01-08 21:47:44 EST
My proposal to add a /etc/sysconfig/firefox was rejected.  The preferred
long-term solution is for nspluginwrapper to be fixed up for any plugins to be
run within a separate process than the browser.  This allows 32bit (or any
plugins) to be usable within a 64bit browser.  This also enables greater
flexibility to tighten down what plugins are allowed to do with selinux policies.

Until nspluginwrapper is fixed up, please try firefox-32 from Extras.  It sucks,
but it works for the near-term.
Comment 4 David Alden 2007-03-27 16:42:14 EDT
(In reply to comment #3)
> My proposal to add a /etc/sysconfig/firefox was rejected. 

How about changing:

MOZ_ARCH=$(uname -m)

to:

test -n "$MOZ_ARCH" || MOZ_ARCH=$(uname -m)

that way I can set MOZ_ARCH to be i386 and it will fire up the 32bit version (this is what I've done for 
all of my local machines).

As for firefox-32 from Extras - how does that work with the "Web Browser" button in kde?  Will it 
automatically fire up the 32bit version?

Comment 5 Matěj Cepl 2007-12-10 04:22:28 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 6 Matěj Cepl 2007-12-17 09:05:39 EST

*** This bug has been marked as a duplicate of 425951 ***

Note You need to log in before you can comment on or make changes to this bug.