Bug 221775 - No "install everything", installation doesn't work
No "install everything", installation doesn't work
Status: CLOSED DUPLICATE of bug 186007
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-07 16:56 EST by Frank Farance
Modified: 2008-01-24 11:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 11:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Farance 2007-01-07 16:56:20 EST
Description of problem:

There is no "install everything".  Simply, this means I must spend time trying
to recreate FC4's installation -- THIS IS A HUGE WASTE OF MY TIME AND IS ERROR
PRONE!!!!  Here's why ...

With FC4, I could install a system with "everything".  I am preparing dozens of
systems for use as webservers, development servers, etc..  When I install a
system, I check the system before bringing it into production.  ***BEFORE*** it
goes into production is when I want to test everything to make sure it is working.

Some of you have the bone-head idea that we just "add packages as necessary".

Who has the patience to click 3000 mouse clicks (not to mention its error
proneness in missing one or two packages, and its non-reproducibility)?

Who wants to take a running production system and (later on) add a huge amount
of integration risk by adding lots new packages?  I don't want to add packages
as my users request them.  Thus, all the software needs to be added at once: at
the beginning, during installation time.

http://linux.slashdot.org/comments.pl?sid=189398&threshold=1&commentsort=0&mode=thread&cid=15596807

I read on slashdot that you believe that getting rid of "install everything"
will reduce the load on your update servers.  If you had a detailed,
step-by-step process on setting up one's own update server and clients, then I
would certainly set up my own update server (improving my update response,
decreasing your load).  But the documentation at
"http://fedora.redhat.com/docs/mirror/en" is poor in that it is incomplete and
it worries more about doing tasks as a non-root user and typos in rsync commands
rather than worrying about the completeness and robustness of the end result,
i.e., getting an update server working, updating itself, and updating client
systems.

In other words, why should I trust a roll-your-own update server with poor
documentation?  What's the benefit of choosing a solution that (1) I'm not sure
if it is going to work, (2) the Redhat documentation doesn't give me the
confidence it is going to work, (3) the penalty for failure is not being certain
if updates are done correctly?

You shoot yourself in the foot by providing poor documentation.

Not to mention, there is no current documentation on anaconda, nor is there
documentation on the format of the kickstart file (if you search the Redhat
website, you'll find kickstart formats for the Redhat 7.1, but nothing current).
 So there is little confidence one can get from on-line documentation.

How to reproduce the poor documentation?  Go to:

        1. http://redhat.com

        2. Click "Support" at the top of the page.

        3. Enter "anaconda" in the search box, then click Search.

        4. On the right, under "Narrow Your Search / Search Categories", click
"Documentation".

You'll see the the links all point to very old Redhat releases (e.g., Redhat 7.1).

So while there might be some conflicts in the package installation of "install
everything" for FC6, your solution could be: still provide "install everything",
but remove conflicts and document the conflicts in the release notes.

IN SUMMARY: An FC6 installation requires about 30 minutes of installation from
CDs, then ***a couple days trying*** to sort out packages and test everything
... and then the systems created by the installation are all different because
much was done manually (a really poor QA problem).  In contrast, the FC4
installation required a couple hours and then one had a complete system -- as
was consistent across installations and the QA was better.

OR SAID DIFFERENTLY: Everyone else (including Microsoft and Adobe) has managed
to distribute CDs for their software and is able to get a consistent
installation across users (assuming the users want to install all of the
software in the CD bundle), but Redhat now as taken a huge step backwards in
installation reliability: they've made much of the installation process a manual
process where each user must craft their own idea on what "everything" is, each
user must *invent* their own procedure to do this (since it isn't document on
the Fedora website), and then each user will do it inconsistently -- even the
same user will do it inconsistently across his/her installations.

The is no reason you can't put back "install everything".  However, if you
insist upon leaving out "install everything", they many of us will have to find
another Linux distribution because: (1) Fedora installations take too much work,
(2) Fedora installations are error prone, (3) everyone else (other distros)
seems to figure out how to make a useful distro except for Redhat.

Clearly, no one at Redhat is thinking about how to roll out dozens/scores of
Fedora systems that are all consistently, completely, and reliably installed. 
You seem to believe that Fedora is for the hobbyist/home user who installs only
**one system** and he/she has no worries about integration risk or error
proneness.  Given all the manual work after FC6 CD installation and all the
manual fix-up work later on because of errors/inconsistencies, how can RHEL be
any good if Fedora installation is all screwed up?

Version-Release number of selected component (if applicable):

FC6

How reproducible:

Just install FC6.

Steps to Reproduce:
1. Install FC6.  There is no "install everything" option.
2.
3.
  
Actual results:
The FC6 produced an incomplete installation with lots of software yet to be
installed.

Expected results:
There would be an "install everything" in the installation script.

Additional info:
See bug 201911 for a related problem with "@ everything" no longer working in
the kickstart file.
Comment 1 Chris Lumens 2007-01-24 11:45:52 EST
If you need to do dozens of consistent installs, you need to be using kickstart.
 For FC6 and beyond, kickstart installs can even pull packages from multiple
repos (extras, third party repos, your own in-house repo) which should fix up a
lot of the post-installation package stuff you want to do.  If you really want
to install everything, you can specify * in the %packages section and this will
expand to all packages in all configured repos.  This is a lot of stuff.  If you
feel the documentation is inadequate, please file a bug against the documentation.

*** This bug has been marked as a duplicate of 186007 ***
Comment 2 Frank Farance 2007-01-24 12:33:28 EST
You didn't read the bug report:

(1) there is no "install everything" (which might be a duplicate of bug 186007)

(2) there is no guidance on the compatibility of installing everything on the
5-CD ISO media

(3) there is no current documentation to the kickstart format posted on the
redhat or fedora websites (and easily discoverable)

(4) there is no current documentation on running anaconda and command options
posted on the redhat or fedora websites (and easily discoverable)

So if you are going to say that (1) is a duplicate of bug 186007, then the
remaining parts of this bug (package compatibility, no documentation on
kickstart or anaconda), is still valid and not a duplicate.
Comment 3 Chris Lumens 2007-01-24 12:56:30 EST
#2-4 are all documentation problems.  Please file a bug against the Fedora
Documentation product regarding these.  I do agree that the easily discoverable
documentation is lacking.  We have documentation in the anaconda package, but
unfortunately you need anaconda already installed before you are able to read
them.  I'll work on getting these documents cleaned up and then posted to the
wiki.  As for RHEL documentation, I know that for RHEL5 it should be better
because I have reviewed it and made extensive comments on it.

This bug was marked as a duplicate based on the title and that being your main
problem.
Comment 4 Frank Farance 2007-01-24 15:34:19 EST
Facet #2 of the problem is related to some incompatibilities in your packaging.
 So I wouldn't expect to find a document on "here's where the Fedora
installation is broken", I'd expect the software to provide guidance on
installing as much of the CD-set as I can -- this is where I click most of the
packages and the installation should tell me "hey, there's a conflict here, try
X", rather than the installation aborting 60-120 minutes later.

Bug 186007 relates to the fact that there is no "install everything" check box
(a problem for FC5 and FC6) and bug 186007 seems to be specific to FC5. 
However, this bug also concerns the fact that the packaging was broken in that:
even skipping the user-interface issue of having a handy "install everything"
box/button, even when one checks all the packages on the CD media, it still
crashes in the install.

Or said differently, even if kickstart and anaconda were well documented, there
would still be a problem with anaconda or the FC6 packaging because it let's you
go down the path of wasting 60-120 minutes of installation without letting you
know that you will ultimately fail.

All you need to do is what every other software manufacturer knows (and every
user expects from software media): get the installation working and let the user
install everything from the media.

Not a duplicate.
Comment 5 Red Hat Bugzilla 2007-06-11 23:37:16 EDT
requested by Jams Antill
Comment 6 Chris Lumens 2008-01-24 11:06:09 EST
Kickstart and anaconda options have been documented for several months now: 
http://fedoraproject.org/Wiki/Anaconda/Kickstart and
http://fedoraproject.org/Wiki/Anaconda/Options.  We should be doing better about
 detecting and telling you about file conflicts, and then allowing you to make
modifications.  If there are still conflicts between individual packages, that's
a bug with the packages themselves and should be filed against the appropriate
components.  I'm once again marking this as a dupe based on the main complaint
about lack of an everything option.

*** This bug has been marked as a duplicate of 186007 ***

Note You need to log in before you can comment on or make changes to this bug.