Bug 221794 - m17n-db needs to be rebased against m17n-contrib
m17n-db needs to be rebased against m17n-contrib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag Nemade
: i18n
Depends On:
Blocks: 221796
  Show dependency treegraph
 
Reported: 2007-01-07 22:05 EST by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 07:24:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-01-07 22:05:26 EST
Description of problem:
m17n-db needs to be updated to version 1.3.4 and the Indic maps need
to be rebased off m17n-contrib-1.1.1.

This should be done before Test1 of the next release.
Comment 1 Mayank Jain 2007-01-08 08:15:01 EST
m17n-db-1.3.3 rebased to m17n-db-1.3.4 in m17n-db-1.3.4-1.fc7
Package up for testing.

What can be tested
- All respective keymaps should be appearing in the scim menu
- All keymaps should be working
- si-wijesekera keymap should be named as "si-wijesekera" and not
"si-wijesekera-preedit" in scim
- key summary should be present in si-wijesekera


ChangeLogs (straight from m17n-db.spec)
---------------------------------------
- Resolves: Bug 221794 - Rebased to new release m17n-db-1.3.4
- Removed patch: si-wijesekera_surrounding_to_preedit.patch
- Added directive to delete si-wijesekera from the upstream tarball as it used
surrounding text
- Commented directive to copy bopo-kbd.mim
- Commented directive using variable.mim and command.mim - added global.mim in
place of them
- Added sections for new Uyghur.
- Added copy directive for Mizuochi (grc-*) keymap for classical greek
- Added directives to install translations for japanese translations.
- Added patch to rename si-wijesekera-preedit to si-wijesekera and add key
summary as Patch2

Comment 2 Jens Petersen 2007-01-08 18:32:36 EST
Thanks.  We should also rebase m17n-db-indic off m17n-contrib-1.1.1 too.
Comment 3 Mayank Jain 2007-02-09 06:44:27 EST
Hi Jens, 
Does your comment 2 means that we should include the keymaps in contrib (which
were submitted by other community members) in our m17n-db?
Comment 4 Jens Petersen 2007-02-12 03:12:30 EST
No, I am referring to:
http://www.m17n.org/m17n-lib-download/m17n-contrib-1.1.1.tar.gz
Comment 5 Red Hat Bugzilla 2007-05-13 21:21:46 EDT
User majain@redhat.com's account has been closed
Comment 6 Jens Petersen 2007-05-23 22:13:28 EDT
reassigning to Parag, the new package owner
Comment 7 Parag Nemade 2007-05-30 09:01:10 EDT
(In reply to comment #2)
> Thanks.  We should also rebase m17n-db-indic off m17n-contrib-1.1.1 too.

What does this mean? we are not using upstream tarball m17n-contrib-1.1.1 right?
Comment 8 Jens Petersen 2007-05-30 19:24:31 EDT
(In reply to comment #7)
> we are not using upstream tarball m17n-contrib-1.1.1 right?

Correct, as you can see for yourself.

I recommend waiting for m17n-contrib-1.1.2 before doing this since it
contains a lot of our fixes and new maps.  But it would be good if
you can check which of our latest packages have not been moved upstream
yet.  There has been some discussion of that on the m17n-lib list recently
as I tried to help with that.
Comment 9 Jens Petersen 2007-05-30 19:26:21 EDT
Alternatively if upstream is slow to release we can also just
take a cvs snapshot for m17n-contrib in the meantime, but they
are actually still waiting for some fixes from us I think before releasing.
Comment 10 Parag Nemade 2007-07-26 07:24:39 EDT
latest builds of m17n-db and m17n-contrib are available in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.