Bug 2220051 - F39FailsToInstall: odcs, python3-odcs-client, python3-odcs-common
Summary: F39FailsToInstall: odcs, python3-odcs-client, python3-odcs-common
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: odcs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomír Sedlář
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2220146 2220234 2220300
Blocks: F39FailsToInstall PYTHON3.12 2219959
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:06 UTC by Fedora Fails To Install
Modified: 2023-07-13 11:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-13 11:32:41 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-05 19:06:02 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (odcs) Fails To Install in Fedora 39:

can't install odcs:
  - nothing provides python(abi) = 3.11 needed by odcs-0.6.0-1.fc39.noarch
  
can't install python3-odcs-client:
  - nothing provides python(abi) = 3.11 needed by python3-odcs-client-0.6.0-1.fc39.noarch
  
can't install python3-odcs-common:
  - nothing provides python3.11dist(requests) needed by python3-odcs-common-0.6.0-1.fc39.noarch
  - nothing provides python3.11dist(openidc-client) needed by python3-odcs-common-0.6.0-1.fc39.noarch
  - nothing provides python3.11dist(requests-gssapi) needed by python3-odcs-common-0.6.0-1.fc39.noarch
  - nothing provides python(abi) = 3.11 needed by python3-odcs-common-0.6.0-1.fc39.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install odcs python3-odcs-client python3-odcs-common


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Haibo Lin 2023-07-10 02:36:34 UTC
I tried to rebuild odcs for Python 3.12, but some of the dependencies are not ready for Python 3.12.

DEBUG util.py:442:  Error: 
DEBUG util.py:442:   Problem 1: conflicting requests
DEBUG util.py:442:    - nothing provides python(abi) = 3.11 needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:    - nothing provides (python3.11dist(billiard) < 5~~ with python3.11dist(billiard) >= 4.1) needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:    - nothing provides (python3.11dist(click) < 9~~ with python3.11dist(click) >= 8.1.2) needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:    - nothing provides (python3.11dist(vine) < 6~~ with python3.11dist(vine) >= 5) needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:    - nothing provides python3.11dist(click-didyoumean) >= 0.3 needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:    - nothing provides python3.11dist(click-plugins) >= 1.1.1 needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:    - nothing provides python3.11dist(click-repl) >= 0.2 needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:    - nothing provides python3.11dist(python-dateutil) >= 2.8.2 needed by python3-celery-5.3.1-1.fc39.noarch from build
DEBUG util.py:442:   Problem 2: conflicting requests
DEBUG util.py:442:    - nothing provides python(abi) = 3.11 needed by python3-flask-login-0.6.2-2.fc39.noarch from build
DEBUG util.py:442:    - nothing provides python3.11dist(flask) >= 1.0.4 needed by python3-flask-login-0.6.2-2.fc39.noarch from build
DEBUG util.py:442:    - nothing provides python3.11dist(werkzeug) >= 1.0.1 needed by python3-flask-login-0.6.2-2.fc39.noarch from build

Comment 2 Haibo Lin 2023-07-11 07:09:46 UTC
  File "/builddir/build/BUILDROOT/odcs-0.6.0-2.fc39.noarch/usr/lib/python3.12/site-packages/odcs/server/config.py", line 25, in <module>
    import imp
ModuleNotFoundError: No module named 'imp'

imp module deprecated since version 3.4, will be removed in version 3.12: The imp module is deprecated in favor of importlib. https://docs.python.org/3/library/imp.html

Comment 3 Haibo Lin 2023-07-13 07:32:17 UTC
(In reply to Haibo Lin from comment #2)
>   File
> "/builddir/build/BUILDROOT/odcs-0.6.0-2.fc39.noarch/usr/lib/python3.12/site-
> packages/odcs/server/config.py", line 25, in <module>
>     import imp
> ModuleNotFoundError: No module named 'imp'
> 
> imp module deprecated since version 3.4, will be removed in version 3.12:
> The imp module is deprecated in favor of importlib.
> https://docs.python.org/3/library/imp.html

https://pagure.io/odcs/pull-request/626

Comment 4 Haibo Lin 2023-07-13 10:07:46 UTC
Backported the patch https://koji.fedoraproject.org/koji/buildinfo?buildID=2231945

Comment 5 Fedora Fails To Install 2023-07-13 11:32:41 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 39.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.