Bug 2220328 - F39FailsToInstall: python3-mechanize
Summary: F39FailsToInstall: python3-mechanize
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-mechanize
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohan Boddu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FailsToInstall PYTHON3.12 2219956
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:15 UTC by Fedora Fails To Install
Modified: 2023-07-07 07:30 UTC (History)
3 users (show)

Fixed In Version: python-mechanize-0.4.8-7.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-07 07:30:43 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-05 19:15:20 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-mechanize) Fails To Install in Fedora 39:

can't install python3-mechanize:
  - nothing provides python(abi) = 3.11 needed by python3-mechanize-0.4.8-6.fc38.noarch
  - nothing provides python3.11dist(html5lib) >= 0.999999999 needed by python3-mechanize-0.4.8-6.fc38.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install python3-mechanize


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Kevin Fenzi 2023-07-06 18:35:09 UTC
So, this is due to there being a empty "SPECPARTS" created by autosetup... removing it makes it build fine. 

But... why isn't it getting removed? Or why is it even there? 

I guess this is 

https://github.com/rpm-software-management/rpm/issues/2532 ?

Comment 2 Miro Hrončok 2023-07-07 06:59:11 UTC
Right.

Building python-mechanize-0.4.8-7.fc39 for rawhide
Created task: 103033040
Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=103033040


Marking as fixed, assuming it actually builds.


Note You need to log in before you can comment on or make changes to this bug.