Bug 2220379 - F39FailsToInstall: Multiple packages built from python-opentelemetry-contrib
Summary: F39FailsToInstall: Multiple packages built from python-opentelemetry-contrib
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-opentelemetry-contrib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact:
URL:
Whiteboard:
Depends On: 2220146 2220196 2220203 2220217 2220295 2220300
Blocks: F39FailsToInstall PYTHON3.12 2220496
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:17 UTC by Fedora Fails To Install
Modified: 2023-07-13 04:24 UTC (History)
3 users (show)

Fixed In Version: python-opentelemetry-contrib-1.18.0-20.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-13 04:24:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-05 19:17:00 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-opentelemetry-contrib) Fails To Install in Fedora 39:

can't install python3-opentelemetry-instrumentation-sqlite3+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-sqlite3+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-logging:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-logging-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pika+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pika+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(pika) >= 0.12 needed by python3-opentelemetry-instrumentation-pika+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-contrib-instrumentations:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-contrib-instrumentations-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-distro+otlp:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-distro+otlp-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-distro:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-distro-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-exporter-richconsole:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-exporter-richconsole-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(rich) >= 10 needed by python3-opentelemetry-exporter-richconsole-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(setuptools) >= 16 needed by python3-opentelemetry-instrumentation-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-aiohttp-client+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-aiohttp-client+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(aiohttp) >= 3 with python3.11dist(aiohttp) < 4) needed by python3-opentelemetry-instrumentation-aiohttp-client+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-aiohttp-client:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-aiohttp-client-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-aiohttp-client-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-aiopg+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-aiopg+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(aiopg) < 2~~ with python3.11dist(aiopg) >= 0.13) needed by python3-opentelemetry-instrumentation-aiopg+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-aiopg:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-aiopg-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-aiopg-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-asgi+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-asgi+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(asgiref) >= 3 with python3.11dist(asgiref) < 4) needed by python3-opentelemetry-instrumentation-asgi+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-asgi:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-asgi-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(asgiref) >= 3 with python3.11dist(asgiref) < 4) needed by python3-opentelemetry-instrumentation-asgi-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-asyncpg+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-asyncpg+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-asyncpg:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-asyncpg-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-aws-lambda+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-aws-lambda+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-aws-lambda:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-aws-lambda-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-boto+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-boto+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(boto) >= 2 with python3.11dist(boto) < 3) needed by python3-opentelemetry-instrumentation-boto+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-boto:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-boto-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-boto3sqs+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-boto3sqs+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(boto3) >= 1 with python3.11dist(boto3) < 2) needed by python3-opentelemetry-instrumentation-boto3sqs+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-boto3sqs:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-boto3sqs-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-boto3sqs-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-botocore+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-botocore+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(botocore) >= 1 with python3.11dist(botocore) < 2) needed by python3-opentelemetry-instrumentation-botocore+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-botocore:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-botocore-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-celery+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-celery+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-celery:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-celery-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-dbapi+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-dbapi+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-dbapi:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-dbapi-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-dbapi-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-django+asgi:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-django+asgi-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-django+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-django+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-django:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-django-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-elasticsearch+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-elasticsearch+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-elasticsearch:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-elasticsearch-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-elasticsearch-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-fastapi+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-fastapi+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-fastapi:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-fastapi-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-flask+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-flask+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(flask) < 3~~ with python3.11dist(flask) >= 1) needed by python3-opentelemetry-instrumentation-flask+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-grpc:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-grpc-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-grpc-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-flask:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-flask-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-jinja2:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-jinja2-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-jinja2-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-jinja2+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-jinja2+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(jinja2) < 4~~ with python3.11dist(jinja2) >= 2.7) needed by python3-opentelemetry-instrumentation-jinja2+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-kafka-python:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-kafka-python-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-logging+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-logging+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-grpc+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-grpc+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(grpcio) >= 1.27 with python3.11dist(grpcio) < 2) needed by python3-opentelemetry-instrumentation-grpc+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-kafka-python+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-kafka-python+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pika:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pika-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-pika-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(packaging) >= 20 needed by python3-opentelemetry-instrumentation-pika-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-mysql:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-mysql-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-mysql+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-mysql+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(mysql-connector-python) >= 8 with python3.11dist(mysql-connector-python) < 9) needed by python3-opentelemetry-instrumentation-mysql+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-psycopg2+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-psycopg2+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(psycopg2) >= 2.7.3.1 needed by python3-opentelemetry-instrumentation-psycopg2+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pymongo:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pymongo-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-psycopg2:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-psycopg2-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pymysql+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pymysql+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(pymysql) < 2~~ needed by python3-opentelemetry-instrumentation-pymysql+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pymemcache+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pymemcache+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(pymemcache) < 5~~ with python3.11dist(pymemcache) >= 1.3.5) needed by python3-opentelemetry-instrumentation-pymemcache+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pyramid+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pyramid+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(pyramid) >= 1.7 needed by python3-opentelemetry-instrumentation-pyramid+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pyramid:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pyramid-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-pyramid-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-sqlalchemy+instruments:
  - nothing provides python3.11dist(sqlalchemy) needed by python3-opentelemetry-instrumentation-sqlalchemy+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-sqlalchemy+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pymysql:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pymysql-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-redis+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-redis+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(redis) >= 2.6 needed by python3-opentelemetry-instrumentation-redis+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-sqlalchemy:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-sqlalchemy-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(packaging) >= 21 needed by python3-opentelemetry-instrumentation-sqlalchemy-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(wrapt) >= 1.11.2 needed by python3-opentelemetry-instrumentation-sqlalchemy-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-redis:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-redis-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(wrapt) >= 1.12.1 needed by python3-opentelemetry-instrumentation-redis-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-requests+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-requests+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(requests) >= 2 with python3.11dist(requests) < 3) needed by python3-opentelemetry-instrumentation-requests+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-requests:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-requests-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-tornado+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-tornado+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(tornado) >= 5.1.1 needed by python3-opentelemetry-instrumentation-tornado+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-urllib+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-urllib+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-tornado:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-tornado-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-urllib3:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-urllib3-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-urllib3-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-sqlite3:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-sqlite3-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-system-metrics+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-system-metrics+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides python3.11dist(psutil) >= 5 needed by python3-opentelemetry-instrumentation-system-metrics+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-system-metrics:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-system-metrics-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(psutil) >= 5.9 with python3.11dist(psutil) < 6) needed by python3-opentelemetry-instrumentation-system-metrics-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-urllib:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-urllib-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-urllib3+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-urllib3+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(urllib3) < 2~~ with python3.11dist(urllib3) >= 1) needed by python3-opentelemetry-instrumentation-urllib3+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-wsgi:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-wsgi-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-wsgi+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-wsgi+instruments-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-propagator-aws-xray:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-propagator-aws-xray-1:1.0.1-16.fc39.noarch
  
can't install python3-opentelemetry-propagator-ot-trace:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-propagator-ot-trace-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-sdk-extension-aws:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-sdk-extension-aws-1:2.0.1-16.fc39.noarch
  
can't install python3-opentelemetry-util-http:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-util-http-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pymemcache:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pymemcache-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(wrapt) < 2~~ with python3.11dist(wrapt) >= 1) needed by python3-opentelemetry-instrumentation-pymemcache-1:0.39~b0-16.fc39.noarch
  
can't install python3-opentelemetry-instrumentation-pymongo+instruments:
  - nothing provides python(abi) = 3.11 needed by python3-opentelemetry-instrumentation-pymongo+instruments-1:0.39~b0-16.fc39.noarch
  - nothing provides (python3.11dist(pymongo) < 5~~ with python3.11dist(pymongo) >= 3.1) needed by python3-opentelemetry-instrumentation-pymongo+instruments-1:0.39~b0-16.fc39.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install python3-opentelemetry-instrumentation-sqlite3+instruments python3-opentelemetry-instrumentation-logging python3-opentelemetry-instrumentation-pika+instruments python3-opentelemetry-contrib-instrumentations python3-opentelemetry-distro+otlp python3-opentelemetry-distro python3-opentelemetry-exporter-richconsole python3-opentelemetry-instrumentation python3-opentelemetry-instrumentation-aiohttp-client+instruments python3-opentelemetry-instrumentation-aiohttp-client python3-opentelemetry-instrumentation-aiopg+instruments python3-opentelemetry-instrumentation-aiopg python3-opentelemetry-instrumentation-asgi+instruments python3-opentelemetry-instrumentation-asgi python3-opentelemetry-instrumentation-asyncpg+instruments python3-opentelemetry-instrumentation-asyncpg python3-opentelemetry-instrumentation-aws-lambda+instruments python3-opentelemetry-instrumentation-aws-lambda python3-opentelemetry-instrumentation-boto+instruments python3-opentelemetry-instrumentation-boto python3-opentelemetry-instrumentation-boto3sqs+instruments python3-opentelemetry-instrumentation-boto3sqs python3-opentelemetry-instrumentation-botocore+instruments python3-opentelemetry-instrumentation-botocore python3-opentelemetry-instrumentation-celery+instruments python3-opentelemetry-instrumentation-celery python3-opentelemetry-instrumentation-dbapi+instruments python3-opentelemetry-instrumentation-dbapi python3-opentelemetry-instrumentation-django+asgi python3-opentelemetry-instrumentation-django+instruments python3-opentelemetry-instrumentation-django python3-opentelemetry-instrumentation-elasticsearch+instruments python3-opentelemetry-instrumentation-elasticsearch python3-opentelemetry-instrumentation-fastapi+instruments python3-opentelemetry-instrumentation-fastapi python3-opentelemetry-instrumentation-flask+instruments python3-opentelemetry-instrumentation-grpc python3-opentelemetry-instrumentation-flask python3-opentelemetry-instrumentation-jinja2 python3-opentelemetry-instrumentation-jinja2+instruments python3-opentelemetry-instrumentation-kafka-python python3-opentelemetry-instrumentation-logging+instruments python3-opentelemetry-instrumentation-grpc+instruments python3-opentelemetry-instrumentation-kafka-python+instruments python3-opentelemetry-instrumentation-pika python3-opentelemetry-instrumentation-mysql python3-opentelemetry-instrumentation-mysql+instruments python3-opentelemetry-instrumentation-psycopg2+instruments python3-opentelemetry-instrumentation-pymongo python3-opentelemetry-instrumentation-psycopg2 python3-opentelemetry-instrumentation-pymysql+instruments python3-opentelemetry-instrumentation-pymemcache+instruments python3-opentelemetry-instrumentation-pyramid+instruments python3-opentelemetry-instrumentation-pyramid python3-opentelemetry-instrumentation-sqlalchemy+instruments python3-opentelemetry-instrumentation-pymysql python3-opentelemetry-instrumentation-redis+instruments python3-opentelemetry-instrumentation-sqlalchemy python3-opentelemetry-instrumentation-redis python3-opentelemetry-instrumentation-requests+instruments python3-opentelemetry-instrumentation-requests python3-opentelemetry-instrumentation-tornado+instruments python3-opentelemetry-instrumentation-urllib+instruments python3-opentelemetry-instrumentation-tornado python3-opentelemetry-instrumentation-urllib3 python3-opentelemetry-instrumentation-sqlite3 python3-opentelemetry-instrumentation-system-metrics+instruments python3-opentelemetry-instrumentation-system-metrics python3-opentelemetry-instrumentation-urllib python3-opentelemetry-instrumentation-urllib3+instruments python3-opentelemetry-instrumentation-wsgi python3-opentelemetry-instrumentation-wsgi+instruments python3-opentelemetry-propagator-aws-xray python3-opentelemetry-propagator-ot-trace python3-opentelemetry-sdk-extension-aws python3-opentelemetry-util-http python3-opentelemetry-instrumentation-pymemcache python3-opentelemetry-instrumentation-pymongo+instruments


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2023-07-06 12:49:16 UTC
I have fixed unwanted test dependencies on python3-falcon and python3-django3 (both currently FTI), but because of the way BR generation is done in this package, I don’t necessarily see all of the issues up front. Currently, the package is blocked on python-kafka, python-elasticsearch, and python-celery:

$ fedpkg mockbuild --enablerepo=local

Error:
 Problem 1: package python3-elasticsearch-8.3.1-4.fc38.noarch from fedora requires python(abi) = 3.11, but none of the providers can be installed
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.i686 from fedora
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.x86_64 from fedora
  - cannot install the best candidate for the job
 Problem 2: package python3-kafka-2.0.2-9.fc38.noarch from fedora requires python(abi) = 3.11, but none of the providers can be installed
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.i686 from fedora
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.x86_64 from fedora
  - cannot install the best candidate for the job
 Problem 3: cannot install both python3-dateutil-1:2.8.2-9.fc39.noarch from local and python3-dateutil-1:2.8.2-6.fc39.noarch from fedora
  - package python3-celery-5.3.1-1.fc39.noarch from fedora requires python3.11dist(python-dateutil) >= 2.8.2, but none of the providers can be installed
  - package python3-botocore-1.29.164-2.fc39.noarch from local requires (python3.12dist(python-dateutil) < 3~~ with python3.12dist(python-dateutil) >= 2.1), but none of the providers can be installed
  - cannot install the best candidate for the job

Comment 2 Ben Beasley 2023-07-13 04:11:36 UTC
Patching out the kafka instrumentation for now will allow this package to be rebuilt for Python 3.12.

Comment 3 Fedora Update System 2023-07-13 04:22:37 UTC
FEDORA-2023-c0b161b6ee has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c0b161b6ee

Comment 4 Fedora Update System 2023-07-13 04:24:55 UTC
FEDORA-2023-c0b161b6ee has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.