Bug 222109 - Make evolution's gnome-pilot dependency optional by splitting it out into a subpackage
Make evolution's gnome-pilot dependency optional by splitting it out into a s...
Status: CLOSED DUPLICATE of bug 178155
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 08:46 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 18:01:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2007-01-10 08:46:32 EST
The way Evolution is packaged it currently has a runtime dependency on gnome-pilot.
evolution-2.8.0-7.fc6

rpm -qR evolution | grep pilot
gnome-pilot >= 2.0.13
libgpilotd.so.2  
libgpilotdcm.so.2  
libgpilotdconduit.so.2

The gnome-pilot dependency pulls in various dependencies in the pilot stack.

Suggest that for Fedora 7 and beyond the built components depending on
gnome-pilot be factored out into a separate evolution-pilot subpackage in the
evolution specfile, which would take the Requires: gnome-pilot and this
subpackage be made optional in the Fedora comps file, since not all Evolution
users will want this stack.  The Evolution specfile would still have a
BuildRequires on gnome-pilot-devel

I believe it's just the pilot conduits that would need to live in this subpackage:
rpm -ql evolution | grep conduits
/usr/lib/evolution/2.8/conduits
/usr/lib/evolution/2.8/conduits/libeaddress_conduit.so
/usr/lib/evolution/2.8/conduits/libecalendar_conduit.so
/usr/lib/evolution/2.8/conduits/libememo_conduit.so
/usr/lib/evolution/2.8/conduits/libetodo_conduit.so
/usr/lib/gnome-pilot/conduits/e-address-2.8.conduit
/usr/lib/gnome-pilot/conduits/e-calendar-2.8.conduit
/usr/lib/gnome-pilot/conduits/e-memo-2.8.conduit
/usr/lib/gnome-pilot/conduits/e-todo-2.8.conduit
Comment 1 Matthew Barnes 2007-01-10 15:10:53 EST
Sounds good to me!
Comment 2 Dave Malcolm 2007-01-10 15:43:57 EST
You may want to doublecheck things; this is based on my half-remembered
knowledge of how the pilot stuff in evo works :-)
Comment 3 Matthew Barnes 2007-10-05 11:38:01 EDT
I think a user submitted a patch for this in a different bug that I can't find
at the moment.  I plan to attempt this split for Fedora 9.
Comment 4 Matthew Barnes 2007-10-05 18:01:45 EDT

*** This bug has been marked as a duplicate of 178155 ***

Note You need to log in before you can comment on or make changes to this bug.