Bug 22213 - GDM was already running, but seems to have been murdered mysteriously
GDM was already running, but seems to have been murdered mysteriously
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Dale Lovelace
:
: 23259 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-13 05:23 EST by Stephen Tittel
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 16:28:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tittel 2000-12-13 05:23:26 EST
During starting up of the GNOME login interface the following error is 
generated: <filename> According to /var/run/gdm.pid gdm was already 
running, but seems to have been murdered mysteriously.

This error message continues to be displayed (each time with a different 
and higher process id). If I login with root permissions and search for 
the gdm.pid under /var/run I could delete it but without any results. Also 
the screen is flickering all the time.
Comment 1 Need Real Name 2001-01-02 15:55:47 EST
I am having the same problems, I cannot get an X server, as gdm keeps claiming 
its being murdered. and the screen keeps flashing. The only way I have found to 
stop it is to while its flashing, manage to login to a terminal and run 
Xconfigurator. However this only means the flashing screen turs off, I still 
cannot get an Xserver, and the problem returns when you restart.
Comment 2 Havoc Pennington 2001-01-02 17:23:50 EST
Means gdm is crashing for some reason, I guess. Check for useful information in
/var/log/gdm/:0.log? Otherwise the way to find out would be to build gdm with
debugging and get it in a debugger. I can do that if I can make it crash - what
video card, etc. do you guys have? What changes have you made to the default 7.0
setup? Did it do this since you installed, or did it appear at some point?
Comment 3 Need Real Name 2001-01-03 16:16:49 EST
Below is the :0.log file, dont know if it is any use:


XFree86 Version 4.0.1a / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 2 August 2000
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-22smp i686 [ELF] 
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Jan  3 21:03:16 2001
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "PBN5103"
(**) |   |-->Device "nVidia Corporation|GeForce 256 DDR"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) XKB: layout: "gb"
(**) FontPath set to "unix/:7100"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 9

As you can probably tell from this I have a Creative labe geforce annhillator 
pro graphics, with gefore 256 ddr chipshet, and 32b ram. I have recomplied the 
kernel, only adding in a Bt848 tv card, and ntfs file system, both of which I 
have only just recently done, and I have encountered the problem before this . 
I also have changes LILO commands, networiking names in Linuxconf, possibly 
could be this but I don't think so. Also when the system reboots, the 
messages 'Shutting down X server [Failed]' and 'Stopping lpd [Failed]' can be 
seen. (Lpd is fine on boot) I have had the problem 6 or 7 times now, and each 
time I cannot fix the problem and end up having to reinstall rh7. Is there a 
way I can reinstall gdm rather than having to reinstall the whole of rh7?
Comment 4 Havoc Pennington 2001-01-03 17:05:38 EST
Sure, you can just 'rpm -e gdm' then 'rpm -Uvh gdmpackage.rpm' where
gdmpackage.rpm is a file on your Red Hat CD, the exact filename starts with gdm
and ends in rpm and has some version information in between. ;-) Also you can
edit /etc/inittab to make the default runlevel 3 instead of 5, then gdm won't
start, and you start x by logging in as a user and typing 'startx'. To do that
change the line 'id:5:initdefault:' to have a 3 instead of a 5. Those are just
workarounds though; still need to figure out what the bug is...
Comment 5 Need Real Name 2001-01-04 13:34:14 EST
I have had another thought of what it could be. I have a user set up, so as 
when I log in with that user it opens a new x server in :1, in 8 bit colour 
mode, instead of in 24 bit colour mode. I think it could be caused by the order 
in which I logout of these servers, or rebooting with out closing :1 down 
first. I know it works on a friends version of redhat 6.2, and mine is set up 
idetically to that execpt I have a different graphics card, and of course rh7
Comment 6 Havoc Pennington 2001-01-05 13:27:03 EST
*** Bug 23259 has been marked as a duplicate of this bug. ***
Comment 7 Havoc Pennington 2001-01-05 13:27:41 EST
*** Bug 23259 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2004-11-01 16:28:40 EST
Hi,

This is bug is quite old and is very probably not relevant anymore. 
I'm going to close it, but if it occurs in a more recent release,
please feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.