Bug 222243 - gnome-panel lock up
gnome-panel lock up
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-panel (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
: 222244 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 19:13 EST by Adam Kropelin
Modified: 2014-06-23 09:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Kropelin 2007-01-10 19:13:03 EST
Description of problem:
The topmost gnome-panel on the GNOME desktop locks up (stops refreshing and 
does not respond to input) periodically. This happens once or twice a day and 
can be remedied by killing the gnome-panel process, at which time a replacement 
will be launched automatically. You do not have to be interacting with the 
desktop or the panel for the lockup to occurr; in fact it usually happens while 
I'm away from the computer. Perhaps an interaction with the default screen 
saver?

Version-Release number of selected component (if applicable):
gnome-panel-2.16.0-7.el5

How reproducible:
100% ... all it takes is patience

Steps to Reproduce:
1. Install RHEL5 Beta 2
2. Log into GNOME desktop session
3. Wait until lockup
Comment 1 Ralph Loader 2007-11-13 17:19:06 EST
I'm seeing this on Fedora 8 too.  The panel process is chewing CPU while locked up.
Comment 2 Ralph Loader 2007-11-13 17:55:21 EST
It looks like we've gone into an infinite loop resizing something; here is a
typical backtrace I get attaching gdb:

#0  0x008cd365 in g_source_list_add (source=0xd583288, context=0x9d48a98)
    at gmain.c:852
#1  0x008d10da in IA__g_source_attach (source=0xd583288, context=0x9d48a98)
    at gmain.c:917
#2  0x008d121c in IA__g_idle_add_full (priority=110, 
    function=0xc3d590 <gdk_threads_dispatch>, data=0xd581730, 
    notify=0xc3d540 <gdk_threads_dispatch_free>) at gmain.c:4190
#3  0x00c3d657 in IA__gdk_threads_add_idle_full (priority=110, 
    function=0x1c2ff0 <gtk_container_idle_sizer>, data=0x0, notify=0)
    at gdk.c:558
#4  0x001c32f6 in _gtk_container_queue_resize (container=0x9d69548)
    at gtkcontainer.c:1346
#5  0x002e9c80 in real_queue_resize (widget=0x9d69548) at gtksizegroup.c:161
#6  0x002e9e80 in queue_resize_on_widget (widget=0x9d69548, 
    check_siblings=<value optimized out>) at gtksizegroup.c:203
#7  0x003b4558 in IA__gtk_widget_queue_resize (widget=0x9d69548)
    at gtkwidget.c:3548
#8  0x0809508e in panel_toplevel_update_edges (toplevel=0x9d69548)
    at panel-toplevel.c:1543
#9  0x08099234 in panel_toplevel_size_request (widget=0x9d69548, 
    requisition=0x9d69564) at panel-toplevel.c:2504
#10 0x00983a79 in IA__g_cclosure_marshal_VOID__BOXED (closure=0x9d5cbe0, 
    return_value=0x0, n_param_values=2, param_values=0xbff149bc, 
    invocation_hint=0xbff148cc, marshal_data=0x8098f00) at gmarshal.c:566
#11 0x00975779 in g_type_class_meta_marshal (closure=0x9d5cbe0, 
    return_value=0x0, n_param_values=2, param_values=0xbff149bc, 
    invocation_hint=0xbff148cc, marshal_data=0x7c) at gclosure.c:567
#12 0x00976f83 in IA__g_closure_invoke (closure=0x9d5cbe0, return_value=0x0, 
    n_param_values=2, param_values=0xbff149bc, invocation_hint=0xbff148cc)
    at gclosure.c:490
#13 0x0098791a in signal_emit_unlocked_R (node=0x9d2c2f0, detail=0, 
    instance=0x9d69548, emission_return=0x0, instance_and_params=0xbff149bc)
    at gsignal.c:2370
#14 0x00988997 in IA__g_signal_emit_valist (instance=0x9d69548, signal_id=29, 
    detail=0, var_args=0xbff14c0c "0NQ") at gsignal.c:2199
#15 0x0098997e in IA__g_signal_emit_by_name (instance=0x9d69548, 
    detailed_signal=0x47895a "size_request") at gsignal.c:2267
#16 0x002ea158 in do_size_request (widget=0x9d69548) at gtksizegroup.c:620
#17 0x002ea3ca in _gtk_size_group_compute_requisition (widget=0x9d69548, 
    requisition=0xbff14c8c) at gtksizegroup.c:820
#18 0x003b4426 in IA__gtk_widget_size_request (widget=0x9d69548, 
    requisition=0xbff14c8c) at gtkwidget.c:3632
#19 0x08096e8d in panel_toplevel_check_resize (container=0x9d69548)
    at panel-toplevel.c:2963
#20 0x00984409 in IA__g_cclosure_marshal_VOID__VOID (closure=0x9d60950, 
    return_value=0x0, n_param_values=1, param_values=0xbff14efc, 
    invocation_hint=0xbff14e0c, marshal_data=0x8096e30) at gmarshal.c:77
#21 0x00975779 in g_type_class_meta_marshal (closure=0x9d60950, 
    return_value=0x0, n_param_values=1, param_values=0xbff14efc, 
    invocation_hint=0xbff14e0c, marshal_data=0x174) at gclosure.c:567
#22 0x00976f83 in IA__g_closure_invoke (closure=0x9d60950, return_value=0x0, 
    n_param_values=1, param_values=0xbff14efc, invocation_hint=0xbff14e0c)
    at gclosure.c:490
#23 0x00987ad3 in signal_emit_unlocked_R (node=0x9d60980, detail=0, 
    instance=0x9d69548, emission_return=0x0, instance_and_params=0xbff14efc)
    at gsignal.c:2478
#24 0x00988997 in IA__g_signal_emit_valist (instance=0x9d69548, signal_id=92, 
    detail=0, var_args=0xbff1513c "0NQ") at gsignal.c:2199
#25 0x00988b59 in IA__g_signal_emit (instance=0x9d69548, signal_id=92, 
    detail=0) at gsignal.c:2243
#26 0x001c2fb7 in IA__gtk_container_check_resize (container=0x9d69548)
    at gtkcontainer.c:1378
#27 0x001c305e in gtk_container_idle_sizer (data=0x0) at gtkcontainer.c:1304
#28 0x00c3d5f8 in gdk_threads_dispatch (data=0x9fcfc20) at gdk.c:470
#29 0x008cd491 in g_idle_dispatch (source=0x9fcd340, callback=0x6e, 
    user_data=0x9fcfc20) at gmain.c:4132
#30 0x008cf05c in IA__g_main_context_dispatch (context=0x9d48a98)
    at gmain.c:2061
#31 0x008d249f in g_main_context_iterate (context=0x9d48a98, block=1, 
    dispatch=1, self=0x9d215a0) at gmain.c:2694
#32 0x008d2849 in IA__g_main_loop_run (loop=0x9ee70a0) at gmain.c:2898
#33 0x0026cae4 in IA__gtk_main () at gtkmain.c:1146
#34 0x080603ec in main (argc=7, argv=0xbff153f4) at main.c:97
Comment 3 Matěj Cepl 2009-11-15 10:30:29 EST
*** Bug 222244 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2014-03-07 08:56:37 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-02 09:23:40 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 6 Adam Kropelin 2014-06-23 09:51:32 EDT
Clearing needinfo.

Note You need to log in before you can comment on or make changes to this bug.