Bug 222253 - Submitting bug report from a crash
Submitting bug report from a crash
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 221950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 22:37 EST by Austin
Modified: 2007-12-10 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 20:10:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The saved bug report generated by bug buddy. (7.71 KB, text/plain)
2007-01-10 22:37 EST, Austin
no flags Details
Another bug report created this afternoon. (7.28 KB, text/plain)
2007-01-10 22:39 EST, Austin
no flags Details
Another bug report created. (7.50 KB, text/plain)
2007-01-11 20:04 EST, Austin
no flags Details
Another bug report created. (7.67 KB, text/plain)
2007-01-11 20:08 EST, Austin
no flags Details
Another bug report created. (7.53 KB, text/plain)
2007-01-14 18:43 EST, Austin
no flags Details
Another bug report created. (7.59 KB, text/plain)
2007-01-14 18:49 EST, Austin
no flags Details
Another bug report created. (7.62 KB, text/plain)
2007-01-14 19:40 EST, Austin
no flags Details
Another bug report created. (7.63 KB, text/plain)
2007-01-15 19:29 EST, Austin
no flags Details
Another bug report created. (8.87 KB, text/plain)
2007-01-15 19:33 EST, Austin
no flags Details
Another bug report created. (7.33 KB, text/plain)
2007-01-16 01:10 EST, Austin
no flags Details
Another bug report created. (10.71 KB, text/plain)
2007-01-18 03:39 EST, Austin
no flags Details
Another bug report created. (9.42 KB, text/plain)
2007-01-18 03:40 EST, Austin
no flags Details
Another bug report created. (9.67 KB, text/plain)
2007-01-18 17:10 EST, Austin
no flags Details
Another bug report created. (9.42 KB, text/plain)
2007-01-19 01:03 EST, Austin
no flags Details
Another bug report created. (9.42 KB, text/plain)
2007-01-21 16:22 EST, Austin
no flags Details
Another bug report created. (9.41 KB, text/plain)
2007-01-21 17:21 EST, Austin
no flags Details
Another bug report created - with debuginfo enabled. (7.65 KB, text/plain)
2007-01-21 22:38 EST, Austin
no flags Details
Output at the console. (2.44 KB, text/plain)
2007-01-21 22:40 EST, Austin
no flags Details
Another bug report created - with debuginfo enabled. (7.76 KB, text/plain)
2007-01-21 23:41 EST, Austin
no flags Details
Output at the console. (504 bytes, text/plain)
2007-01-21 23:42 EST, Austin
no flags Details
Another bug report created - with debuginfo enabled. (7.73 KB, text/plain)
2007-01-22 16:50 EST, Austin
no flags Details
Output at the console. (1.49 KB, text/plain)
2007-01-22 16:51 EST, Austin
no flags Details
Another bug report created - with debuginfo enabled. (6.01 KB, text/plain)
2007-01-24 18:51 EST, Austin
no flags Details
Output at the console. (583 bytes, text/plain)
2007-01-24 18:52 EST, Austin
no flags Details
Another bug report created - with debuginfo enabled. (5.44 KB, text/plain)
2007-01-28 17:28 EST, Austin
no flags Details
Output at the console. (1.07 KB, text/plain)
2007-01-28 17:29 EST, Austin
no flags Details
Another bug report created - with debuginfo enabled. (5.45 KB, text/plain)
2007-01-30 19:06 EST, Austin
no flags Details
Output at the console. (1.52 KB, text/plain)
2007-01-30 19:07 EST, Austin
no flags Details
Another bug report created - with debuginfo enabled. (4.98 KB, text/plain)
2007-01-30 19:09 EST, Austin
no flags Details
Output at the console. (504 bytes, text/plain)
2007-01-30 19:10 EST, Austin
no flags Details

  None (edit)
Description Austin 2007-01-10 22:37:37 EST
Description of problem: evolution (or one of it's components crashed)


Version-Release number of selected component (if applicable):$ evolution --version
Gnome evolution 2.8.2.1

$ rpm -qa | grep -i evolu
mail-notification-evolution-plugin-3.0-10.fc6
evolution-data-server-1.8.2-1.fc6
evolution-connector-2.8.2-2.fc6
evolution-webcal-2.7.1-6
evolution-data-server-devel-1.8.2-1.fc6
evolution-2.8.2.1-3.fc6



How reproducible: Unsure. Sorry.

 
Actual results: Something crashed and presented the bug buddy dialog asking for
it to be saved and reported.


Expected results: No crash - for the app to work.


Additional info: Available upon request.
Comment 1 Austin 2007-01-10 22:37:37 EST
Created attachment 145313 [details]
The saved bug report generated by bug buddy.
Comment 2 Austin 2007-01-10 22:39:08 EST
Created attachment 145314 [details]
Another bug report created this afternoon.

Added in addition to the first bug report, but I'm unsure if they are related.
I figured it would be more than likely.
Comment 3 Matthew Barnes 2007-01-10 23:00:45 EST
Thanks for reporting the crash.  Can you please give some more details about
what you were doing when the program crashed?  For example, did it crash just
after startup, or when you were exiting the program?  What kinds of mail
accounts were you accessing?  Which component were you using when the program
crashed (Mail, Calendar, Tasks, etc.)?  The more details the better.

Also, can I ask you to install a few debugging packages and post another Bug
Buddy report the next time it happens?  These packages contain information about
your installed software that might help me track down the problem.

evolution-debuginfo
evolution-data-server-debuginfo
evolution-connector-debuginfo
gtk2-debuginfo
glib2-debuginfo
Comment 4 Austin 2007-01-10 23:22:10 EST
The second time I ran evolution from the console, and this was left at the console:

$ evolution &
[1] 10936
CalDAV Eplugin starting up ...

** (evolution:10936): WARNING **: LDAP authentication failed (0x31)
** (evolution:10936): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:10936): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
BBDB spinning up...

** (evolution:10936): WARNING **: bbdb: Failed to add new contact: EBookStatus
returned 20

(evolution:10936): e-data-server-DEBUG: Loading categories from
"/home/austin.arrowsmith/.evolution/categories.xml"
(evolution:10936): e-data-server-DEBUG: Loaded 29 categories

report junk?? Spam: [Spam Detected] Watch your body change with Anatrim[Spam]

report junk?? Re:[Spam]

report junk?? Spam: Re: my linde[Spam]

(evolution:10936): evolution-mail-WARNING **: Can't get contacts: EBookStatus
returned 3

I was pretty much using the application only as an email program, against an
Exchange server.

I'll install the requested packages and let you know of any further information.

(I can't find any package using yumex's search with "debuginfo" in the search
field.)
Comment 5 Austin 2007-01-11 20:04:46 EST
Created attachment 145412 [details]
Another bug report created.

This was created over night, and was waiting for me in the morning.
Comment 6 Austin 2007-01-11 20:08:54 EST
Created attachment 145413 [details]
Another bug report created.

After the morning's bug report, I killed everything evolution (evolution
--force-shutdown), and then re-started evolution.

There were 10 emails waiting for me, of which a few were SPAM. I noticed that
the subjects of emails with SPAM in them are present in the bug report. Does
this indicate a problem with the spam scanner, from either evolution, or the
connection to the Exchange server?

I had read (clicked) two of the emails when the crash occurred. Evolution was
still changing the status bar with lots of information as I was quickly
skimming emails.

These crashes are becoming a multi-daily occurrence - quite annoying.
Comment 7 Austin 2007-01-14 18:43:50 EST
Created attachment 145544 [details]
Another bug report created.

This was found waiting for me Monday morning, whilst the computer was left on
over the weekend.
I then ran evolution --force-shutdown (twice to be sure...) and resumed
evolution.
Comment 8 Austin 2007-01-14 18:49:36 EST
Created attachment 145545 [details]
Another bug report created.

Ran Evolution from the quick launch bar in FC6. It probed the Exchange server,
and retrieved headers and told me I had 35 new emails. Shortly there after bug
buddy came up with this report. 23 emails remain un-retrieved.
Comment 9 Austin 2007-01-14 19:40:43 EST
Created attachment 145546 [details]
Another bug report created.

New mail arrived, and I think part way through processing the SPAM, bug buddy
popped up with another report. Unsure if it's the two processes trying to
access the information at once - mail-notification and evolution's spam
processing?
Comment 10 Austin 2007-01-15 19:29:10 EST
Created attachment 145642 [details]
Another bug report created.

This was left for me over night to see when I came in this morning. Evolution
had one unread email visible behind bug buddy.

Evolution --force-shutdown was then run, before starting evolution up again.
Comment 11 Austin 2007-01-15 19:33:28 EST
Created attachment 145643 [details]
Another bug report created.

When evolution was started up after the restart (and crash?) this morning, it
brought up bug buddy again after scanning the inbox. There was more than the
one unread email. When I came in this morning, there was one unread email
waiting behind bug buddy. When it loaded this time there was more unread email,
with the first one after the only unread email from earlier being SPAM.

I'm leaning towards this being a SPAM scanning related crash.
Comment 12 Austin 2007-01-16 01:10:44 EST
Created attachment 145655 [details]
Another bug report created.

This time, I was playing some Wolfenstein : Enemy Territory (windowed) (on a
break), when the notification tool popped up saying I have new SPAM, which was
shortly followed by bug buddy informing me of the attached report.

I'll disable mail notification to see if these crashes persist.

In the mean time, if you can figure out how I can stop the SPAM (which appears
to be the cause), I'd be most grateful! ;-)
Comment 13 Austin 2007-01-18 03:39:20 EST
Created attachment 145889 [details]
Another bug report created.

Mail notification was not running with this one, or the next one.

They are still occuring. :-/

Hope these reports help track this down.
Comment 14 Austin 2007-01-18 03:40:33 EST
Created attachment 145890 [details]
Another bug report created.

I'm unsure on the inclusion of MPlayer information in this report, as it wasn't
even running at the time.
Comment 15 Austin 2007-01-18 17:10:04 EST
Created attachment 145949 [details]
Another bug report created.

Another bug report found waiting for me when I got in this morning.
Comment 16 Austin 2007-01-19 01:03:00 EST
Created attachment 145967 [details]
Another bug report created.

I know a yum update was done earlier, so here's the latest list of evolution*
software:
[root@localhost ~]# rpm -qa | grep evolution*
mail-notification-evolution-plugin-3.0-10.fc6
evolution-connector-2.8.2-2.fc6
evolution-data-server-devel-1.8.2-2.fc6
evolution-webcal-2.7.1-6
evolution-data-server-1.8.2-2.fc6
evolution-2.8.2.1-3.fc6
Comment 17 Austin 2007-01-21 16:22:07 EST
Created attachment 146145 [details]
Another bug report created.

I started evolution from the command prompt sometime on Friday. This was
presented to me when I got in this morning, so must have happened some time
over the weekend.

This was all I saw at the prompt:
$ evolution 
CalDAV Eplugin starting up ...

** (evolution:16824): WARNING **: LDAP authentication failed (0x31)
** (evolution:16824): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:16824): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
(evolution:16824): e-data-server-DEBUG: Loading categories from
"/home/austin.arrowsmith/.evolution/categories.xml"
(evolution:16824): e-data-server-DEBUG: Loaded 29 categories
BBDB spinning up...

** (evolution:16824): WARNING **: bbdb: Failed to add new contact: EBookStatus
returned 20
Comment 18 Austin 2007-01-21 17:21:25 EST
Created attachment 146147 [details]
Another bug report created.

Closed down Evolution after the last crash, ran "evolution --force-shutdown",
and then re-ran evolution from the command-line (gnome-terminal). It showed me
I had 44 (new) emails, and was out-putting a lot of information to the status
bar quickly. I scrolled down to the latest email, and selected it. Half way
through reading it (the status bar was still changing when I opened the email),
I was presented with this bug report.

The command line at the time, read:
$ evolution 
CalDAV Eplugin starting up ...

** (evolution:28681): WARNING **: LDAP authentication failed (0x31)
** (evolution:28681): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:28681): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files

(evolution:28681): e-data-server-WARNING **: Error in execution: Failed to
retrieve message

(evolution:28681): e-data-server-WARNING **: Error in execution: Failed to
retrieve message
Comment 19 Matthew Barnes 2007-01-21 17:47:22 EST
Thanks for all the debug information and sorry I haven't been able to address
this sooner.  One thing I noticed that's common to all of the crash reports is
that /usr/libexec/evolution-exchange is the source of the crash.  So the bug is
somewhere in the evolution-connector package.

Unfortunately these reports lack the debugging symbols provided by the various
debuginfo packages, which are necessary for me to investigate the problem further.

Can I have you install the debuginfo packages mentioned in comment #3 as well as
a few more:

libsoup-debuginfo
libgnome-debuginfo
libgnomeui-debuginfo

If you have trouble finding the debuginfo packages in yumex (or other graphical
package manager), here's a few things to try:

1) In /etc/yum.repos.d/fedora-core.repo, make sure you have "enabled=1" in
   the [code-debuginfo] section.

2) If your graphical package manager still doesn't find them, try these
   commands from a terminal window:

      $ su
      <enter root password>
      # yum install evolution-debuginfo
      # yum install evolution-data-server-debuginfo
      ... etc ...
Comment 20 Austin 2007-01-21 19:55:28 EST
Yes, core-debuginfo was disabled. I should have checked that first. I'm
downloading the 23MB of debug packages you've suggested, and will let you know
when the next crash occurs.
Comment 21 Austin 2007-01-21 22:38:18 EST
Created attachment 146148 [details]
Another bug report created - with debuginfo enabled.

Didn't have to wait long. The information at the command prompt after running
evolution this time will be attached next.
Comment 22 Austin 2007-01-21 22:40:14 EST
Created attachment 146149 [details]
Output at the console.

Output from the console when the crash occured.
Comment 23 Austin 2007-01-21 23:41:25 EST
Created attachment 146151 [details]
Another bug report created - with debuginfo enabled.

Another one a short time later... Console output coming.
Comment 24 Austin 2007-01-21 23:42:35 EST
Created attachment 146152 [details]
Output at the console.

Console output when the crash occured. Generated with: evolution >& [filename]
Comment 25 Austin 2007-01-22 16:50:12 EST
Created attachment 146234 [details]
Another bug report created - with debuginfo enabled.

Another report from an overnight crash.
Comment 26 Austin 2007-01-22 16:51:37 EST
Created attachment 146236 [details]
Output at the console.

Here's the output that was left at the console after running "evolution >&
[filename]"

Let me know if there's any other flags you want me to run evolution with.
Comment 27 Austin 2007-01-23 02:35:06 EST
*** Bug 221950 has been marked as a duplicate of this bug. ***
Comment 28 Austin 2007-01-24 18:51:05 EST
Created attachment 146476 [details]
Another bug report created - with debuginfo enabled.

Another bug buddy report when I came in this morning.
A yum update was done yesterday, so new kernel, new (other stuff):

$ rpm -qa evolution* kernel*
kernel-xen-2.6.18-1.2849.fc6
kernel-xen-2.6.19-1.2895.fc6
evolution-debuginfo-2.8.0-7.fc6
evolution-connector-2.8.2-2.fc6
kernel-devel-2.6.19-1.2895.fc6
kernel-devel-2.6.18-1.2849.fc6
kernel-2.6.18-1.2849.fc6
evolution-data-server-debuginfo-1.8.0-11.fc6
kernel-2.6.19-1.2895.fc6
evolution-data-server-devel-1.8.2-2.fc6
evolution-webcal-2.7.1-6
evolution-data-server-1.8.2-2.fc6
kernel-headers-2.6.19-1.2895.fc6
evolution-2.8.2.1-3.fc6
Comment 29 Austin 2007-01-24 18:52:16 EST
Created attachment 146477 [details]
Output at the console.

The output at the console from redirection with evolution >& [outputfile]
Comment 30 Austin 2007-01-28 17:28:34 EST
Created attachment 146787 [details]
Another bug report created - with debuginfo enabled.

Found waiting for me after the long weekend. As soon as I restarted Evolution,
there were more new emails waiting for me, indicating that it failed to
retrieve all emails before the crash.
Comment 31 Austin 2007-01-28 17:29:07 EST
Created attachment 146788 [details]
Output at the console.

Attached is the output at the console when run as previously noted.
Comment 32 Austin 2007-01-30 19:06:48 EST
Created attachment 146978 [details]
Another bug report created - with debuginfo enabled.

Another crash waiting for me when I arrived. Evolution won't re-connect without
running "evolution --force-shutdown" first.
Comment 33 Austin 2007-01-30 19:07:46 EST
Created attachment 146979 [details]
Output at the console.

This is the output from running evolution at the console, and redirecting all
output to a file.
Comment 34 Austin 2007-01-30 19:09:15 EST
Created attachment 146980 [details]
Another bug report created - with debuginfo enabled.

When trying to run evolution again, it appeared to connect, and load all of the
emails it wasn't already aware of. Then while I was filling in the previous bug
report's details, bug-buddy presented me with this one.
Comment 35 Austin 2007-01-30 19:10:11 EST
Created attachment 146981 [details]
Output at the console.

Here's the (limited) output at the console from the brief instance of running
evolution.
Comment 36 Matthew Barnes 2007-10-04 23:25:05 EDT
Is this problem still present on Fedora 8 Test 2 or later?
Comment 37 Austin 2007-10-05 01:14:02 EDT
I am unable to test this, as I would not be permitted to run a TEST release on a
production system.
Comment 38 Matthew Barnes 2007-10-05 10:11:17 EDT
Thanks for responding.  Setting this to NEEDINFO for the time being as a
reminder to myself.
Comment 39 Matěj Cepl 2007-12-10 16:48:02 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Evolution.
If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 40 Austin 2007-12-10 19:21:49 EST
I no longer run the FC6 system, and now have a Fedora 7 system. I have not seen
this problem on this system.
Comment 41 Matthew Barnes 2007-12-10 20:10:40 EST
Thanks for the update.  Closing as WORKSFORME but feel free to reopen this bug
if you encounter the problem again.

Note You need to log in before you can comment on or make changes to this bug.