Bug 222357 - software updater: unscriptable object
software updater: unscriptable object
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 15:35 EST by Mark Jenks
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 15:56:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Jenks 2007-01-11 15:35:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060313 Fedora/1.5.0.1-9 Firefox/1.5.0.1 pango-text

Description of problem:
Component: Software Updater
Summary: TBd751b3d9 kmdl.py:91:postresolve_hook:TypeError: unsubscriptable object

Traceback (most recent call last):
  File "/usr/sbin/pup", line 292, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 592, in applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 408, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 402, in buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/kmdl.py", line 91, in postresolve_hook
    if commands[0] == 'update':
TypeError: unsubscriptable object

Local variables in innermost frame:
conduit: <yum.plugins.DepsolvePluginConduit instance at 0xb38fec8c>
commands: None
opts: None


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Running System Updater
2.
3.

Actual Results:


Expected Results:


Additional info:
This is MythDora 3.2
Comment 1 Jeremy Katz 2007-01-11 15:56:13 EST

*** This bug has been marked as a duplicate of 191630 ***
Comment 2 Mark Jenks 2007-01-11 17:00:28 EST
I don't have either of these packages installed?


$yum remove yum-downloadonly.noarch
$yum remove yum-tsflags.noarch
Comment 3 Mark Jenks 2007-01-11 17:06:00 EST
Actually, it looks like I might, but how do I remove extras?

 yum list | grep yum
yum.noarch                               2.6.0-1                installed
yum-plugin-kmdl.noarch                   0.1-2.fc5.at           installed
gnome-yum.i386                           0.1.3-1.fc5            extras
kyum.i386                                0.7.5-3.fc5            extras
yum.noarch                               2.6.1-0.fc5            updates
yum-changelog.noarch                     0.6-3.fc5              extras
yum-downloadonly.noarch                  0.6-3.fc5              extras
yum-fastestmirror.noarch                 0.6-3.fc5              extras
yum-fedorakmod.noarch                    0.6-3.fc5              extras
yum-kernel-module.noarch                 0.6-3.fc5              extras
yum-plugin-kmdl.noarch                   0.5-7.fc5.at           atrpms
yum-protectbase.noarch                   0.6-3.fc5              extras
yum-tsflags.noarch                       0.6-3.fc5              extras
yum-updateonboot.noarch                  0.6-3.fc5              extras
yum-utils.noarch                         0.6-3.fc5              extras
yum-versionlock.noarch                   0.6-3.fc5              extras
yumex.noarch                             1.0.3-3.0.fc5          extras

Note You need to log in before you can comment on or make changes to this bug.