Bug 191630 - Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' object has no attribute 'add_option'
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType'...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 191648 191654 191677 191801 192288 193264 196686 199863 201029 202477 202912 210794 219051 222357 222813 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-13 22:23 EDT by Leslie Satenstein
Modified: 2014-01-21 17:54 EST (History)
16 users (show)

See Also:
Fixed In Version: 1.0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-15 14:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback (1.17 KB, application/octet-stream)
2006-05-13 22:23 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2006-05-13 22:23:37 EDT
Description of problem:
Software Manager Crash

Version-Release number of selected component (if applicable):


How reproducible:
Every execution via gnome menu select. 

Steps to Reproduce:
1.Click on System Menu-->Software Manager-->Passoword
2.
3.
  
Actual results:

It is broken

Expected results:

To work with download manager in order to invoke rpm


Additional info:
Comment 1 Leslie Satenstein 2006-05-13 22:23:37 EDT
Created attachment 128987 [details]
Traceback
Comment 2 Leslie Satenstein 2006-05-13 22:25:38 EDT
Problem may have occurred between 1 May and today, when new updates were
installed on system. These updates pertained to YUMEX /Yum enhancements.
Comment 3 Luke Macken 2006-05-14 05:00:27 EDT
Looks like yum's option parser is getting lost somewhere along the way down to
the downloadonly plugin.  Not an update system issue :)
Comment 4 Luke Macken 2006-05-14 05:20:42 EDT
Doesn't look like a yum issue, seeing as how this parser seems to remain
optional through yum's code path to the plugin.  This could be resolved by
creating a dummy parser in pirut, or by adding some sanity checking to the
downloadonly plugin.  I would tend to lean toward the latter.
Comment 5 Seth Vidal 2006-05-14 08:51:06 EDT
for the immediate term you should remove yum-downloadonly then
yum/yumex/pirut/pup will work.
Comment 6 Jeremy Katz 2006-05-15 13:47:35 EDT
*** Bug 191648 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2006-05-15 13:47:37 EDT
*** Bug 191654 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2006-05-15 14:11:19 EDT
While more error checking in the plugin isn't a bad idea, the root cause here is
a typo in pirut.  Will be fixed in 1.0.3 which I'll push to rawhide and
updates-testing shortly
Comment 9 Jeremy Katz 2006-05-15 17:12:57 EDT
*** Bug 191801 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2006-05-18 15:51:01 EDT
*** Bug 192288 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2006-06-26 10:40:26 EDT
*** Bug 196686 has been marked as a duplicate of this bug. ***
Comment 12 Akb 2006-06-28 05:47:01 EDT
I removed the DownloadOnly plugin using rpm, add/remove software got working. I
thing the bug is in the downloadonly.py plugin.
Comment 13 Leslie Satenstein 2006-06-28 20:01:18 EDT
Love the simple fixes.  Keep them up. Lets look for yumex to be legacy level
software (bug free)
Comment 14 Jeremy Katz 2006-07-19 20:36:56 EDT
*** Bug 191677 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2006-08-07 11:11:20 EDT
*** Bug 201029 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2006-08-14 20:38:26 EDT
*** Bug 202477 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Katz 2006-08-16 20:54:48 EDT
*** Bug 202912 has been marked as a duplicate of this bug. ***
Comment 18 Jeremy Katz 2006-10-17 08:39:59 EDT
*** Bug 210794 has been marked as a duplicate of this bug. ***
Comment 19 Y. Ming 2006-10-17 09:54:16 EDT
Resolved by 
$yum remove yum-downloadonly.noarch
$yum remove yum-tsflags.noarch
Comment 20 Jeremy Katz 2006-10-30 13:40:44 EST
*** Bug 193264 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2006-12-11 13:06:55 EST
*** Bug 219051 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2007-01-11 15:56:26 EST
*** Bug 222357 has been marked as a duplicate of this bug. ***
Comment 23 Jeremy Katz 2007-01-16 10:10:30 EST
*** Bug 222813 has been marked as a duplicate of this bug. ***
Comment 24 Jeremy Katz 2007-08-10 15:10:49 EDT
*** Bug 199863 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.