Bug 222393 - cdrom test fails due to /bin/cp being blocked by SELinux
cdrom test fails due to /bin/cp being blocked by SELinux
Status: CLOSED DUPLICATE of bug 218124
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 19:19 EST by Sun Certifications
Modified: 2008-07-16 17:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-12 11:00:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sun Certifications 2007-01-11 19:19:57 EST
Description of problem:
SELinux (which must be enabled) seems to be causing the CDROM test to fail.

Version-Release number of selected component (if applicable):
hts-5.0-14

How reproducible:
Perform "hts certify --test=cdrom"

Steps to Reproduce:
1.hts certify --test=cdrom (it asks you to put in a data CD)

  
Actual results:

From the hts window right at the beginning of the test:
cp: cannot create directory `./device-copy': Permission denied

On the System, SELinux popup warns us that:
SELinux is preventing /bin/cp (iso9960_t) "associate" to device-copy (fs_t).

and the following info is found in the /var/log/audit/audit.log file:

type=AVC msg=audit(1168386500.282:22): avc:  denied  { associate } for  pid=6392
comm="cp" name="device-copy" scontext=system_u:object_r:iso9660_t:s0
tcontext=system_u:object_r:fs_t:s0 tclass=filesystem


Expected results:
Read of data CD should work as expected


Additional info:
the test performs CD(data), CD-RW and DVD.
Both CD and DVD tests fail while CD-RW seems to pass
Comment 1 Greg Nichols 2007-01-12 11:00:31 EST

*** This bug has been marked as a duplicate of 218124 ***

Note You need to log in before you can comment on or make changes to this bug.