Bug 218124 - HTS: cdrom test failed
HTS: cdrom test failed
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: YangKun
: Reopened
: 222300 222393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 16:47 EST by Danny Trinh
Modified: 2008-07-16 17:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 22:02:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
plan text (1.49 KB, text/xml)
2006-12-01 16:47 EST, Danny Trinh
no flags Details
Results rpm (6.52 MB, application/x-rpm)
2006-12-06 11:13 EST, Danny Trinh
no flags Details
results rpm (6.78 MB, application/x-rpm)
2007-01-09 13:59 EST, Danny Trinh
no flags Details
selinux errors (1.84 KB, text/plain)
2007-01-10 17:29 EST, Danny Trinh
no flags Details
Failed cdrom test result rpm (888.91 KB, application/x-rpm)
2007-01-10 17:30 EST, Danny Trinh
no flags Details
output.log (261.03 KB, application/octet-stream)
2007-01-19 14:23 EST, Danny Trinh
no flags Details
This HTS.R21 test still failed DVD+RW test. Attached is output.log (8.71 MB, text/plain)
2007-01-30 10:19 EST, Danny Trinh
no flags Details
output.log of cdrom test of external USB DVD-ROM drive (DVD-ROM DV-28PU) (8.75 MB, text/plain)
2007-02-06 13:42 EST, Danny Trinh
no flags Details
hal_USB-DVDROM.txt (78.87 KB, text/plain)
2007-02-07 11:15 EST, Danny Trinh
no flags Details
X-CD-Roast snapshot (35.02 KB, image/png)
2007-02-09 11:01 EST, Danny Trinh
no flags Details
everything about this cd-rw/dvd-rom drive (147.49 KB, application/gzip)
2007-03-02 18:02 EST, Danny Trinh
no flags Details

  None (edit)
Description Danny Trinh 2006-12-01 16:47:29 EST
Description of problem:
After running "hts discover", I check the /var/hts/plan.xml and see that hts
recognized DVD +/-RW as DVD+RW. Also, when running "hts certify", the output
said "Your CD/DVD-ROM device /dev/hda supports (cd-rw,dvd,burnfree)".
Version-Release number of selected component (if applicable):
hts-5.0-9

How reproducible:
easy

Steps to Reproduce:
1.install RHEL5-x86_64 beta2 (everything installed)
2.Install hts*.rpm and dependences
3.run "hts plan"
4.run "hts discover"
5.run "hts certify"
  
Actual results:
The test is not correct for DVD +/-RW

Expected results:
Must test as the DVD type.

Additional info:
Comment 1 Danny Trinh 2006-12-01 16:47:29 EST
Created attachment 142625 [details]
plan text
Comment 2 YangKun 2006-12-05 22:38:39 EST
could you please run "hts submit" on your test machine and attach the result rpm
here ? 

we need more info.
Comment 3 Danny Trinh 2006-12-06 11:13:56 EST
Created attachment 142962 [details]
Results rpm

This test shows the cdrom test passed, but the test itself is incorrectly for
this  device. It supposed to test DVD writer (both format DVD +/- RW).
Comment 4 YangKun 2006-12-06 21:52:58 EST
the Label for this cdrom device is "TEAC DVD+RW DV-W58E"
http://www.teac.co.jp/dspd/product/optical/dv-w58e.html

the system finds this cdrom as :
-
class: CDROM
bus: IDE
detached: 0
device: hda
desc: "TEAC DVD+RW DV-W58E"
-
-----------------------
Dec  5 06:18:11 localhost kernel: hda: TEAC DVD+RW DV-W58E, ATAPI CD/DVD-ROM drive
-----------------------

Typicall, a DVD+R/DVD+RW device now can also handle DVD-R/DVD-RW media too . The
"+" and "-" do not have too much differences, so the "+/-" is not the big issue
here. 

The problem is the system recognizes this device as a COMBO device , supports
CD+/-RW and DVD-ROM , but no DVD+/-R or DVD+/-RW support:
---------------------------------------
# cat proc/sys/dev/cdrom/info 
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:             hda
drive speed:            40
drive # of slots:       1
Can close tray:         1
Can open tray:          1
Can lock tray:          1
Can change speed:       1
Can select disk:        0
Can read multisession:  1
Can read MCN:           1
Reports media changed:  1
Can play audio:         1
Can write CD-R:         1
Can write CD-RW:        1
Can read DVD:           1
Can write DVD-R:        0
Can write DVD-RAM:      0
Can read MRW:           1
Can write MRW:          1
Can write RAM:          1
---------------------------------------

So the CDROM test only checks (cd-rw,dvd,burnfree). The HTS itself works
correctly. This is not an HTS's bug.

I think following possibilities may lead to this problem:
  o The cdrom device is overly used and has been used for quite a long time, so
it loses the capability of DVD+/-RW
  o need special device driver

Dose this cdrom device work well(support DVD+/-RW) under other OS ?
Comment 5 YangKun 2006-12-06 22:12:48 EST
I checked the detailed spec of this device , it supports DVD+R/RW in
"Write/Read" mode and supports DVD-R/RW in only "Read" mode. So for us, it is a
"DVD+R/RW" drive.
Comment 6 Danny Trinh 2006-12-08 10:46:29 EST
I think you're right. But the test is running as dvd read only. It doesn't do
writing function (I used DVD+RW media).
Do I need to close this bug and open another one or just change the summary?
Comment 7 Danny Trinh 2006-12-11 11:03:23 EST
After checking output.log, I saw that this test didn't even test DVD read only
test. It failed to "cp files to ./device-copy". But it said on "hts print" that
the test passed. ??????????????????
Comment 8 YangKun 2006-12-12 02:25:10 EST
I've made an update of the CDROM test, will check both DVD-R/RW and DVD+R/RW and
fixed this "DVD read only" problem. the update should be available in hts-5.0-15 .
Comment 9 Danny Trinh 2007-01-09 13:59:19 EST
Created attachment 145185 [details]
results rpm

cdrom test still failed on hts-5.0-15. See attachment.
Comment 10 Irina Boverman 2007-01-09 14:03:05 EST
reopening based on comment #9.
Comment 12 Danny Trinh 2007-01-10 17:29:27 EST
Created attachment 145290 [details]
selinux errors

It seemed that SELinux is involved to this bug. Please see attachment.
Comment 13 Danny Trinh 2007-01-10 17:30:56 EST
Created attachment 145291 [details]
Failed cdrom test result rpm
Comment 15 Greg Nichols 2007-01-11 15:54:46 EST
*** Bug 222300 has been marked as a duplicate of this bug. ***
Comment 17 Greg Nichols 2007-01-12 11:00:32 EST
*** Bug 222393 has been marked as a duplicate of this bug. ***
Comment 19 YangKun 2007-01-19 00:24:50 EST
fixed in R17 .
Comment 20 Danny Trinh 2007-01-19 14:23:04 EST
Created attachment 146023 [details]
output.log

I retest. It seems working with CD-RW, DVD-ROM, but DVD+RW. Please check the
output.log. It perform the test over 4.7GB capacity limit.
Comment 21 YangKun 2007-01-22 01:03:21 EST
fixed in hts R18 .
Comment 22 Danny Trinh 2007-01-23 11:49:42 EST
When is hts R18 available to testers for verifying?
Comment 23 YangKun 2007-01-25 00:22:12 EST
R18 is built and will be available very soon.
Comment 24 Danny Trinh 2007-01-30 10:19:44 EST
Created attachment 146917 [details]
This HTS.R21 test still failed DVD+RW test. Attached is output.log

I tried to "hts submit", but failed. Below are error messages.
[root@localhost ~]# hts submit
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
writing results to
/var/log/hts/Dell_Inc.-PowerEdge_SC440-Tikanga4.92_x86_64_results
copied attachment file localhost.localdomain.2007013082901.tar.bz2 for info
test
copied attachment file localhost.localdomain.2007013082901.tar.bz2 for info
test
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 73, in do
    return self.doSubmit()	
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 369, in
doSubmit
    report.WriteResultsRPM(self.LogDirectory)
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 181, in
WriteResultsRPM
    self.WriteLogForRPM(testsByName[testName], runNumber, [byTestDirectory,
byRunDirectory])
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 215, in
WriteLogForRPM
    log.write(outputLog)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xb1' in position
25473: ordinal not in range(128)
[root@localhost ~]#
Comment 25 YangKun 2007-01-30 11:23:11 EST
fixed in hts-5.0 R22
Comment 26 YangKun 2007-02-02 00:30:48 EST
the fix is in hts-5.0 R23, not in R22. sorry for the inaccuracy.
Comment 27 Danny Trinh 2007-02-06 13:42:40 EST
Created attachment 147500 [details]
output.log of cdrom test of external USB DVD-ROM drive (DVD-ROM DV-28PU)

I tried "hts submit" and got errors below.
[root@localhost ~]# hts submit
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 73, in do
    return self.doSubmit()	
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 366, in
doSubmit
    self.load()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 104, in
load
    self.results.load(self.resultsFile)     
  File "/usr/lib/python2.4/site-packages/hts/certificationtest.py", line 89, in
load
    self.document = parse(file)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/minidom.py", line 1915,
in parse
    return expatbuilder.parse(file)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line
930, in parse
    result = builder.parseFile(file)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line
207, in parseFile
    parser.Parse(buffer, 0)
xml.parsers.expat.ExpatError: reference to invalid character number: line 120,
column 21
[root@localhost ~]#
Comment 28 Danny Trinh 2007-02-06 13:47:46 EST
Comment #27(In reply to comment #27)
This is tested with HTS R23.
Comment 29 YangKun 2007-02-06 23:23:56 EST
Warning and error messages:
-------------------------------------
....
  Start testing DVD+R ... 
WARNING: /dev/scd0 already carries isofs!
....
:-[ MODE SENSE failed with SK=5h/ASC=24h/ACQ=00h]: Input/output error
mkisofs: Broken pipe. cannot fwrite 6144*1
....
-------------------------------------
Seems an non-blank DVD+R disk is used to test DVD+R , this is NOT acceptable.
Please make sure you are using a NEW blank DVD+R disk to test DVD+R. 

Also, it's strange to test DVD+R with TEAC DV-28PU External USB DVD-ROM Drive,
it does not support DVD+R according to the spec on
http://support.ap.dell.com/support/edocs/storage/P113634/en/spec.htm

Please plug in the TEAC DV-28PU External USB DVD-ROM Drive and then run the
following command : 
    # hal-device > hal.log
and submit the hal.log file here.


Thanks
Comment 30 YangKun 2007-02-06 23:46:22 EST
(In reply to comment #27)
> Created an attachment (id=147500) [edit]
> output.log of cdrom test of external USB DVD-ROM drive (DVD-ROM DV-28PU)
> 
> I tried "hts submit" and got errors below.
> [root@localhost ~]# hts submit
> loaded configuration /var/hts/config.xml
> loaded plan /var/hts/plan.xml
> Traceback (most recent call last):
>   File "/usr/bin/hts", line 113, in ?
>     success = hts.do(args)
>   File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 73, in do
>     return self.doSubmit()	
>   File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 366, in
> doSubmit
>     self.load()
>   File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 104, in
> load
>     self.results.load(self.resultsFile)     
>   File "/usr/lib/python2.4/site-packages/hts/certificationtest.py", line 89, in
> load
>     self.document = parse(file)
>   File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/minidom.py", line 1915,
> in parse
>     return expatbuilder.parse(file)
>   File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line
> 930, in parse
>     result = builder.parseFile(file)
>   File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line
> 207, in parseFile
>     parser.Parse(buffer, 0)
> xml.parsers.expat.ExpatError: reference to invalid character number: line 120,
> column 21
> [root@localhost ~]# 
> 


The "reference to invalid character number" error may caused by data
inconsistency after user manually killed(Ctrl-C) running tests. Please remove
all *.xml files under /var/hts/ directory , then re-run "hts plan --server
x.x.x.x" and "hts certify ..." etc.
Comment 31 YangKun 2007-02-07 01:13:07 EST
Currently, the CDROM test will check for media types and status, it will quit
with error if user insert wrong type of media or corrupted disk. 
We'll consider such enhancement like to let user re-insert disks if they insert
wrong type or corrupted media for the next version of HTS.
Comment 32 Danny Trinh 2007-02-07 11:15:40 EST
Created attachment 147566 [details]
hal_USB-DVDROM.txt
Comment 33 Danny Trinh 2007-02-07 11:19:28 EST
(In reply to comment #29)
Yes, It's really strange. I'm not so sure this message is for this bug# or
bug#225438.
Please check both bugs. Thanks,
Comment 34 YangKun 2007-02-08 08:58:38 EST
HAL shows this TEAC DV-28PU External USB DVD-ROM
Drive(TEAC_DVD_ROM_DV_28PU_DEF10BAB3A94) does support DVD+R, this is
inconsistent with the spec.

Anyway, if HAL sees it supports DVD+R, then we will check this feature. So
please prepare a NEW blank DVD+R disc to re-test. 

Thanks
Comment 35 Danny Trinh 2007-02-09 11:01:36 EST
Created attachment 147783 [details]
X-CD-Roast snapshot

According to X-CD-Roast, this DV-28PU external dvd-rom is read-only.
What is the different between HAL and X-CD-Roast, when they check for the
functionality of this DVD?

Please see the snapshot image.
Comment 36 Danny Trinh 2007-02-09 11:11:37 EST
Also, this device passed rhr2 test on rhel4. There is no reason hts is worse
than rhr2, isn't it?
Comment 37 YangKun 2007-02-11 21:58:52 EST
(In reply to comment #35)
> Created an attachment (id=147783) [edit]
> X-CD-Roast snapshot
> 
> According to X-CD-Roast, this DV-28PU external dvd-rom is read-only.
> What is the different between HAL and X-CD-Roast, when they check for the
> functionality of this DVD?
> 
> Please see the snapshot image. 

By default, X-CD-Roast CAN NOT handle DVD+R/DVD+RW media/feature, you can not
see DVD+R/DVD+RW in the feature list, only CD-R/CD-RW/DVD-ROM/DVD-R/DVD-RAM are
listed.

HAL will list all features/media-types an optical device supports, following are
the features which TEAC DV-28PU External USB DVD-ROM supports:
--------------------------------------
  storage.cdrom.hddvdrw = false  (bool)
  storage.cdrom.hddvdr = false  (bool)
  storage.cdrom.hddvd = false  (bool)
  storage.cdrom.bdre = false  (bool)
  storage.cdrom.bdr = false  (bool)
  storage.cdrom.bd = false  (bool)
  storage.cdrom.dvdplusrdl = true  (bool)
  storage.cdrom.dvdplusrwdl = false  (bool)
  storage.cdrom.dvdplusrw = false  (bool)
  storage.cdrom.dvdplusr = true  (bool)
  storage.cdrom.dvdram = false  (bool)
  storage.cdrom.dvdrw = false  (bool)
  storage.cdrom.dvdr = false  (bool)
  storage.cdrom.dvd = true  (bool)
  storage.cdrom.cdrw = false  (bool)
  storage.cdrom.cdr = false  (bool)
--------------------------------------
we can see storage.cdrom.dvdplusr and storage.cdrom.dvdplusrdl are "true", this
means the optical drive can write to DVD+R discs(DVD+R Dual-Layer discs).

So,  please prepare a NEW blank DVD+R disc to re-test. 

Thanks
Comment 38 YangKun 2007-02-11 22:12:17 EST
(In reply to comment #36)
> Also, this device passed rhr2 test on rhel4. There is no reason hts is worse
> than rhr2, isn't it?
> 

RHR2 does NOT check for DVD+R/DVD+RW features.
Checking for DVD+R/DVD+RW are added in HTS.
Comment 39 YangKun 2007-02-11 22:46:18 EST
According to TEAC DV-28PU External USB DVD-ROM Drive's spec:
http://support.ap.dell.com/support/edocs/storage/P113634/en/spec.htm

"write to DVD+R discs" is NOT supported. However, we find this device does
support DVD+R. This is inconsistent. 

If the spec is accurate and up-to-date. If Dell intent to treat this device as a
CD/DVD read-only(no DVD+R) device, then there is no need to test DVD+R, we will
make an exception for this device.
Comment 40 Danny Trinh 2007-03-02 18:02:05 EST
Created attachment 149161 [details]
everything about this cd-rw/dvd-rom drive

Another drive failed the same. Please see attached file.
Comment 41 YangKun 2007-03-05 05:36:24 EST
cd-rw/dvd-rom did passed on this device.

HAL finds this optical device also supports DVD+RW, so the CDROM test continues
to check DVD+RW . But this drive seems can not write DVD+RW disks. 
Interestingly, this issue only applies to TEAC's optical devices. This maybe an
HAL's bug .

Anyway, if the spec says the device only supports cd-rw/dvd-rom, and we do see
cd-rw/dvd-rom passed in the CDROM test's output log, then we can certify this
device regardless the DVD+RW's failure.

What we are checking in the CDROM test are those features listed in the spec.
Features which outside the spec are not required.

Note You need to log in before you can comment on or make changes to this bug.