Bug 222680 - New 8gig iPod Nanos doen't work with banshee
New 8gig iPod Nanos doen't work with banshee
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-01-15 13:04 EST by Joshua Jensen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-14 15:53:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2007-01-15 13:04:14 EST
Description of problem:

I've got udev and hal seeing the ipod, thanks to udev-095-17.fc6
(BZ # 220543).

dmesg now shows this:

SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
  Vendor: Apple     Model: iPod              Rev: 1.62
  Type:   Direct-Access                      ANSI SCSI revision: 00
usb-storage: device scan complete
scsi 0:0:0:0: Attached scsi generic sg0 type 0
SCSI device sda: 3964928 2048-byte hdwr sectors (8120 MB)
sda: Write Protect is off
sda: Mode Sense: 68 00 00 08
sda: assuming drive cache: write through
SCSI device sda: 3964928 2048-byte hdwr sectors (8120 MB)
sda: Write Protect is off
sda: Mode Sense: 68 00 00 08
sda: assuming drive cache: write through
 sda: sda1 sda2
sd 0:0:0:0: Attached scsi removable disk sda

"lshal | grep -i ipod" now shows this:

 info.udi = '/org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A2700192
DBC01'  (string)
  info.product = 'iPod'  (string)
  storage.serial = 'Apple_iPod_000A2700192DBC01'  (string)
  storage.model = 'iPod'  (string)
  block.storage_device = '/org/freedesktop/Hal/devices/storage_serial_Apple_iPod
_000A2700192DBC01'  (string)

udev and hal are happy, but Banshee still doesn't see the Nano. Bill Peck swears
it works... but it doesn't over here.  I've even tried libgpod-0.4.0-0.fc6 from
freshrpms as he suggested... no dice.

Version-Release number of selected component (if applicable):

FC6, all updates as of today
libgpod-0.4.0-0.fc6 from freshrpms
Comment 1 Joshua Jensen 2007-01-15 13:08:32 EST
I noticed that libgpod-0.4.2 came out *today*... but can't get it to compile so
I can't tell if that would help me or not.  Perhaps we can get libgpod updated
to this version in Fedora Core 6
Comment 2 Todd Zullinger 2007-01-21 19:35:53 EST
Joshua, I don't think libgpod is required or used by banshee.  I believe your
trouble is more likely with libipoddevice.

Does your nano have an empty iPod_Control/Device/SysInfo file?  That and other
issues have been fixed in libipoddevice >= 0.5.  You can find 0.5.2 in rawhide.
 It might be worth trying to rebuild that to see if it helps banshee find your
ipod.  I don't know if banshee needs to be updated along with libipoddevice or not.

That said, libgpod-0.4.2 has been available in updates-testing since the 17th. 
It'll probably get pushed to updates very soon.
Comment 3 Joshua Jensen 2007-02-02 18:16:54 EST
Trying a binary package I built from libipoddevice-0.5.2-1.fc7.src.rpm
I'll let you know what we find.
Comment 4 Joshua Jensen 2007-11-14 15:53:33 EST
No longer have access to iPod nanos :-(

Note You need to log in before you can comment on or make changes to this bug.