Bug 22275 - I just purchased ver 7.0 and tried to install it -- it failed with the following description:
Summary: I just purchased ver 7.0 and tried to install it -- it failed with the follow...
Status: CLOSED DUPLICATE of bug 19523
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-14 00:42 UTC by Paul A. Valente
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-14 16:49:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul A. Valente 2000-12-14 00:42:25 UTC
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
    if todo.doInstall ():
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in doInstall
    self.fstab.makeFilesystems ()
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in makeFilesystems
    isys.umount("/mnt/loophost")
  File 
"/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables 
in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2000-12-14 16:49:10 UTC

*** This bug has been marked as a duplicate of 19523 ***

Comment 2 Brock Organ 2000-12-21 19:35:37 UTC
There is an update disk that should fix this. Download it, gzip it, dd (or
 rawrite) it to a floppy disk. When you boot into the install, specify "linux
 updates" at the boot prompt. The install will prompt you to install this floppy
 when it needs it.

 ftp://people.redhat.com/ewt/mountupd.img.gz

 It should fix this problem. Please reopen this bug if it doesn't.

Comment 3 Paul A. Valente 2000-12-21 20:56:20 UTC
The file to correct the problem is a little bit too large to fit on a 1.4M floppy.  My 1.4M floppy formats out to 1,457,664 bytes and that correction file is 
1,474,560 bytes.


Note You need to log in before you can comment on or make changes to this bug.