Bug 222781 - [indic] Cursor navigation behaviour is unexpected during Delete composed character with Backspace key
[indic] Cursor navigation behaviour is unexpected during Delete composed char...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n
: 238903 (view as bug list)
Depends On: 213197
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 01:10 EST by Sachin Tawniya
Modified: 2008-05-07 12:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 12:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 142636 None None None Never

  None (edit)
Description Sachin Tawniya 2007-01-16 01:10:18 EST
+++ This bug was initially created as a clone of Bug #213197 +++

Description of problem:
When delete composed character with Backspace key, then cursor navigation is not 
good, cursor is moved to some other character to RIght hand side

Version-Release number of selected component (if applicable):
qt-3.3.6-13

How reproducible:
Everytime in composed character in word

Steps to Reproduce:
1.open kedit
2. Please select keyboard 'Jhelum' from scim-Punjabi. 
3. Type following word: kdho
4. move cursor 1 position to right side from [HOME]
5. Press Backspace once

Actual results:
cursor behavior unexpected.

Expected results:
it should be at same position.



Additional info:
Comment 1 A S Alam 2007-03-07 04:45:12 EST
behaviour is still present in Devel (Fedora7), so moving forward this bug.
qt-3.3.7-2.fc7
Comment 2 A S Alam 2007-05-03 19:33:04 EDT
*** Bug 238903 has been marked as a duplicate of this bug. ***
Comment 3 Rahul Bhalerao 2008-03-10 03:49:26 EDT
The Split Cursor feature is not yet implemented for QT. Otherwise this is not a
bug. 

Note You need to log in before you can comment on or make changes to this bug.