Bug 238903 - Cursor navigation behaviour is unexpected during Delete composed character with Backspace key
Summary: Cursor navigation behaviour is unexpected during Delete composed character wi...
Status: CLOSED DUPLICATE of bug 222781
Alias: None
Product: Fedora
Classification: Fedora
Component: qt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: i18n
Depends On: 213197
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 18:58 UTC by A S Alam
Modified: 2013-07-03 00:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 23:32:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test Case - Text File (150 bytes, text/plain)
2007-05-03 19:00 UTC, A S Alam
no flags Details

Comment 1 A S Alam 2007-05-03 19:00:47 UTC
Created attachment 154064 [details]
Test Case - Text File

Comment 2 A S Alam 2007-05-03 19:02:32 UTC
Description of problem:
When delete composed character with Backspace key, then cursor navigation is not 
good, cursor is moved to some other character to RIght hand side

Version-Release number of selected component (if applicable):
qt-3.3.6-13

How reproducible:
Everytime in composed character in word

Steps to Reproduce:
1.open kedit
2. paste test from test case
3. move cursor 1 position to right side from [HOME]
 4.Press Backspace once

Actual results:
cursor move to 3 position

Expected results:
it should be at same position

1) Please select keyboard 'Jhelum' from scim-Punjabi. Type following word:
kdho (ਪ੍ਰਧਾਨਗੀ)

(move to end, move cursor 1 left side and press backspace. Now check cursor. 

2) Problem exist in words where halant (0A4D) is used in Punjabi.

Comment 3 A S Alam 2007-05-03 19:06:21 UTC
Tested version:
qt-3.3.8-4.fc7

Comment 4 A S Alam 2007-05-03 23:32:30 UTC

*** This bug has been marked as a duplicate of 222781 ***


Note You need to log in before you can comment on or make changes to this bug.