Bug 222813 - Software Updater results in error and exit (and with no updates)
Software Updater results in error and exit (and with no updates)
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 06:25 EST by boston924
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 10:10:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output file from "system updater" error (1.00 KB, application/octet-stream)
2007-01-16 06:25 EST, boston924
no flags Details

  None (edit)
Description boston924 2007-01-16 06:25:00 EST
Description of problem:
Have run "software updater" under the "system" menu.  It finds parts to update,
and tries to update, but experiences an error and quits, with seemingly no
updates performed.  (Note, I couldn't find "software updater" in the "component
list" on this bug submission page.)

Version-Release number of selected component (if applicable):


How reproducible:
tried it several times, with the same failure each time

Steps to Reproduce:
1. listed above
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 boston924 2007-01-16 06:25:00 EST
Created attachment 145673 [details]
Output file from "system updater" error
Comment 2 boston924 2007-01-16 06:26:37 EST
This is the info from the logfile attachment:

Component: Software Updater
Summary: TBd751b3d9 kmdl.py:91:postresolve_hook:TypeError: unsubscriptable object

Traceback (most recent call last):
  File "/usr/sbin/pup", line 292, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 592, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 408, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 402, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/kmdl.py", line 91, in postresolve_hook
    if commands[0] == 'update':
TypeError: unsubscriptable object

Local variables in innermost frame:
conduit: <yum.plugins.DepsolvePluginConduit instance at 0xb38ae2ec>
commands: None
opts: None
Comment 3 Jeremy Katz 2007-01-16 10:10:21 EST

*** This bug has been marked as a duplicate of 191630 ***

Note You need to log in before you can comment on or make changes to this bug.