Bug 223236 - RHEL5-RC-S6 :snmpd error messages seen in /var/log/messages when channel bonding is configured
RHEL5-RC-S6 :snmpd error messages seen in /var/log/messages when channel bond...
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
David Lawrence
: 245584 371811 (view as bug list)
Depends On:
Blocks: 223278
  Show dependency treegraph
Reported: 2007-01-18 11:28 EST by Raghavendra Biligiri
Modified: 2010-10-22 03:57 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0498
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-07 12:16:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Attached /var/log/messages (119.80 KB, text/plain)
2007-01-18 11:31 EST, Raghavendra Biligiri
no flags Details
Network config files and modprobe.conf (10.00 KB, application/x-tar)
2007-05-15 10:44 EDT, Raghavendra Biligiri
no flags Details

  None (edit)
Description Raghavendra Biligiri 2007-01-18 11:28:16 EST
Description of problem:
On RHEL5-B2-Snapshot6(kernel-2.6.18-1.2961.el5),when we configure channel 
bonding and then start the snmpd service,we find the below messages logged 
in /var/log/messages.

Jan 18 20:37:41 Mustang-5 snmpd[4200]: error on subcontainer 'ia_addr' insert (-
Jan 18 20:37:41 Mustang-5 snmpd[4200]: error on subcontainer 'ia_addr' insert (-
Jan 18 20:37:41 Mustang-5 snmpd[4200]: error on subcontainer '' insert (-1)
Jan 18 20:37:41 Mustang-5 snmpd[4200]: error on subcontainer '' insert (-1)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install RHEL5-B2-Snapshot6(kernel-2.6.18-1.2961.el5)
2.Configure Channel bonding(I used two interfaces and configured mode 1) 
3.Restart the snmpd service
Actual results:
snmpd error messages logged in /var/log/messages

Expected results:
snmpd error messages should not be seen in /var/log/messages

Additional info:
Attached /var/log/messages
Comment 1 Raghavendra Biligiri 2007-01-18 11:31:58 EST
Created attachment 145926 [details]
Attached /var/log/messages
Comment 2 Raghavendra Biligiri 2007-01-20 02:43:09 EST
Issue is reproducible on RHEL5-B2-Snapshot7(kernel-2.6.18-1.3002.el5).

Found dicussions on this issue on the mailing list.
Comment 3 Raghavendra Biligiri 2007-01-23 04:07:09 EST
Issue not seen with net-snmp-5.1.2-11.EL4.7(RHEL4-U4).
Comment 4 Amit Bhutani 2007-01-24 10:08:03 EST
Tracking this against RHEL 5.1.0 as the chances of this making RHEL 5.0.0 at
this point appear to be slim to none.
Comment 7 Raghavendra Biligiri 2007-03-16 09:37:18 EDT
Issue not reproducible with net-snmp-5.4-1.
Comment 9 RHEL Product and Program Management 2007-03-21 18:49:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 13 Jan Safranek 2007-04-30 03:41:17 EDT
I have set up the channel bonding according to http://kbase.redhat.com/faq/
FAQ_79_258.shtm. I have tried net-snmp*-5.3.1-14.0.1.el5, net-snmp*-5.4-1.fc7 
and net-snmp*-5.4-13.fc7, all with the same result: the bug is still present, I 
can see 'error on subcontainer 'ia_addr' insert (-1)' in the log.

Could you please provide me the config files for your channel bonding? And 
could you please double check the log file, if the message really disappears?
Comment 19 Raghavendra Biligiri 2007-05-15 10:40:32 EDT
I have attached the config files for channel bonding and modprobe.conf file.
Below are the steps that I followed to test this issue with net-snmp-5.4-1:
1. Configured channel bonding (mode=1) and restarted network service.
2. Installed net-snmp-5.4-1.src.rpm
3. Ran ./configure in the net-snmp source directory. Did not make any changes, 
left everything as default during configuration.
4. Executed make and then make install.
5. Changed /usr/sbin/snmpd to /usr/sbin/local/snmpd in the /etc/init.d/snmpd 
6. Restarted the snmpd service.
7. Log messages displayed that the "no access control information is 
configured" and displayed the net-snmp version number.Error messages as 
reported in this issue was not seen.

Let me know if I am missing something while reproducing the issue with net-snmp-
Comment 20 Raghavendra Biligiri 2007-05-15 10:44:22 EDT
Created attachment 154738 [details]
Network config files and modprobe.conf
Comment 21 Jan Safranek 2007-05-16 07:10:52 EDT
net-snmp build in this way does not support IPv6 MIBs. This may be sufficient
for you, but when IPv6 support is enabled (e.g. by calling rpmbuild -bc
net-snmp.spec), the error is back. The interfaces bond0 and eth0/1 share the
same IPv6 link address and net-snmp does not like it. Net-snmp will work, only
IP-MIP does not support multiple interfaces with one address -> strange log
message appears. We can try to log something more meaningful and log it only
once, not every 30 sec.
Comment 23 Jan Safranek 2007-06-26 03:06:13 EDT
*** Bug 245584 has been marked as a duplicate of this bug. ***
Comment 26 lunix4knmi 2007-08-06 09:52:25 EDT
Comment 28 errata-xmlrpc 2007-11-07 12:16:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

Comment 31 Jan Safranek 2007-11-09 03:20:17 EST
*** Bug 371811 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.