Bug 2232579 - Geolocation in Anaconda should be turned off on the Fedora Workstation live image
Summary: Geolocation in Anaconda should be turned off on the Fedora Workstation live i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 39
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: anaconda-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
: 2231921 2235610 2236034 (view as bug list)
Depends On:
Blocks: Anaconda40WebUITracker F39BetaBlocker F39BetaFreezeException F39FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2023-08-17 13:10 UTC by Martin Kolman
Modified: 2023-09-06 01:26 UTC (History)
8 users (show)

Fixed In Version: anaconda-39.32.1-1.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-01 03:33:28 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Martin Kolman 2023-08-17 13:10:00 UTC
Right now Anaconda performs geolocation automatically on the Fedora Workstation live image. 

This interferes with Genome Initial Setup setting the language before Anaconda is launched. 

Therefore Anaconda geolocation support should be disabled on Fedora Workstation live image.

Reproducible: Always

Steps to Reproduce:
1. boot into Fedora Workstation live image
2. set language with GIS
3. observer Anaconda override the language with something else
Actual Results:  
Language set in GIS is ignored.

Expected Results:  
Language set in GIS is respected.

Comment 1 Martin Kolman 2023-08-17 13:11:10 UTC
We have a fix for this, that should be merged at the time we do the switch for the Workstation live image to the Web UI: https://github.com/rhinstaller/anaconda/pull/5053

Comment 2 Adam Williamson 2023-08-24 17:53:13 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=2231921 seems kinda in the same area, not sure if we should consider it a dupe.

I'm gonna propose this as a Final blocker as a violation of "The installer must correctly display all sufficiently complete translations available for use" - https://fedoraproject.org/wiki/Fedora_39_Final_Release_Criteria#Installer_translations , in the case where geolocation doesn't give you the locale you actually want. Also proposing as a Beta FE as this is clearly not great behaviour for the Beta.

Comment 3 Adam Williamson 2023-08-27 16:18:31 UTC
+3 for both Beta FE and Final blocker in https://pagure.io/fedora-qa/blocker-review/issue/1192 , marking accepted for both.

Comment 4 Adam Williamson 2023-08-29 15:56:09 UTC
*** Bug 2235610 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2023-08-30 16:10:26 UTC
FEDORA-2023-7b30b63db9 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-7b30b63db9

Comment 6 Fedora Update System 2023-08-31 01:48:26 UTC
FEDORA-2023-7b30b63db9 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-7b30b63db9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-7b30b63db9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Adam Williamson 2023-08-31 01:56:49 UTC
Seems fixed in Rawhide testing. When I install in Russian, things stay in Russian.

Comment 8 Adam Williamson 2023-09-01 01:02:40 UTC
Also verified in F39.

Comment 9 Fedora Update System 2023-09-01 03:33:28 UTC
FEDORA-2023-7b30b63db9 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Adam Williamson 2023-09-05 17:08:06 UTC
*** Bug 2231921 has been marked as a duplicate of this bug. ***

Comment 11 Adam Williamson 2023-09-06 01:17:30 UTC
*** Bug 2236034 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.