Bug 223277 - Raw I/O Performance test fails on cciss/c0d1 drive
Raw I/O Performance test fails on cciss/c0d1 drive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: YangKun
:
: 222369 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 15:22 EST by Mark Coskey
Modified: 2008-07-16 17:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 11:50:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results Package (718.79 KB, application/octet-stream)
2007-01-18 15:22 EST, Mark Coskey
no flags Details

  None (edit)
Description Mark Coskey 2007-01-18 15:22:35 EST
Description of problem:
The Raw I/O Performance test fails on /dev/cciss/c0d1 HD due to an invalid 
path. This error is encountered at line 43 of storage.sh and the following 
details are from the output.log file:

*** Testing raw I/O performance on c0d1
./storage.sh: line 43: [: flags=direct: integer expression expected
--- sequential write
dt: 'open -> /dev/c0d1', errno = 2 - No such file or directory
dt: Error number 1 occurred on Thu Jan 18 11:54:07 2007

 It is trying to open /dev/c0d1 which appears to be an invalid path. The c0d1 
file does exist at /dev/cciss. The storage controller is a Smart Array E200i 
with two 72GB SAS HDs each a RAID 0. The OS is installed on /dev/cciss/c0d0
(LVM) and /dev/cciss/c0d1 is blank. 

Version-Release number of selected component (if applicable):
Test Kit used was the HTS-5.0-17.


How reproducible:
Failure occurs every time and is the same in RHEL5x86_64 & x86.

Steps to Reproduce:
1. On a machine with a cciss storage controller install RHEL5 1/5/2007 build, 
kernel 2.6.18-1.2961.el5xen
2. Install HTS-5.0-17
3. Create test plan (hts plan)
4. Launch storage test (hts certify --test storage)
  
Actual results:


Expected results:


Additional info: See attached results package.
Comment 1 Mark Coskey 2007-01-18 15:22:36 EST
Created attachment 145941 [details]
Results Package
Comment 2 YangKun 2007-01-19 00:03:07 EST
fixed in R18 .
Comment 3 YangKun 2007-01-19 00:35:01 EST
*** Bug 222369 has been marked as a duplicate of this bug. ***
Comment 4 Mark Coskey 2007-01-30 10:06:04 EST
Retested with HTS-5.0-21, issue fixed.

Note You need to log in before you can comment on or make changes to this bug.