Bug 223446 - Boot time messages from init scripts not being logged to /var/log/boot.log
Summary: Boot time messages from init scripts not being logged to /var/log/boot.log
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 5.1
Hardware: All Linux
high
medium
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature, Regression
: 489838 523532 (view as bug list)
Depends On:
Blocks: 234654 222082 227613 RHEL5u2_relnotes RHEL5u3_relnotes 494051 531175
TreeView+ depends on / blocked
 
Reported: 2007-01-19 14:22 UTC by Bill Nottingham
Modified: 2018-12-02 15:48 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
(all architectures) Boot-time logging to /var/log/boot.log is not available in Red Hat Enterprise Linux 5.3.
Story Points: ---
Clone Of:
: 494051 531175 (view as bug list)
Environment:
Last Closed: 2009-10-26 15:16:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 1 RHEL Product and Program Management 2007-01-19 14:27:31 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 12 RHEL Product and Program Management 2007-10-24 21:34:30 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 13 RHEL Product and Program Management 2007-10-24 21:35:35 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 16 Darren Hart 2007-12-04 00:56:16 UTC
So I think is more like what Jburke was looking for:

Failing command from rt->rhel5.1:
Command line: ro console=ttyS0,57600 root=/dev/sda3 clocksource=acpi_pm irqpoll
maxcpus=1 reset_devices memmap=exactmap memmap=640K@0K memmap=130416K@17024K
elfcorehdr=147440K memmap=68K#3145024K memmap=124K#3145092K

Successful command from rhel5.1->rhel5.1
Kernel command line: ro console=ttyS0,57600 root=/dev/sda3 clocksource=acpi_pm
irqpoll maxcpus=1 reset_devices memmap=exactmap memmap=640K@0K
memmap=5048K@16384K memmap=125368K@22072K elfcorehdr=147440K memmap=68K#3145024K
memmap=124K#3145092K

Note I have also tried without the clocksource=acpi_pm option with the same
results.  interestingly, I noted that the rhel5.1->rhel5.1 scenario on my latest
boot also printed:

ACPI: PCI Interrupt Link [LNKE] (IRQsirq 50, desc: ffffffff803b1580, depth: 1,
count: 0, unhandled: 0
->handle_irq():  ffffffff800b54e3, handle_bad_irq+0x0/0x1f6
->chip(): ffffffff802ea700, 0xffffffff802ea700
->action(): 0000000000000000
  IRQ_DISABLED set
   IRQ_PENDING set
unexpected IRQ trap at vector 32
 3 4 5 6 7 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 4 5 6 7 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKH] (IRQs 4 5 6 7 10 11 14 15) *0, disabled.

But it recovered and booted successfully.

Comment 17 Bill Nottingham 2007-12-04 16:21:41 UTC
DarreN: are you sure you're commenting on the right bug?

Comment 20 Don Domingo 2008-02-06 22:38:01 UTC
adding same release note quoted in Comment# 6, removing statement promising
"equivalent functionality" to be added in a future update. 

Comment 21 Don Domingo 2008-04-02 02:11:35 UTC
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Comment 24 Ryan Lerch 2008-08-08 01:41:19 UTC
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes. 

This Release Note is currently located in the Known Issues section.

Comment 25 Ryan Lerch 2008-08-08 01:41:19 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Comment 28 Phil Knirsch 2008-10-28 13:42:44 UTC
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,2 +1,2 @@
 (all architectures)
-Boot-time logging to /var/log/boot.log is not available in Red Hat Enterprise Linux 5.2.+Boot-time logging to /var/log/boot.log is not available in Red Hat Enterprise Linux 5.3.

Comment 30 Denise Dumas 2008-11-11 13:49:14 UTC
I have verified that the release note is correct for 5.3 and am moving this bz to 5.4.

Comment 39 Peter Vrabec 2009-03-23 15:10:36 UTC
*** Bug 489838 has been marked as a duplicate of this bug. ***

Comment 46 Bill Nottingham 2009-09-15 21:08:03 UTC
*** Bug 523532 has been marked as a duplicate of this bug. ***

Comment 48 Denise Dumas 2009-10-09 19:21:59 UTC
This issue will be fixed in RHEL6 with Plymouth. Unfortunately, that is not something we can backport without bringing a huge number of dependencies along and introducing instability. 
With IBM's OK, I'd like to convert this to a RHEL6 bz.

Comment 52 Issue Tracker 2009-10-15 23:06:40 UTC
Event posted on 2009-10-15 16:35 EDT by Glen Johnson

------- Comment From emachado@linux.vnet.ibm.com 2009-10-15 16:27
EDT-------
I've just verified RHEL5.4 GA in a ppc64 machine from ABAT and the file
/var/log/boot.log continues empty.

[root@vgerdwb ~]# cat /var/log/boot.log
[root@vgerdwb ~]# rpm -qa sysklogd
sysklogd-1.4.1-44.el5

Ticket type changed from 'Question' to ''

This event sent from IssueTracker by balkov 
 issue 103700

Comment 54 Denise Dumas 2009-10-26 15:08:47 UTC
This is just too much to change in the rhel5 stream. We will continue to carry the release note.

Comment 55 RHEL Product and Program Management 2009-10-26 15:16:04 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Comment 62 Robin R. Price II 2010-04-22 16:09:46 UTC
Putting in a workaround for anyone who is curious:

* You need to edit /etc/init.d/functions file. There are 4 points: success, failure, passed, warning.


* before:

:
# Log that something succeeded
success() {
  #if [ -z "${IN_INITLOG:-}" ]; then
  #   initlog $INITLOG_ARGS -n $0 -s "$1" -e 1
  #fi
  [ "$BOOTUP" != "verbose" -a -z "${LSB:-}" ] && echo_success
  return 0
}
:

* after:

:
# Log that something succeeded
success() {
  if [ -z "${IN_INITLOG:-}" ]; then
     initlog $INITLOG_ARGS -n $0 -s "$1" -e 1
  fi
  [ "$BOOTUP" != "verbose" -a -z "${LSB:-}" ] && echo_success
  return 0
}
:


Do this to all four functions.  Note:  Your console will be flooded by each service echoing out: "WARNING: initlog is deprecated and will be removed in a future release" but /var/log/boot.log will be populated.

-- Robin

Comment 63 R.M. Stockmann 2011-11-27 18:02:47 UTC
Robin  2010-04-22 12:09:46 EDT wrote :

"Note:  Your console will be flooded by each service echoing out:
 "WARNING: initlog is deprecated and will be removed in a future
 release" but /var/log/boot.log will be populated."

Well i might point to the following patch by the CentOS people :

http://bugs.centos.org/view.php?id=4861

where inside src/initlog.c the fprintf(stderr, ...)  function of this
"WARNING: initlog is deprecated and will be removed in a future
release" is simply disabled by commenting it out, and you have the old
functionality back. Enabling initlog inside scripts which trigger this
"WARNING: initlog is deprecated .." message is a potential attack bug.

I wonder who inserted this into initlog.c ,  claimed that : "initlog is
deprecated and will be removed in a future release", never bothered to
furnish new (initlog) shoes and apparently walked away barefooted.

Comment 64 Ryan Sawhill 2013-08-30 15:55:57 UTC
The work-around described in comment #62 did not work on my RHEL 5.9 system. (Not bothering to inspect, but I assume the "initlog is deprecated and will be removed in a future release" part finally happened.)

Here's how I "fixed" this on my systems back in 2009: 

sed -i.orig 's,set -m,#---------- /var/log/boot.log enablement modifications ----------#\nexec > >(tee -a /var/log/boot.log)\nexec 2>\&1\necho -e "\\n================================================================================"\necho $(/bin/date +%Y-%m-%d\\ %H:%M:%S)\necho "$0" "$@"\necho "-------------------"\n#----------- end of boot.log enablement modifications -----------#\n\n&,' /etc/rc.d/rc

Rewrote KCS solution https://access.redhat.com/site/solutions/9834 accordingly. See that for full directions.


Note You need to log in before you can comment on or make changes to this bug.