Bug 223507 - xdm should use system Xsession file
xdm should use system Xsession file
Status: CLOSED DUPLICATE of bug 244264
Product: Fedora
Classification: Fedora
Component: xorg-x11-xdm (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
: 242213 (view as bug list)
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-01-19 14:37 EST by Ryan Daly
Modified: 2014-06-18 05:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 12:59:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Daly 2007-01-19 14:37:41 EST
After installing Fedora Core 6, XDM behaves differently.  When I first logged
in, it didn't seem to use my ~/.Xclients.  I read a little and discovered that
it was looking for xsm.  I installed it and created a ~/.xsession file (which
had the same lines as my .Xclients had).

Things somewhat work, however when I log in my fonts are not what they should
be, and some environment settings are not getting set.

Using GDM, things work as they should.

With the assistance of rstrode@redhat.com, I did the follwowing:

mv /etc/X11/xdm/Xsession /etc/X11/xdm/Xsession.broken
ln -s /etc/X11/xinit/Xsession /etc/X11/xdm/Xsession

Things began to work properly again.
Comment 1 Matěj Cepl 2007-01-23 05:58:41 EST
Should not we really use cetralized Xsession from xorg-x11-xinit?
Comment 2 Ray Strode [halfline] 2007-03-06 00:53:04 EST
yes, exactly.
Comment 3 Ryan Daly 2007-06-07 14:30:09 EDT
Confirming that this bug still exists in FC7.
Comment 4 Matěj Cepl 2007-07-30 10:33:50 EDT
*** Bug 242213 has been marked as a duplicate of this bug. ***
Comment 5 Eduard Vopicka 2007-10-26 05:54:59 EDT
Please is there any chance to see this bug fixed in the upcoming F8 release?
Comment 6 Matěj Cepl 2007-12-10 04:24:10 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 7 Ryan Daly 2008-01-06 11:13:22 EST
I'm still seeing some sort of issue while using XDM.

The sound mixer is unavailable, and the NetworkManager cannot utilize the
gnome-keyring-daemon because the daemon is not started upon login.

I can understand that the gnome-keyring-daemon doesn't start w/ XDM, but the
mixer being unavailable is strange.
Comment 8 Matěj Cepl 2008-01-09 11:05:20 EST
Just one nitpicking question -- what's your distro? FC6 is not supported anymore.
Comment 9 Ryan Daly 2008-01-09 13:04:17 EST
Sorry.  I'm now using FC8.
Comment 10 Eduard Vopicka 2008-01-09 13:41:40 EST
:-) :-) :-) (Sorry, but I could not resist... :-)
Comment 11 Patrice Dumas 2008-01-11 12:59:25 EST

*** This bug has been marked as a duplicate of 244264 ***

Note You need to log in before you can comment on or make changes to this bug.