Bug 242213 - X sessions started with xdm are seriously broken
X sessions started with xdm are seriously broken
Status: CLOSED DUPLICATE of bug 223507
Product: Fedora
Classification: Fedora
Component: xorg-x11-xdm (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 04:30 EDT by Eduard Vopicka
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 10:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Vopicka 2007-06-02 04:30:00 EDT
Description of problem:

X sessions started with xdm are seriously broken


Version-Release number of selected component (if applicable):

[root@vel eda]# rpm -q xorg-x11-xdm
xorg-x11-xdm-1.1.3-1.fc7
[root@vel eda]# 

How reproducible:

always

Steps to Reproduce:
1. Configure your system in /etc/sysconfig/desktop to use xdm and reboot to
start xdm session
2. 
3.
  
Actual results:
Session is broken in many ways, for example, no dbus-launch and no ssh-agent is
started.

Expected results:
Session should work as with other DMs.

Additional info:

This has been reported in mid-january 2007 for FC6 as
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=223507 which is medium
severity bug, but it is still not fixed in both FC6 and F7. W/O workaround
described in 223507 xdm sessions are not of much use. This is why I am reporting
this bug again for F7.
Comment 1 Adam Jackson 2007-07-27 17:34:11 EDT
I recomend not using xdm.
Comment 2 Eduard Vopicka 2007-07-27 21:53:18 EDT
OK, so please which display manager do you recommend for use with fvwm? I do not
want to install KDE or Gnome on minimalistic dedicated systems with X11 just to
get display manager for use with xdm. What I need is just login prompt on login
screen, with no internationalization, keyboard switching and so on.

I refer again to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=223507
with solution proposed by RH people:

======
With the assistance of rstrode@redhat.com, I did the follwowing:

mv /etc/X11/xdm/Xsession /etc/X11/xdm/Xsession.broken
ln -s /etc/X11/xinit/Xsession /etc/X11/xdm/Xsession

Things began to work properly again.


Comment #1 From Matej Cepl 	on 2007-01-23 05:58 EST 	[reply] 	 

Should not we really use cetralized Xsession from xorg-x11-xinit?


Comment #2 From Ray Strode 	on 2007-03-06 00:53 EST 	[reply] 	 

yes, exactly.


Comment #3 From Ryan Daly 	on 2007-06-07 14:30 EST 	[reply] 	 

Confirming that this bug still exists in FC7.
======

And I refer to

[root@vel tmp]# ls -l /etc/X11/xdm/Xsession
lrwxrwxrwx 1 root root 17 Jun  2 00:30 /etc/X11/xdm/Xsession -> ../xinit/Xsession
[root@vel tmp]# 

on a couple of my systems. And this simple RH proposed solution really works!

I would also point out that xdm is included af part of F2 distribution, so it
should work:

[root@vel tmp]# rpm -qf /usr/bin/xdm
xorg-x11-xdm-1.1.3-1.fc7
[root@vel tmp]# 

Brgds,

Ed

Comment 3 Matěj Cepl 2007-07-30 10:33:47 EDT

*** This bug has been marked as a duplicate of 223507 ***

Note You need to log in before you can comment on or make changes to this bug.