Bug 223571 - gtk2-2.10.8-1 breaks drag & drop in thunderbird
Summary: gtk2-2.10.8-1 breaks drag & drop in thunderbird
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
: 225053 226723 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-20 01:44 UTC by Jason Farrell
Modified: 2018-04-11 09:45 UTC (History)
6 users (show)

Fixed In Version: thunderbird-1.5.0.9-7.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-04 21:01:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Farrell 2007-01-20 01:44:29 UTC
Description of problem:
gtk2-2.10.8-1 from updates-testing breaks dragging and dropping of messages in
thunderbird. Reverting to gtk2-2.10.4-10.fc6 in core restores correct behavior.

Version-Release number of selected component (if applicable):
gtk2-2.10.8-1.fc6

How reproducible:
always

Steps to Reproduce:
1. yum --enablerepo=updates-testing install gtk2
2. start thunderbird and attempt to drag&drop a message from the right message
pane to another folder in the left pane
  
Actual results:
drag fails when crossing the pane boundary. draws a drag trail back to the source.

Comment 1 Harri Lapinkoski 2007-01-26 22:08:24 UTC
I noticed this same problem today when I was trying to reorder my Firefox
bookmarks. Gtk2 was updated to 2.10.8-1 today. It's in updates now.


Comment 2 Tim Jackson 2007-01-27 13:06:55 UTC
Hmm, how did this upgrade make it from testing breaking 2 major apps?

Comment 3 Thorsten Leemhuis 2007-01-27 13:31:13 UTC
(In reply to comment #2)
> Hmm, how did this upgrade make it from testing breaking 2 major apps?

See Bug 222349

BTW, this is not gtk2 bug -- it's a thunderbird and firefox bug. And probably a
dupe of Bug 222349 (but that's maked as devel, and not FC-6, thus I won't mark
it as dupe)

Comment 4 Matěj Cepl 2007-02-01 09:25:56 UTC
*** Bug 226723 has been marked as a duplicate of this bug. ***

Comment 5 Johan Kok 2007-02-04 16:42:07 UTC
*** Bug 225053 has been marked as a duplicate of this bug. ***

Comment 6 Johan Kok 2007-02-04 16:56:47 UTC
thunderbird-1.5.0.9-7.fc6 was pushed a few days ago. Can you update and check if this is resolved now?

Comment 7 Jason Farrell 2007-02-04 21:01:00 UTC
Yes - i can confirm that today's firefox and thunderbird updates have fixed the
drag&drop problems in each.

* Tue Jan 30 2007 Christopher Aillon <caillon@redhat.com> 1.5.0.9-6
- Fix the DND implementation to not grab, so it works with new GTK+.

Comment 8 Doug Mitchell 2007-02-07 16:29:43 UTC
Fedora Core 6 Updates is still showing 1.5.0.9-2.fc6 as current for me, and I'm
getting other updtes, has this been pushed out?



Note You need to log in before you can comment on or make changes to this bug.