Bug 223602 - gnome-python2-libegg doesn't contain egg.recent module
gnome-python2-libegg doesn't contain egg.recent module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 223664 223727 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-20 12:03 EST by Sindre Pedersen Bjørdal
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-python2-extras-2.14.2-8.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-20 15:15:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sindre Pedersen Bjørdal 2007-01-20 12:03:22 EST
Description of problem:
The gnome-python2-libegg package doesn't contain the egg.recent python module
needed for several gnome apps, including the code examples included in said
package, like /usr/share/doc/gnome-python2-libegg/recent/*

I've rebuilt the package locally here to include the module without any changes
to the .spec, seems to me it's a missing builddep, I've failed to figure out
just which package is missing as of yet.

Version-Release number of selected component (if applicable):
2.14.2-6

How reproducible:
Every time

Steps to Reproduce:
1. Install gnome-python2-libegg
2. Try to run /usr/share/doc/gnome-python2-libegg2/recent/*
3. Observe how it fails due to missing egg.recent module
  
Actual results:
Applications depending on the egg.recent module fails to run due to said module
missing

Expected results:
gnome-python2-libegg should include bothe egg.trayicon and egg.recent modules

Additional info:
The configure script echoes which modules are built, might be helpful.
Comment 1 Sindre Pedersen Bjørdal 2007-01-20 12:52:43 EST
The missing BuildRequires turned out to be gnome-python2-devel, adding it fixes
build without any other changes to SPEC.
Comment 2 Matthew Barnes 2007-01-20 15:15:11 EST
Yep, you're right.  The configure script is looking for gnome-python-2.0.pc,
which is provided by gnome-python2-devel.  Thanks for pointing this out!

Fixed in gnome-python2-extras-2.14.2-8.fc6.
Comment 3 Matthew Barnes 2007-01-21 11:48:31 EST
*** Bug 223664 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Barnes 2007-01-21 19:43:27 EST
*** Bug 223727 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.