Bug 22364 - anaconda crashes during install with kickstart
anaconda crashes during install with kickstart
Status: CLOSED DUPLICATE of bug 19384
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-15 15:27 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-18 12:23:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-15 15:27:37 EST
hy there,

i try to install witch kickstart from floppy. anaconda always crashes at 
the same situation with the following message:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/textw/partitioning_text.py", line 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in 
allowLiloLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 81d9268>
self: <lilo.LiloConfiguration instance at 81aaf48>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


i have changed my ks.cfg file from loading from cdrom to http, to ftp but 
i is always the same error.

this is my ks.cfg file:

lang de_DE

network --bootproto static --device eth1 --ip 10.10.101.4 --netmask 
255.255.255.0 --gateway 10.10.101.254 --hostname mmhyp04

# nfs --server 10.10.101.10 --dir /mnt/data/export/redhat_7_0_install
url --url http://10.10.101.10/redhat/

device ethernet 3c90x

keyboard "de-latin1"

zerombr yes
clearpart --linux
part swap --size 259
install

mouse genericps/2

timezone Etc/GMT-5

xconfig --server "/etc/X11/X: symbolic link 
to ../../usr/X11R6/bin/XFree86" --monitor "generic monitor"

# rootpw --iscrypted $1$0ZQJKeD0$d9UEal79AVf4Xui93hVZQ1
rootpw root

auth --useshadow

lilo --location mbr

reboot

%packages
glibc
libtermcap
fileutils
e2fsprogs
sysklogd
modutils
textutils
cracklib
db3
chkfontpath
db1
sh-utils
amanda-server
anonftp
apmd
asp2php-gtk
audiofile
bc
bison
cdecl
control-panel
crontabs
db2
dhcpcd
sgml-common
ed
emacs-nox
findutils
fortune-mod
gcc-c++
gdb
gedit
ghostscript-fonts
gmc
gnome-libs
libxml
gnupg
groff
umb-scheme
hdparm
imlib-cfgeditor
ipchains
isapnptools
kdelibs
kernel
kernelcfg
kudzu-devel
libgtop
libpng-devel
libtermcap-devel
perl
lilo
losetup
ltrace
make
mc
mkbootdisk
mount
mtools
ncurses-devel
netpbm-devel
newt
nmh
openssh-clients
passwd
pidentd
portmap
pspell
pygtk
pythonlib
raidtools
readline-devel
rep-gtk-gnome
rhs-printfilters
rpm
rsh
rusers-server
samba-client
screen
sgml-tools
slang-devel
statserial
switchdesk
tar
tcsh
tftp-server
tin
tksysv
ucd-snmp
up2date-gnome
util-linux
wu-ftpd
Xconfigurator
XFree86-doc
XFree86-ISO8859-2-Type1-fonts
XFree86-ISO8859-7-Type1-fonts
XFree86-tools
xinitrc
xscreensaver
zip
dhcp
firewall-config
gnuplot
kdoc
man-pages-de
mtr
mysql-server
nss_ldap
pdksh
psacct
rpmfind
symlinks
tree
wget
ytalk
setup
basesystem
chkconfig
termcap
bash
info
sed
gawk
procps
logrotate
psmisc
vixie-cron
shadow-utils
grep
XFree86-libs
XFree86-xfs
words
pwdb
glib
SysVinit
abiword
openssl
gdbm
readline
python
amanda-client
anaconda
anacron
mailcap
apache-manual
arpwatch
asp2php
aspell
at
authconfig
automake
bdflush
binutils
byacc
bzip2-devel
compat-libstdc++
control-center
cpio
cproto
ctags
cyrus-sasl
desktop-backgrounds
dev86
diffstat
dip
docbook
dump
eject
emacs
esound
file
finger
flex
freetype
gcc
gcc-g77
gd-devel
gdbm-devel
gdm
gettext
ghostscript
gimp
glibc-devel
gnome-applets
gnome-games
gnome-linuxconf
urw-fonts
gnome-print
gnumeric
gphoto
gpm-devel
groff-perl
gtk-engines
guile
gzip
ical
imlib
indent
inews
iproute
iputils
kbdconfig
kdegraphics
kdenetwork
kdeutils
kernel-doc
kernel-utils
krb5-devel
kudzu
less
libglade
libjpeg
libpng
librep
libstdc++-devel
libtiff
m4
libtool
libungif
links
linuxconf-devel
LPRng
lsof
lynx
mailx
MAKEDEV
man-pages
Mesa
minicom
mkinitrd
mod_ssl
mouseconfig
mt-st
mutt
ncompress
net-tools
netpbm
netpbm-progs
netscape-communicator
newt-devel
njamd
ntsysv
openldap
openssh
openssh-askpass-gnome
openssh-server
ORBit
patch
pciutils-devel
pine
pnm2ppa
ppp
procmail
pump
pygnome-libglade
pygtk-libglade
python-xmlrpc
qt
quota
rcs
rdist
redhat-logos
rep-gtk
rep-gtk-libglade
rhn_register-gnome
rmt
rp-pppoe
rpm-build
rpm-python
rsh-server
rusers
rwall-server
samba
samba-common
sawfish
sendmail
setuptool
shapecfg
slang
slocate
stat
strace
stylesheets
sysstat
talk-server
tcl
tcpdump
telnet
texinfo
time
timetool
tix
tkinter
tmpwatch
trn
ucd-snmp-utils
up2date
urlview
utempter
vim-common
whois
wvdial
xchat
XFree86
XFree86-75dpi-fonts
XFree86-ISO8859-2
XFree86-ISO8859-2-75dpi-fonts
XFree86-ISO8859-7
XFree86-ISO8859-7-75dpi-fonts
XFree86-ISO8859-9
XFree86-ISO8859-9-75dpi-fonts
XFree86-twm
XFree86-xf86cfg
xloadimage
xpdf
yp-tools
ypserv
zlib-devel
bash-doc
dump-static
fbset
ftpcopy
gimp-perl
groff-gxditview
kdebase-3d-screensavers
korganizer
lm_sensors
mkkickstart
mod_php
mtr-gtk
mysql
nc
nscd
ntp
openldap-servers
php
php-mysql
qt-Xt
rpm2html
sawfish-themer
sudo
sysctlconfig
tftp
unarj
w3c-libwww-apps
xcpustate
xsysinfo
zsh
filesystem
mktemp
ncurses
mingetty
popt
which
initscripts
zlib
cracklib-dicts
pam
amanda
gmp
xinetd
anaconda-runtime
apache
ash
aspell-de
autoconf
bind-utils
bzip2
console-tools
cpp
cvs
dev
diffutils
dosfstools
elm
fetchmail
finger-server
ftp
gd
gdk-pixbuf
gftp
kernel-headers
gnome-core
gnome-pim
gnome-users-guide
gpm
gtk+
gv
ImageMagick
indexhtml
iptables
kdebase
kdesupport
kernel-pcmcia-cs
krb5-libs
libghttp
libjpeg-devel
libstdc++
libtiff-devel
libtool-libs
linuxconf
lrzsz
magicdev
man
metamail
mod_perl
mpage
ncftp
netcfg
netscape-common
nfs-utils
openjade
openssh-askpass
openssl-devel
pciutils
pmake
printtool
pygnome
python-devel
qt1x
rdate
redhat-release
rhn_register
rootfiles
rpm-devel
rsync
rwho
sash
setserial
sharutils
slrn
stunnel
talk
tcp_wrappers
telnet-server
timeconfig
tk
traceroute
unzip
usermode
vim-minimal
Xaw3d
XFree86-100dpi-fonts
XFree86-ISO8859-2-100dpi-fonts
XFree86-ISO8859-7-100dpi-fonts
XFree86-ISO8859-9-100dpi-fonts
XFree86-xdm
xpaint
ypbind
auth_ldap
ext2ed
gimp-data-extras
kdeadmin
kpackage
mod_dav
mtx
netscape-navigator
openldap-clients
php-manual
qt1x-GL
sendmail-doc
taper
w3c-libwww
xosview

%post

# Nameserver hinzufuegen

echo "nameserver 151.136.192.18" >> /etc/resolv.conf
echo "nameserver 151.136.128.18" >> /etc/resolv.conf
echo "nameserver 151.136.42.18" >> /etc/resolv.conf

# Hier noch zweites Netzwerkinterface konfigurieren  !!!
Comment 1 Michael Fulbright 2000-12-18 12:23:48 EST

*** This bug has been marked as a duplicate of 19384 ***

Note You need to log in before you can comment on or make changes to this bug.