Bug 22370 - req_finished_io unresolved in sr_mod.o
Summary: req_finished_io unresolved in sr_mod.o
Status: CLOSED DUPLICATE of bug 19072
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-15 21:35 UTC by Göran Uddeborg
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-18 15:33:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Göran Uddeborg 2000-12-15 21:35:47 UTC
I made my own kernel using kernel-sources-2.2.16-22.  I first tried to make
my SCSI CD player usable as a module.  But this results in complaints that
the symbol "req_finished_io" is unresolved when doing things like
"modprobe" or "depmod -e".

I don't understand why this problem happens.  "req_finished_io" IS defined
in the kernel itself, and appears in System.map.  The function is added in
the patch linux-2.2.16-sard.patch, so I suppose this patch is broken.  In
some way I don't understand.

(Of course, linking SCSI CD support directly into the kernel rather than as
a module is a workaround.)

Comment 1 Arjan van de Ven 2000-12-16 17:57:48 UTC
Dupe of bug 19072
See the fix in that report...

Comment 2 Göran Uddeborg 2000-12-16 19:18:06 UTC
Ok, thanks.  I missed that one when I looked for a previous report.  (I looked
for subjects with req_finished_io and sr_mod among other things, but didn't
realise it hit SCSI in general.)

Comment 3 Bill Nottingham 2000-12-18 15:33:13 UTC

*** This bug has been marked as a duplicate of 19072 ***


Note You need to log in before you can comment on or make changes to this bug.