Bug 22371 - samba auth fails
Summary: samba auth fails
Status: CLOSED DUPLICATE of bug 21654
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 7.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-15 22:02 UTC by Kurt Ludwig
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-15 22:05:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kurt Ludwig 2000-12-15 22:02:50 UTC
after setting up samba vanillaly, it refuses to let anyone log into the
shares.

this is using encrypted passwords from a w2k machine. The passwords have
been added using the shell script to /etc/samba/smbpasswd. There is also a
map in /etc/samba/smbusers to my user account on the machine like so:

[root@moonraker /root]# cat /etc/samba/smbusers
# Unix_name = SMB_name1 SMB_name2 ...
root = administrator admin
nobody = guest pcguest smbguest
kurt = kurt.ludwig
[root@moonraker /root]#                            

logs:
---------------------------------------------------------
[root@moonraker samba]# cat smb.log
[2020/12/15 17:50:27, 1] smbd/files.c:file_init(216)
  file_init: Information only: requested 10000 open files, 1014 are
available.
[2020/12/15 17:50:32, 1] smbd/files.c:file_init(216)
  file_init: Information only: requested 10000 open files, 1014 are
available.
[2020/12/15 17:54:08, 1] smbd/files.c:file_init(216)
  file_init: Information only: requested 10000 open files, 1014 are
available.
[2020/12/15 18:03:08, 1] smbd/files.c:file_init(216)
  file_init: Information only: requested 10000 open files, 1014 are
available.
[root@moonraker samba]#
----------------------------------------------------------
[root@moonraker samba]# cat rainbowtrout.log
[2020/12/15 17:50:53, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:50:53, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:50:53, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:50:53, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:50:53, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:50:53, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:50:58, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
[2020/12/15 17:50:58, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid

[2020/12/15 17:51:37, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:51:37, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:51:37, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:51:37, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:51:37, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:51:37, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/1517:51:42, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
[2020/12/15 17:51:42, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid

[2020/12/15 17:52:29, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:52:29, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:52:29, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:52:29, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:52:29, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:52:29, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:52:33, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:33, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:33, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'admin': authentication failed
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'admin': authentication failed
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'admin': authentication failed
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'admin': authentication failed
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'admin': authentication failed
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'admin' in UNIX password database.
[2020/12/15 17:52:34, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'admin': authentication failed
[2020/12/15 17:54:19, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:54:19, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:54:19, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:54:19, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:54:19, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:54:19, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:54:25, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:54:25, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 17:54:25, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 17:54:30, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
[2020/12/15 17:54:30, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid
 
[2020/12/15 18:03:20, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:20, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:20, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 18:03:20, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:20, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:20, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 18:03:24, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
[2020/12/15 18:03:24, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid
 
[2020/12/15 18:03:27, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:27, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:27, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 18:03:27, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:27, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:27, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[2020/12/15 18:03:33, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:33, 1] smbd/password.c:pass_check_smb(492)
  Couldn't find user 'kurt.ludwig' in UNIX password database.
[2020/12/15 18:03:33, 1] smbd/reply.c:reply_sesssetup_and_X(925)
  Rejecting user 'kurt.ludwig': authentication failed
[root@moonraker samba]#   
--------------------------------------------------------                                                  
[root@moonraker samba]# cat log.smb
[2020/12/15 17:50:27, 1] smbd/server.c:main(641)
  smbd version 2.0.7 started.
  Copyright Andrew Tridgell 1992-1998
[2020/12/15 17:50:32, 1] smbd/server.c:main(641)
  smbd version 2.0.7 started.
  Copyright Andrew Tridgell 1992-1998
[2020/12/15 17:54:08, 1] smbd/server.c:main(641)
  smbd version 2.0.7 started.
  Copyright Andrew Tridgell 1992-1998
[2020/12/15 18:03:08, 1] smbd/server.c:main(641)
  smbd version 2.0.7 started.
  Copyright Andrew Tridgell 1992-1998
[root@moonraker samba]#                            
---------------------------------------------------

         [root@moonraker samba]# cat log.nmb
[2020/12/15 17:50:28, 1] nmbd/nmbd.c:main(757)
  Netbios nameserver version 2.0.7 started.
  Copyright Andrew Tridgell 1994-1998
[2020/12/15 17:50:32, 0] nmbd/nmbd.c:sig_term(65)
  Got SIGTERM: going down...
[2020/12/15 17:50:32, 1] nmbd/nmbd.c:main(757)
  Netbios nameserver version 2.0.7 started.
  Copyright Andrew Tridgell 1994-1998
[2020/12/15 17:54:08, 0] nmbd/nmbd.c:sig_term(65)
  Got SIGTERM: going down...
[2020/12/15 17:54:08, 1] nmbd/nmbd.c:main(757)
  Netbios nameserver version 2.0.7 started.
  Copyright Andrew Tridgell 1994-1998
[2020/12/15 18:03:08, 0] nmbd/nmbd.c:sig_term(65)
  Got SIGTERM: going down...
[2020/12/15 18:03:09, 1] nmbd/nmbd.c:main(757)
  Netbios nameserver version 2.0.7 started.
  Copyright Andrew Tridgell 1994-1998
[root@moonraker samba]#                             
--------------------------------------------------------


any ideas?

Thanks,
Kurt

Comment 1 Kurt Ludwig 2000-12-15 22:05:16 UTC
This still occurs after applying the PAM update for 7.0

Kurt

Comment 2 Bill Nottingham 2000-12-15 22:07:18 UTC

*** This bug has been marked as a duplicate of 21654 ***


Note You need to log in before you can comment on or make changes to this bug.