Bug 21654 - PANIC: failed to set gid
PANIC: failed to set gid
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
alpha Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Dale Lovelace
:
: 22371 32223 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-03 15:28 EST by Larry Fahnoe
Modified: 2007-03-26 23:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-16 16:51:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to possibly fix samba/kernel interaction (390 bytes, patch)
2000-12-15 17:14 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Larry Fahnoe 2000-12-03 15:28:34 EST
Red Hat Linux release 7.0 (Guinness)
Kernel 2.2.17-4 on an alpha

glibc-2.2-5
samba-2.0.7-21ssl

smb.conf:
   encrypt passwords = yes
   smb passwd file = /etc/samba/smbpasswd

NT 4 client attempts to connect to server using valid username/password,
/var/log/samba/client.log shows:

[2000/12/03 14:19:09, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
[2000/12/03 14:19:09, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid

The same smb.conf with the same release of RedHat on my Intel system works
properly.

--Larry
Comment 1 Bill Nottingham 2000-12-06 11:35:01 EST
This appears to be a kernel problem. Reassigning there.
Comment 2 Bill Nottingham 2000-12-15 17:06:08 EST
*** Bug 22371 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2000-12-15 17:06:32 EST
*** Bug 22371 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2000-12-15 17:07:15 EST
*** Bug 22371 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2000-12-15 17:13:01 EST
Can you apply the attached and rebuild your kernel - does it work then?
Comment 6 Bill Nottingham 2000-12-15 17:14:36 EST
Created attachment 6493 [details]
patch to possibly fix samba/kernel interaction
Comment 7 Larry Fahnoe 2000-12-16 16:51:39 EST
Yes, the patch solves the problem.

Tested with patch applied to 2.2.18 stock kernel, not RH 2.2.17-4.  I'm assuming that you will get the updated entry points to the proper kernel folks, but 
let me know if you are not planning to and I will send them the update.

Thanks!!

--Larry
Comment 8 Bill Nottingham 2001-02-07 03:05:19 EST
This got fixed in both the 2.4.0 rawhide kernels and whatever the 
last 2.2 one we built was.
Comment 9 Bill Nottingham 2001-03-19 11:13:42 EST
*** Bug 32223 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.