Bug 224149 - rebuild of brltty-3.7.2-1.fc6 fails on a Rawhide system
rebuild of brltty-3.7.2-1.fc6 fails on a Rawhide system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: brltty (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
: Reopened
Depends On:
Blocks: 224341
  Show dependency treegraph
 
Reported: 2007-01-24 08:37 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: brltty-3.7.2-1.1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 07:00:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
srpm patch (340 bytes, patch)
2007-01-25 06:08 EST, Tomas Janousek
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2007-01-24 08:37:28 EST
Description of problem:
make[3]: Entering directory
`/home/build/rebuild/build/brltty-3.7.2-1.fc6.src.rpm/brltty-3.7.2/Programs'
gcc -Wall -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -I. -I.. -I. -I.. -D_POSIX_C_SOURCE=2 -D_BSD_SOURCE
-D_XOPEN_SOURCE=500 -DHAVE_CONFIG_H -fPIC -c ./api_client.c
./api_client.c: In function 'brlapi_waitForPacket':
./api_client.c:167: warning: dereferencing type-punned pointer will break
strict-aliasing rules
./api_client.c: In function 'getControllingTty':
./api_client.c:669: error: 'MAX_NR_CONSOLES' undeclared (first use in this function)
./api_client.c:669: error: (Each undeclared identifier is reported only once
./api_client.c:669: error: for each function it appears in.)
make[3]: *** [api_client.o] Error 1
Comment 1 Tomas Janousek 2007-01-25 06:08:17 EST
Created attachment 146524 [details]
srpm patch

I'm not gonna rebuild it because of this, therefore attaching the patch. SRPM
is at
http://people.redhat.com/tjanouse/brltty/224149/brltty-3.7.2-1.1.fc7.src.rpm

Note You need to log in before you can comment on or make changes to this bug.