Bug 224341 - rebuild of brltty-3.7.2-1.fc6 fails on a Rawhide system
Summary: rebuild of brltty-3.7.2-1.fc6 fails on a Rawhide system
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: brltty (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Janousek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On: 224149
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-25 11:01 UTC by Tomas Janousek
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 20:39:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Janousek 2007-01-25 11:01:33 UTC
+++ This bug was initially created as a clone of Bug #224149 +++

Description of problem:
make[3]: Entering directory
`/home/build/rebuild/build/brltty-3.7.2-1.fc6.src.rpm/brltty-3.7.2/Programs'
gcc -Wall -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -I. -I.. -I. -I.. -D_POSIX_C_SOURCE=2 -D_BSD_SOURCE
-D_XOPEN_SOURCE=500 -DHAVE_CONFIG_H -fPIC -c ./api_client.c
./api_client.c: In function 'brlapi_waitForPacket':
./api_client.c:167: warning: dereferencing type-punned pointer will break
strict-aliasing rules
./api_client.c: In function 'getControllingTty':
./api_client.c:669: error: 'MAX_NR_CONSOLES' undeclared (first use in this function)
./api_client.c:669: error: (Each undeclared identifier is reported only once
./api_client.c:669: error: for each function it appears in.)
make[3]: *** [api_client.o] Error 1

Comment 2 Jos Vos 2007-01-26 18:31:57 UTC
Solution: add "#include <linux/vt.h> after "#include <linux/tty.h>" in the file
Programs/api_client.c.

Comment 3 Jos Vos 2007-01-26 18:34:57 UTC
Oops, I just saw this fix was already mentioned in bug #224149.

Comment 4 RHEL Product and Program Management 2007-06-05 20:39:46 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.


Note You need to log in before you can comment on or make changes to this bug.