Bug 224284 - "ata1: port is slow to respond, please be patient" followed by failures
"ata1: port is slow to respond, please be patient" followed by failures
Status: CLOSED DUPLICATE of bug 210579
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 19:46 EST by Jason Edgecombe
Modified: 2013-07-02 22:32 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 09:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages displaying behaviour (45.75 KB, text/plain)
2007-05-22 15:23 EDT, Wade Nelson
no flags Details
dmesg output for 2.6.18-8.1.15.el5PAE (27.56 KB, text/plain)
2007-11-09 13:41 EST, Jason Edgecombe
no flags Details

  None (edit)
Description Jason Edgecombe 2007-01-24 19:46:30 EST
+++ This bug was initially created as a clone of Bug #211211 +++

Description of problem:
From the dmesg:
scsi0 : ata_piix
ata1: port is slow to respond, please be patient
ata1: port failed to respond (30 secs)
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: reset failed, giving up
scsi1 : ata_piix
ata2: port is slow to respond, please be patient
ata2: port failed to respond (30 secs)
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: reset failed, giving up


Version-Release number of selected component (if applicable):
Seen in kernel-2.6.18-1.2726.fc6 and kernel-xen-2.6.17-1.2630.fc6
Not seen in kernel-2.6.16-1.2208_FC6


How reproducible:
100%

Not sure how much of a problem this is; having other problems booting into a
usable system with this kernel.

-- Additional comment from dmalcolm@redhat.com on 2006-10-17 16:58 EST --
Created an attachment (id=138726)
dmesg from the boot


-- Additional comment from dmalcolm@redhat.com on 2006-10-17 17:00 EST --
(apart from delaying the boot whilst each waiting for each timeout, that is)

-- Additional comment from bugzilla.redhat@john.holmstadt.com on 2006-10-18
10:21 EST --
I'm seeing this as well on a Dell Poweredge SC1420 with kernel version
2.6.18-1.2200. Everything appears to function just fine after it fails, it just
makes the boot process take an extra minute and a half to complete.

-- Additional comment from bugzilla.redhat@john.holmstadt.com on 2006-10-18
10:22 EST --
Created an attachment (id=138788)
dmesg


-- Additional comment from dmalcolm@redhat.com on 2006-10-19 14:03 EST --
FWIW the original report was also seen on a Dell, a GX270.

-- Additional comment from jpazdziora@redhat.com on 2006-10-24 05:10 EST --
The same problem in RHEL 5 Beta 2, on a Dell GX 270, kernel 2.6.18-1.2732.el5xen.

-- Additional comment from mr.beeba@volny.cz on 2006-10-24 13:03 EST --
Created an attachment (id=139240)
/var/log/messages.log


-- Additional comment from mr.beeba@volny.cz on 2006-10-24 13:05 EST --
Experiencing the same problems on Dell Precision 360, motherboard with both SATA
and ATA controllers, SATA disabled in BIOS, FC5 installed on ATA - /dev/hda6 -
kernel 2.6.18-1.2200 (both versions non-smp/smp). After cca 2-3 minutes of
reporting failures in reseting ata1 and ata2 boots normally, avahi daemon fails
to start, the rest is OK - see the attachment above.

-- Additional comment from orion@cora.nwra.com on 2006-10-26 13:18 EST --
Me too.  Dell Dimension 8300.  OS on ATA/IDE (/dev/hda).  SATA is probably
disabled in BIOS as well.

00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)

ata_piix 0000:00:1f.2: version 2.00
ata_piix 0000:00:1f.2: MAP [ P0 -- P1 -- ]
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0xFE00 ctl 0xFE12 bmdma 0xFEA0 irq 169
ata2: SATA max UDMA/133 cmd 0xFE20 ctl 0xFE32 bmdma 0xFEA8 irq 169
scsi0 : ata_piix
ata1: port is slow to respond, please be patient
ata1: port failed to respond (30 secs)
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: reset failed, giving up
scsi1 : ata_piix
ata2: port is slow to respond, please be patient
ata2: port failed to respond (30 secs)
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: reset failed, giving up




-- Additional comment from dan.walkes@prostorsystems.com on 2006-10-27 11:49 EST --
Created an attachment (id=139588)
/var/log/messages output with SATA2 disabled, OS HDD on SATA 0


-- Additional comment from dan.walkes@prostorsystems.com on 2006-10-27 11:51 EST --
Same noticed with Dell Optiplex GX280 (Intel ICH6 82801FB.)  Fedora 6 install. 
OS HDD is on SATA 0.  Happens even when SATA2 (only other port) is disabled in 
the BIOS (BIOS Rev A08.)

uname -a:
Linux hwqual 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 i686 
i386 GNU/Linux

..
Oct 27 09:28:40 hwqual kernel: ata2: port is slow to respond, please be patient
Oct 27 09:28:40 hwqual kernel: ata2: port failed to respond (30 secs)
Oct 27 09:28:40 hwqual kernel: ata2: SRST failed (status 0xFF)
..

full /var/log/message output attached (see previous post)

-- Additional comment from dnovillo@redhat.com on 2006-10-30 18:23 EST --

Likewise on a Dell OptiPlex GX270N.  There are no SATA disks connected to the
machine and SATA support is disabled in BIOS.  System hangs for about a minute
waiting for timeouts on ata1 and ata2.

Kernel: 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006
dmesg output coming up

-- Additional comment from dnovillo@redhat.com on 2006-10-30 18:26 EST --
Created an attachment (id=139782)
dmesg with ata[12] timeouts on Dell Optiplex GX270N.  SATA disabled in BIOS. 
No SATA disks attached to the system.
Comment 1 Jason Edgecombe 2007-01-24 19:51:46 EST
confirmed on a Dell Optiplex 745 with a SATA hard drive.

It complains about ata3 and ata4 being slow to respond. the boot process pauses
for one minute while it's trying the controllers. This occurs during the install
if you look at the log and it occurs in the normal installed kernel.
Comment 2 Wade Nelson 2007-05-22 15:22:39 EDT
Can also confirm exact behaviour as Comment #1 on the Optiplex 745 w/ SATA
running fully updated RHEL5.  Attaching /var/log/messages.
Comment 3 Wade Nelson 2007-05-22 15:23:16 EDT
Created attachment 155192 [details]
/var/log/messages displaying behaviour
Comment 4 Wade Nelson 2007-05-22 15:29:41 EDT
Also, came across this:

Quote:
"Ok the issue is that the Optiplex 745 comes with a SATA DVD recorder
and the kernel is noisy in trying to treat it at first like a SATA
drive."

http://lists.us.dell.com/pipermail/linux-desktops/2006-December/000097.html
Comment 5 Peter Martuccelli 2007-05-23 09:27:11 EDT
The timeout issue will be resolved in the RHEL 5.1 SATA update.  Closing out as
a duplicate of bug 210579.

*** This bug has been marked as a duplicate of 210579 ***
Comment 6 Jason Edgecombe 2007-11-09 13:41:56 EST
Created attachment 253231 [details]
dmesg output for 2.6.18-8.1.15.el5PAE

The slow sata booting issue is not fixed. the slow booting and SATA messages
persist. I verified this on a Dell Optiplex 745 running the
2.6.18-8.1.15.el5PAE kernel update from RHEL5.1

Note You need to log in before you can comment on or make changes to this bug.