Bug 224293 - Software Updater Crashes
Software Updater Crashes
Status: CLOSED DUPLICATE of bug 224292
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 23:38 EST by Terry Hart
Modified: 2014-01-21 17:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 12:45:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Auto generated error file (1.18 KB, application/octet-stream)
2007-01-24 23:38 EST, Terry Hart
no flags Details

  None (edit)
Description Terry Hart 2007-01-24 23:38:55 EST
Description of problem: Software Updater Crashes.


Version-Release number of selected component (if applicable):


How reproducible: Every Startup or Manual Run


Steps to Reproduce:
1. Shows one available update but crashes when I select install
2.
3.
  
Actual results: See attached error file


Expected results:


Additional info:
Comment 1 Terry Hart 2007-01-24 23:38:56 EST
Created attachment 146495 [details]
Auto generated error file
Comment 2 Gordon Hebert 2007-01-25 00:17:12 EST
Newbie having similar problem on x86 (AMD K6-2 450 Mz).
2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 18:32:37 EST 2007 i586 i586 i386 GNU/Linux

----
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x8cf8068>
child: <Element 'packagereq' at 0x8cd8f68>
Comment 3 Terry Hart 2007-01-25 00:32:03 EST
First PC was Athlon 64 3000 single core running Core 6 64 bit. Now seems to have
fixed itself? But now getting same exact error on second PC which is Athlon 64
3800 dual core running Core 6 32 bit. Strange? Both have 2 GB RAM and dual 250
GB SATA II 3.0 drives. Both also have nVidia 7600GS graphics cards with latest
nVidia drivers from Livna. Both were updated sucessfully with all latest
software updates earlier today.
Comment 4 Juan F Samper 2007-01-25 00:38:58 EST
There's a way to manually solve this problem (it seems).
Open the terminal and log in as root.
# rm /var/lib/rpm/__db*
answer yes to all questions (y + Return).
# rpm --rebuilddb 
# yum -y update
if the update through yum works, it should through pup (graphic update manager) too.
Comment 5 Terry Hart 2007-01-25 00:47:57 EST
Now getting same exact error on third PC which is a Duron 1.8 with ATI graphics.
Something definately wrong here?
Comment 6 Terry Hart 2007-01-25 01:12:39 EST
Juan
Deleted and rebuilt the RPM DB as you suggested. # yum -y update then ran fine. 
But Pup (Software Updater) still crashes and generates same error file?
Terry
Comment 7 Terry Hart 2007-01-25 01:25:38 EST
All three of my PC's now working again. Seems like if you just let them set for
about a half hour they fix themselves. Really Strange?
Terry
Comment 8 Miroslav Šimko 2007-01-25 10:16:24 EST
Since yesterday (after update of number of packages), I have recieved the same 
error as in comment #2 when running graphic update (or add/remove) manager. 
I rebuild rpm db as suggested by kalaka in comment #4, but I still cannot run 
graphic manager. 
From command line, I can run yum update without error.
I use x86_32 FC6 instead of 64bit.

Miro
Comment 9 Richard McPheeters 2007-01-25 10:53:15 EST
I believe I have the same problem as #2.
bug report text follows:
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0xa2d8068>
child: <Element 'packagereq' at 0xa2cff68>



Comment 10 Miroslav Šimko 2007-01-25 12:16:54 EST
Reply to comment #8

After rebooting OS, I can run graphic update. Seems there was some old 
cache even after rpm --rebuilddb ...

For me, problem is solved.
Comment 11 Michael Schwendt 2007-01-25 12:45:48 EST

*** This bug has been marked as a duplicate of 224292 ***

Note You need to log in before you can comment on or make changes to this bug.