Bug 224375 - Software Updater crashes during "Retrieving Update Information" state
Software Updater crashes during "Retrieving Update Information" state
Status: CLOSED DUPLICATE of bug 224292
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-25 09:18 EST by Matthew Schumacher
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 12:18:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Schumacher 2007-01-25 09:18:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
I have been installing all of the updates as they become available.  I have been able to update using yum, but the graphical interface does not work.  Upon its crash, I was instructed to go to https://bugzilla.redhat.com/bugzilla and file a report.  Although I have seen this problem listed in Bugzilla, I have not seen it listed for the PPC.

I am using a PowerBook G4, 1.33 GHz processor.  I have also noticed this issue on a dual 1 GHz PowerMac G4.

I have attempted to use the rm /var/lib/rpm/__db* and rpm --rebuilddb in the terminal.  This fixed it yesterday night (01/24/2006), but it did not fix it this morning (01/25/2006)

The following dump file was created on my PowerBook G4:
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x10713200>
child: <Element 'packagereq' at 0x10713140>

Version-Release number of selected component (if applicable):
version 1.2.8 Release 1.fc6

How reproducible:
Always


Steps to Reproduce:
1. Launched Software Update
2. Crash occured, giving me the above dump file.
3.

Actual Results:
The following message come up:
Exception Occured

An unhandled exception has occured.  THis is most likely a bug.  Please save the crash dump and file a detailed bug report against Software Updater at https://bugzilla.redhat.com/bugzilla

It then gave the contents of the dump file, as seen above.

Expected Results:
I expected to have a list of updates, or at least a message saying no updates were requried/fould.

Additional info:
Comment 1 Dr. Rob Higgins 2007-01-25 09:37:11 EST
exactly the same exception to software updater and same package info being
retrieved (digikam) on my fc6 i386 or i686 running on an HP AMD 64 live (not
running 64 bit version)
Comment 2 Jacek Piskozub 2007-01-25 10:34:50 EST
One more dup of bug 224292
Comment 3 Peter Pein 2007-01-25 11:41:25 EST
Maybe "genre: optinoal" is not perfectly correc ? ;-)
Comment 4 Dr. Rob Higgins 2007-01-25 11:47:14 EST
same CompsException during update in YUM Extender
Comment 5 Michael Schwendt 2007-01-25 12:18:07 EST

*** This bug has been marked as a duplicate of 224292 ***

Note You need to log in before you can comment on or make changes to this bug.